aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/python.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index fbe91076ac64..c406ce562fa1 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -324,11 +324,13 @@ _PYTHON_TEST_DEP= yes
WARNING+= "PYTHON_DEFAULT must be a version present in PYTHON2_DEFAULT or PYTHON3_DEFAULT, if you want more Python flavors, set BUILD_ALL_PYTHON_FLAVORS in your make.conf"
.endif
-.if ${_PYTHON_ARGS} == "2"
+.if ${_PYTHON_ARGS} == 2.7
+DEV_WARNING+= "lang/python27 reached End of Life and will be removed on 2020-12-31, consider converting to a modern version of python"
+.elif ${_PYTHON_ARGS} == 2
DEV_ERROR+= "USES=python:2 is no longer supported, use USES=python:2.7"
-.elif ${_PYTHON_ARGS} == "3"
+.elif ${_PYTHON_ARGS} == 3
DEV_ERROR+= "USES=python:3 is no longer supported, use USES=python:3.5+ or an appropriate version range"
-.endif # ${_PYTHON_ARGS} == "2"
+.endif # ${_PYTHON_ARGS} == 2.7
_PYTHON_VERSION:= ${PYTHON_DEFAULT}