aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/bmon/Makefile58
-rw-r--r--net/bmon/distinfo4
-rw-r--r--net/bmon/files/patch-out_xml_event.c11
-rw-r--r--net/bmon/files/patch-src__out_db.c11
-rw-r--r--net/bmon/pkg-descr12
-rw-r--r--net/bmon/pkg-plist5
6 files changed, 32 insertions, 69 deletions
diff --git a/net/bmon/Makefile b/net/bmon/Makefile
index 2212fea5213f..3db12a15fd0f 100644
--- a/net/bmon/Makefile
+++ b/net/bmon/Makefile
@@ -2,44 +2,26 @@
# $FreeBSD$
PORTNAME= bmon
-PORTVERSION= 2.1.0
-PORTREVISION= 5
+PORTVERSION= 3.3
CATEGORIES= net
-MASTER_SITES= http://people.suug.ch/~tgr/bmon/files/
-
-MAINTAINER= nistor@snickers.org
-COMMENT= Portable bandwidth monitor and rate estimator
-
-OPTIONS_DEFINE= DBI RRDTOOL
-OPTIONS_DEFAULT= DBI
-DBI_DESC= LibDBI output module for rsyslog
-RRDTOOL_DESC= Usage graphs support
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-USES= gmake
-GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --disable-asound
-MAKEFILE= GNUmakefile
-
-PLIST_FILES= sbin/bmon man/man1/bmon.1.gz
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MRRDTOOL}
-BUILD_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
-.else
-CONFIGURE_ARGS+=--disable-rrd
-.endif
-
-.if ${PORT_OPTIONS:MDBI}
-LIB_DEPENDS= libdbi.so:${PORTSDIR}/databases/libdbi
-.else
-CONFIGURE_ARGS+=--disable-dbi
-.endif
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/bmon ${STAGEDIR}${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/man/bmon.1 ${STAGEDIR}${PREFIX}/man/man1/bmon.1
+
+MAINTAINER= michelle@sorbs.net
+COMMENT= Human-readable bandwidth monitor and rate estimator
+
+LICENSE= MIT
+
+LIB_DEPENDS= libconfuse.so:${PORTSDIR}/devel/libconfuse
+
+CONFLICTS_INSTALL= bmon-*
+
+USE_GITHUB= yes
+GH_ACCOUNT= tgraf
+GH_COMMIT= ad62e66
+GH_TAGNAME= v${PORTVERSION}
+
+USES= ncurses pkgconfig:build
+USE_AUTOTOOLS= libtoolize autoheader automake aclocal
+AUTOMAKE_ARGS+= --add-missing
+GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/net/bmon/distinfo b/net/bmon/distinfo
index 3492817bbc9b..1af5a7422ad8 100644
--- a/net/bmon/distinfo
+++ b/net/bmon/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bmon-2.1.0.tar.gz) = 36a5772fc0241298b15db3dc4fb2552dcbb43edeffd6fcea4cd8818e97ec99fe
-SIZE (bmon-2.1.0.tar.gz) = 270287
+SHA256 (bmon-3.3.tar.gz) = b94e531a00325aaa84a63053b43552ba742b00a377373443f9403826b3cb5c2e
+SIZE (bmon-3.3.tar.gz) = 57352
diff --git a/net/bmon/files/patch-out_xml_event.c b/net/bmon/files/patch-out_xml_event.c
deleted file mode 100644
index b8729730d9c3..000000000000
--- a/net/bmon/files/patch-out_xml_event.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/out_xml_event.c.orig Tue Apr 5 17:01:33 2005
-+++ src/out_xml_event.c Sun Jan 28 14:28:18 2007
-@@ -127,7 +127,7 @@
- .om_draw = xml_event_draw,
- .om_set_opts = xml_event_set_opts,
- .om_probe = xml_event_probe,
-- .om_shutdown xml_event_shutdown,
-+ .om_shutdown = xml_event_shutdown,
- };
-
- static void __init xml_event_init(void)
diff --git a/net/bmon/files/patch-src__out_db.c b/net/bmon/files/patch-src__out_db.c
deleted file mode 100644
index d7caa9d85ae9..000000000000
--- a/net/bmon/files/patch-src__out_db.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/out_db.c.orig 2008-03-24 22:44:47.000000000 -0400
-+++ ./src/out_db.c 2008-03-24 22:45:03.000000000 -0400
-@@ -679,7 +679,7 @@
- .om_draw = db_draw,
- .om_set_opts = db_set_opts,
- .om_probe = db_probe,
-- .om_shutdown db_shutdown,
-+ .om_shutdown = db_shutdown,
- };
-
- static void __init db_init(void)
diff --git a/net/bmon/pkg-descr b/net/bmon/pkg-descr
index 30186f50b112..e1c0cdd51101 100644
--- a/net/bmon/pkg-descr
+++ b/net/bmon/pkg-descr
@@ -1,8 +1,6 @@
-bmon is an interface bandwidth monitor using the curses library.
-It's able to compute and draw three types of diagrams (overview,
-graphical, and detailed). The overview diagram is a list of all
-interfaces including the rx/tx rates of each interface. The
-graphical diagram is a bar graph in ASCII. All diagrams are
-continously updated.
+bmon is a monitoring and debugging tool to capture networking related statistics
+and prepare them visually in a human friendly way. It features various output
+methods including an interactive curses user interface and a programmable text
+output for scripting.
-WWW: http://people.suug.ch/~tgr/bmon/
+WWW: https://github.com/tgraf/bmon
diff --git a/net/bmon/pkg-plist b/net/bmon/pkg-plist
new file mode 100644
index 000000000000..768e9473996e
--- /dev/null
+++ b/net/bmon/pkg-plist
@@ -0,0 +1,5 @@
+bin/bmon
+man/man8/bmon.8.gz
+%%PORTDOCS%%%%DOCSDIR%%/examples/bmon.conf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%