aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/netcdf/Makefile9
-rw-r--r--science/netcdf/files/patch-Makefile20
-rw-r--r--science/netcdf/files/patch-rules.make (renamed from science/netcdf/files/patch-aa)0
-rw-r--r--science/netcdf4/Makefile9
-rw-r--r--science/netcdf4/files/patch-Makefile20
-rw-r--r--science/netcdf4/files/patch-rules.make (renamed from science/netcdf4/files/patch-aa)0
6 files changed, 50 insertions, 8 deletions
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index f4b13d6b36de..0b4465af8dad 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -8,7 +8,8 @@
PORTNAME= netcdf
PORTVERSION= 3.6.1
CATEGORIES= science
-MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/
+MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/ \
+ http://sunpoet.net/distfiles/
MASTER_SITE_SUBDIR= . old
MAINTAINER= sunpoet@sunpoet.net
@@ -18,10 +19,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
CONFLICTS= hdf-4.*
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-fPIC -DPIC -Df2cFortran"
-INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
MAN1= ncdump.1 ncgen.1
MAN3= netcdf.3 netcdf.3f
diff --git a/science/netcdf/files/patch-Makefile b/science/netcdf/files/patch-Makefile
new file mode 100644
index 000000000000..00d94fb843f1
--- /dev/null
+++ b/science/netcdf/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Mon Feb 27 00:43:59 2006
++++ Makefile Sat Dec 23 05:33:43 2006
+@@ -117,6 +117,8 @@
+ ncgen/distclean \
+ cxx/clean \
+ cxx/distclean \
++fortran/install \
++fortran/uninstall \
+ :
+ @subdir=`echo $@ | sed 's,/.*,,'`; \
+ target=`echo $@ | sed 's,.*/,,'`; \
+@@ -124,8 +126,6 @@
+
+ fortran/all \
+ fortran/test \
+-fortran/install \
+-fortran/uninstall \
+ nf_test/all \
+ nf_test/test \
+ :
diff --git a/science/netcdf/files/patch-aa b/science/netcdf/files/patch-rules.make
index 4c9e564dc054..4c9e564dc054 100644
--- a/science/netcdf/files/patch-aa
+++ b/science/netcdf/files/patch-rules.make
diff --git a/science/netcdf4/Makefile b/science/netcdf4/Makefile
index f4b13d6b36de..0b4465af8dad 100644
--- a/science/netcdf4/Makefile
+++ b/science/netcdf4/Makefile
@@ -8,7 +8,8 @@
PORTNAME= netcdf
PORTVERSION= 3.6.1
CATEGORIES= science
-MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/
+MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/netcdf/%SUBDIR%/ \
+ http://sunpoet.net/distfiles/
MASTER_SITE_SUBDIR= . old
MAINTAINER= sunpoet@sunpoet.net
@@ -18,10 +19,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
CONFLICTS= hdf-4.*
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-fPIC -DPIC -Df2cFortran"
-INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
MAN1= ncdump.1 ncgen.1
MAN3= netcdf.3 netcdf.3f
diff --git a/science/netcdf4/files/patch-Makefile b/science/netcdf4/files/patch-Makefile
new file mode 100644
index 000000000000..00d94fb843f1
--- /dev/null
+++ b/science/netcdf4/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Mon Feb 27 00:43:59 2006
++++ Makefile Sat Dec 23 05:33:43 2006
+@@ -117,6 +117,8 @@
+ ncgen/distclean \
+ cxx/clean \
+ cxx/distclean \
++fortran/install \
++fortran/uninstall \
+ :
+ @subdir=`echo $@ | sed 's,/.*,,'`; \
+ target=`echo $@ | sed 's,.*/,,'`; \
+@@ -124,8 +126,6 @@
+
+ fortran/all \
+ fortran/test \
+-fortran/install \
+-fortran/uninstall \
+ nf_test/all \
+ nf_test/test \
+ :
diff --git a/science/netcdf4/files/patch-aa b/science/netcdf4/files/patch-rules.make
index 4c9e564dc054..4c9e564dc054 100644
--- a/science/netcdf4/files/patch-aa
+++ b/science/netcdf4/files/patch-rules.make