aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/clamav/Makefile33
-rw-r--r--security/clamav/distinfo6
-rw-r--r--security/clamav/files/patch-fix_svnversion_use30
-rw-r--r--security/clamav/files/patch-libclamav_Makefile.in27
-rw-r--r--security/clamav/files/patch-libclamav_others.h10
-rw-r--r--security/clamav/pkg-plist10
6 files changed, 62 insertions, 54 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index e42654611ac1..e7aed1d7c5bf 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= clamav
-PORTVERSION= 0.95.3
+DISTVERSION= 0.96
CATEGORIES= security
MASTER_SITES= SF
@@ -26,11 +26,14 @@ OPTIONS= ARC "Enable arch archives support" On \
STDERR "Print logs to stderr instead of stdout" Off \
EXPERIMENTAL "Build experimental code" Off
-GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
-USE_LDCONFIG= yes
-USE_RC_SUBR= clamav-clamd clamav-freshclam
-CONF_FILES= clamd freshclam
+USE_GCC= 4.2+
+USE_PYTHON_BUILD= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
+USE_RC_SUBR= clamav-clamd clamav-freshclam
+CONF_FILES= clamd freshclam
PORTDOCS= *
@@ -49,8 +52,9 @@ CONFIGURE_ARGS= --libdir=${PREFIX}/lib \
--enable-bigstack \
--enable-readdir_r \
--enable-gethostbyname_r \
- --enable-check \
- --disable-dependency-tracking
+ --disable-dependency-tracking \
+ --enable-clamdtop \
+ --enable-llvm
CPPFLAGS+= -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib \
@@ -109,6 +113,17 @@ PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
.include <bsd.port.pre.mk>
+.if ${ARCH} == "i386"
+CFLAGS+= -march=i486
+.endif
+
+.if ${OSVERSION} >= 700000
+BUILD_DEPENDS+= ${LOCALBASE}/include/check.h:${PORTSDIR}/devel/libcheck
+CONFIGURE_ARGS+= --enable-check
+.else
+CONFIGURE_ARGS+= --disable-check
+.endif
+
.if defined(WITH_ARC)
RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
.endif
@@ -175,8 +190,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|0x100000000|0x100000000ULL|g' \
${WRKSRC}/libclamunrar/unrar.c
+.if ${OSVERSION} >= 700000
post-build:
@${MAKE} -C ${WRKSRC} check
+.endif
pre-su-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
diff --git a/security/clamav/distinfo b/security/clamav/distinfo
index 9fd00764bf4f..4af4fa9d0d2b 100644
--- a/security/clamav/distinfo
+++ b/security/clamav/distinfo
@@ -1,3 +1,3 @@
-MD5 (clamav-0.95.3.tar.gz) = eaf9fccc3cc3567605a9732313652967
-SHA256 (clamav-0.95.3.tar.gz) = 003e7a570932fdffbd19fa7a7996274fbfc93f890d26c3066a36eb824c906250
-SIZE (clamav-0.95.3.tar.gz) = 26919541
+MD5 (clamav-0.96.tar.gz) = 28ac7bec4cc03627a8e2d6e8647ee661
+SHA256 (clamav-0.96.tar.gz) = 7b0b6e67c87d43b04ce3beceaecddfaf344499f0ee45e9568df6be16808879d2
+SIZE (clamav-0.96.tar.gz) = 39792593
diff --git a/security/clamav/files/patch-fix_svnversion_use b/security/clamav/files/patch-fix_svnversion_use
new file mode 100644
index 000000000000..d17b9dce7413
--- /dev/null
+++ b/security/clamav/files/patch-fix_svnversion_use
@@ -0,0 +1,30 @@
+diff --git a/libclamav/Makefile.am b/libclamav/Makefile.am
+index 460dd42..aa62b61 100644
+--- libclamav/Makefile.am
++++ libclamav/Makefile.am
+@@ -374,10 +374,7 @@ version.h.tmp:
+ rm -f $@;\
+ REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null || echo "exported")";\
+ if test "$$REVISION" = "exported"; then\
+- REVISION="r$$(LANG=C svnversion "$(top_srcdir)" 2>/dev/null || echo exported)";\
+- if test "$$REVISION" = "rexported"; then\
+ REVISION="";\
+- fi;\
+ fi;\
+ if test -n "$$REVISION"; then\
+ echo "#define REPO_VERSION \"devel-$$REVISION\"" >> $@;\
+diff --git a/libclamav/Makefile.in b/libclamav/Makefile.in
+index ed244c7..f002e21 100644
+--- libclamav/Makefile.in
++++ libclamav/Makefile.in
+@@ -2271,10 +2271,7 @@ version.h.tmp:
+ rm -f $@;\
+ REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null || echo "exported")";\
+ if test "$$REVISION" = "exported"; then\
+- REVISION="r$$(LANG=C svnversion "$(top_srcdir)" 2>/dev/null || echo exported)";\
+- if test "$$REVISION" = "rexported"; then\
+ REVISION="";\
+- fi;\
+ fi;\
+ if test -n "$$REVISION"; then\
+ echo "#define REPO_VERSION \"devel-$$REVISION\"" >> $@;\
diff --git a/security/clamav/files/patch-libclamav_Makefile.in b/security/clamav/files/patch-libclamav_Makefile.in
deleted file mode 100644
index 075327c81003..000000000000
--- a/security/clamav/files/patch-libclamav_Makefile.in
+++ /dev/null
@@ -1,27 +0,0 @@
---- libclamav/Makefile.am
-+++ libclamav/Makefile.am
-@@ -346,8 +346,8 @@ version.h: version.h.tmp
- version.h.tmp:
- @test -f version.h || touch version.h;\
- rm -f $@;\
-- REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null)";\
-- if test $$? -ne 0; then\
-+ REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null || echo "exported")";\
-+ if test "$$REVISION" = "exported"; then\
- REVISION="r$$(LANG=C svnversion "$(top_srcdir)" 2>/dev/null || echo exported)";\
- if test "$$REVISION" = "rexported"; then\
- REVISION="";\
---- libclamav/Makefile.in
-+++ libclamav/Makefile.in
-@@ -2028,8 +2028,8 @@ version.h: version.h.tmp
- version.h.tmp:
- @test -f version.h || touch version.h;\
- rm -f $@;\
-- REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null)";\
-- if test $$? -ne 0; then\
-+ REVISION="$$(LANG=C cd "$(top_srcdir)"; git describe --always 2>/dev/null || echo "exported")";\
-+ if test "$$REVISION" = "exported"; then\
- REVISION="r$$(LANG=C svnversion "$(top_srcdir)" 2>/dev/null || echo exported)";\
- if test "$$REVISION" = "rexported"; then\
- REVISION="";\
-
diff --git a/security/clamav/files/patch-libclamav_others.h b/security/clamav/files/patch-libclamav_others.h
deleted file mode 100644
index 2b5623361676..000000000000
--- a/security/clamav/files/patch-libclamav_others.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- libclamav/others.h.orig 2009-10-29 08:11:34.000000000 -0200
-+++ libclamav/others.h 2009-10-29 08:11:45.000000000 -0200
-@@ -29,6 +29,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <unistd.h>
- #include "cltypes.h"
-
- #include "clamav.h"
diff --git a/security/clamav/pkg-plist b/security/clamav/pkg-plist
index 17e2eda2b91d..0e7d9271e39f 100644
--- a/security/clamav/pkg-plist
+++ b/security/clamav/pkg-plist
@@ -1,5 +1,6 @@
@comment $FreeBSD$
bin/clamav-config
+bin/clambc
bin/clamconf
bin/clamdtop
bin/clamscan
@@ -10,18 +11,15 @@ bin/sigtool
sbin/clamd
include/clamav.h
include/clamav-config.h
-lib/libclamav.a
lib/libclamav.la
lib/libclamav.so
-lib/libclamav.so.6
-%%UNRAR%%lib/libclamunrar.a
+lib/libclamav.so.7
%%UNRAR%%lib/libclamunrar.la
%%UNRAR%%lib/libclamunrar.so
-%%UNRAR%%lib/libclamunrar.so.6
-%%UNRAR%%lib/libclamunrar_iface.a
+%%UNRAR%%lib/libclamunrar.so.7
%%UNRAR%%lib/libclamunrar_iface.la
%%UNRAR%%lib/libclamunrar_iface.so
-%%UNRAR%%lib/libclamunrar_iface.so.6
+%%UNRAR%%lib/libclamunrar_iface.so.7
libdata/pkgconfig/libclamav.pc
@unexec if cmp -s %D/etc/clamd.conf %D/etc/clamd.conf.default; then rm -f %D/etc/clamd.conf; fi
etc/clamd.conf.default