aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING16
-rw-r--r--sysutils/munin-master/Makefile1
-rw-r--r--sysutils/munin-master/files/pkg-message.in10
-rw-r--r--sysutils/munin-master/pkg-install18
-rw-r--r--sysutils/munin-master/pkg-plist2
-rw-r--r--sysutils/munin-node/Makefile1
-rw-r--r--sysutils/munin-node/files/pkg-message.in16
-rw-r--r--sysutils/munin-node/pkg-install18
-rw-r--r--sysutils/munin-node/pkg-plist2
9 files changed, 82 insertions, 2 deletions
diff --git a/UPDATING b/UPDATING
index 2a67c1b27ee8..57fb0a1f598f 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,22 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20181124:
+ AFFECTS: users of sysutils/munin-master, sysutils/munin-node, www/owncloud, mail/mailman, net/ntpa
+ AUTHOR: woodsb02@FreeBSD.org
+
+ The newsyslog.conf(5) filename installed by the port has been changed:
+ OLD: ${PREFIX}/etc/newsyslog.conf.d/${PORTNAME}
+ NEW: ${PREFIX}/etc/newsyslog.conf.d/${PORTNAME}.conf
+
+ Any file found at the old location will be automatically moved to the new
+ location. This will ensure log rotation will continue to work after change
+ r340318 to FreeBSD base, where the default newsyslog configuration now only
+ includes filenames that end with '.conf' and do not begin with '.'.
+
+ If you use provisioning/configuration management tools to create or edit this
+ file, you will need to change their configuration to use the new filename.
+
20181111
AFFECTS: users of graphics/mesa-libs
AUTHOR: jbeich@FreeBSD.org
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index 7fc7d905dbe6..58bc62bae0d1 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -3,6 +3,7 @@
PORTNAME= munin
PORTVERSION= ${MUNIN_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils perl5
MASTER_SITES= ${MUNIN_SITES}
PKGNAMESUFFIX= -master
diff --git a/sysutils/munin-master/files/pkg-message.in b/sysutils/munin-master/files/pkg-message.in
index 0706e6e70962..19bb36b72b06 100644
--- a/sysutils/munin-master/files/pkg-message.in
+++ b/sysutils/munin-master/files/pkg-message.in
@@ -10,3 +10,13 @@ If you need to customize the munin crontab, remove the lines
containing #BEGIN_MUNIN_MAIN and #END_MUNIN_MAIN, and add a line
with #MANUAL_MUNIN_CRONTAB.
********************************************************************
+The munin-master newsyslog.conf(5) filename has been changed:
+ OLD: ${PREFIX}/etc/newsyslog.conf.d/munin-master
+ NEW: ${PREFIX}/etc/newsyslog.conf.d/munin-master.conf
+
+Any file found at the old location has been automatically moved to
+the new location. This was done to ensure log rotation continued to
+work after change r340318 made to FreeBSD base, where the default
+newsyslog configuration now only includes filenames that end with
+'.conf' and do not begin with '.'.
+********************************************************************
diff --git a/sysutils/munin-master/pkg-install b/sysutils/munin-master/pkg-install
index d28f0d6b9d41..9a120494261c 100644
--- a/sysutils/munin-master/pkg-install
+++ b/sysutils/munin-master/pkg-install
@@ -60,6 +60,23 @@ move_www_dir() {
fi
}
+move_newsyslog_conf() {
+ oldfile=${PKG_PREFIX}/etc/newsyslog.conf.d/munin-master
+ newfile=${PKG_PREFIX}/etc/newsyslog.conf.d/munin-master.conf
+ samplefile=${PKG_PREFIX}/etc/munin/munin-master.newsyslog
+ if [ -f ${oldfile} ]; then
+ echo "Configuration file found in old location: ${oldfile}"
+ if cmp -s ${samplefile} ${newfile} > /dev/null; then
+ echo "Configuration file in new location has not been modified from the default: ${newfile}"
+ echo " => Moving old configuration file to new location"
+ mv -f ${oldfile} ${newfile}
+ else
+ echo "Configuration file in new location has been modified from the default: ${newfile}"
+ echo " => Deleting old configuration file"
+ rm ${oldfile}
+ fi
+ fi
+}
########################################################################
@@ -78,5 +95,6 @@ MAILTO=root
#END_MUNIN_MAIN
EOT
fi
+ move_newsyslog_conf
;;
esac
diff --git a/sysutils/munin-master/pkg-plist b/sysutils/munin-master/pkg-plist
index 5ff5f4fdadc5..5b52eb6d3b94 100644
--- a/sysutils/munin-master/pkg-plist
+++ b/sysutils/munin-master/pkg-plist
@@ -37,7 +37,7 @@ bin/munin-cron
@comment BSD.local.dist but if not registered here, it will not exist in PREFIX
@comment when the package is installed.
@dir etc/newsyslog.conf.d
-@sample %%ETCDIR%%/munin-master.newsyslog etc/newsyslog.conf.d/munin-master
+@sample %%ETCDIR%%/munin-master.newsyslog etc/newsyslog.conf.d/munin-master.conf
%%SITE_PERL%%/Munin/Master/Config.pm
%%SITE_PERL%%/Munin/Master/GraphOld.pm
%%SITE_PERL%%/Munin/Master/Group.pm
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index 1d87768dab69..a9afd2465599 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -3,6 +3,7 @@
PORTNAME= munin
PORTVERSION= ${MUNIN_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils perl5
MASTER_SITES= ${MUNIN_SITES}
PKGNAMESUFFIX= -node
diff --git a/sysutils/munin-node/files/pkg-message.in b/sysutils/munin-node/files/pkg-message.in
index 5b92e905035b..b652c5a2ad97 100644
--- a/sysutils/munin-node/files/pkg-message.in
+++ b/sysutils/munin-node/files/pkg-message.in
@@ -24,3 +24,19 @@ For a list of plugins that will probably work run
If this is a fresh install run
%%PREFIX%%/sbin/munin-node-configure --shell | sh -x
to install the plugins automatically
+
+********************************************************************
+The munin-node newsyslog.conf(5) filename has been changed:
+ OLD: ${PREFIX}/etc/newsyslog.conf.d/munin-node
+ NEW: ${PREFIX}/etc/newsyslog.conf.d/munin-node.conf
+
+Any file found at the old location has been automatically moved to
+the new location. This was done to ensure log rotation continued to
+work after change r340318 made to FreeBSD base, where the default
+newsyslog configuration now only includes filenames that end with
+'.conf' and do not begin with '.'.
+
+If you use provisioning/configuration management tools to create or
+edit this file, you will need to change their configuration to use
+the new filename.
+********************************************************************
diff --git a/sysutils/munin-node/pkg-install b/sysutils/munin-node/pkg-install
index dd48b19a7058..71212351548e 100644
--- a/sysutils/munin-node/pkg-install
+++ b/sysutils/munin-node/pkg-install
@@ -12,6 +12,23 @@ init_plugins() {
echo "done."
}
+move_newsyslog_conf() {
+ oldfile=${PKG_PREFIX}/etc/newsyslog.conf.d/munin-node
+ newfile=${PKG_PREFIX}/etc/newsyslog.conf.d/munin-node.conf
+ samplefile=${PKG_PREFIX}/etc/munin/munin-node.newsyslog
+ if [ -f ${oldfile} ]; then
+ echo "Configuration file found in old location: ${oldfile}"
+ if cmp -s ${samplefile} ${newfile} > /dev/null; then
+ echo "Configuration file in new location has not been modified from the default: ${newfile}"
+ echo " => Moving old configuration file to new location"
+ mv -f ${oldfile} ${newfile}
+ else
+ echo "Configuration file in new location has been modified from the default: ${newfile}"
+ echo " => Deleting old configuration file"
+ rm ${oldfile}
+ fi
+ fi
+}
########################################################################
@@ -20,5 +37,6 @@ case $2 in
if [ -z "${PACKAGE_BUILDING}" ]; then
init_plugins
fi
+ move_newsyslog_conf
;;
esac
diff --git a/sysutils/munin-node/pkg-plist b/sysutils/munin-node/pkg-plist
index 31b36fb16ef5..64476e1a466d 100644
--- a/sysutils/munin-node/pkg-plist
+++ b/sysutils/munin-node/pkg-plist
@@ -6,7 +6,7 @@ bin/munindoc
@comment BSD.local.dist but if not registered here, it will not exist in PREFIX
@comment when the package is installed.
@dir etc/newsyslog.conf.d
-@sample %%ETCDIR%%/munin-node.newsyslog etc/newsyslog.conf.d/munin-node
+@sample %%ETCDIR%%/munin-node.newsyslog etc/newsyslog.conf.d/munin-node.conf
%%SITE_PERL%%/Munin/Node/Config.pm
%%SITE_PERL%%/Munin/Node/Configure/Debug.pm
%%SITE_PERL%%/Munin/Node/Configure/History.pm