aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-OOTools/Makefile32
-rw-r--r--devel/p5-OOTools/distinfo2
-rw-r--r--devel/p5-OOTools/pkg-descr12
-rw-r--r--devel/p5-OOTools/pkg-plist9
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2fee54fe805f..055276551cfa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -853,6 +853,7 @@
SUBDIR += p5-NEXT
SUBDIR += p5-Net-LibIDN
SUBDIR += p5-OLE-Storage_Lite
+ SUBDIR += p5-OOTools
SUBDIR += p5-ORBit
SUBDIR += p5-Object-MultiType
SUBDIR += p5-Object-Realize-Later
diff --git a/devel/p5-OOTools/Makefile b/devel/p5-OOTools/Makefile
new file mode 100644
index 000000000000..07172b6b412a
--- /dev/null
+++ b/devel/p5-OOTools/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: OOTools
+# Date created: July 22 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= OOTools
+PORTVERSION= 1.75
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/D/DO/DOMIZIO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= A Perl module collection to easily create constructors methods
+
+PERL_CONFIGURE= YES
+
+MAN3= Class::constr.3 \
+ Class::groups.3 \
+ Class::props.3 \
+ Object::groups.3 \
+ Object::props.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.1 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-OOTools/distinfo b/devel/p5-OOTools/distinfo
new file mode 100644
index 000000000000..6bcc46201799
--- /dev/null
+++ b/devel/p5-OOTools/distinfo
@@ -0,0 +1,2 @@
+MD5 (OOTools-1.75.tar.gz) = bc8bf4a42e6bd8d78ee71e759955cf96
+SIZE (OOTools-1.75.tar.gz) = 12540
diff --git a/devel/p5-OOTools/pkg-descr b/devel/p5-OOTools/pkg-descr
new file mode 100644
index 000000000000..7de246cf388c
--- /dev/null
+++ b/devel/p5-OOTools/pkg-descr
@@ -0,0 +1,12 @@
+OOTools is a collection of pragmas to easily create constructors methods and
+lvalue accessor methods at compile time. OOTools distribution includes:
+
+Class::constr Pragma to implement constructor methods
+Class::props Pragma to implement lvalue accessors with options
+Class::group Pragma to implement group of properties accessors with options
+Object::props Pragma to implement lvalue accessors with options
+Object::group Pragma to implement group of properties accessors with options
+
+WWW: http://search.cpan.org/~domizio/OOTools/
+
+Author: Domizio Demichelis <dd@4pro.net>
diff --git a/devel/p5-OOTools/pkg-plist b/devel/p5-OOTools/pkg-plist
new file mode 100644
index 000000000000..fdfb62ebd87f
--- /dev/null
+++ b/devel/p5-OOTools/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Class/props.pm
+%%SITE_PERL%%/Class/constr.pm
+%%SITE_PERL%%/Class/groups.pm
+%%SITE_PERL%%/Object/groups.pm
+%%SITE_PERL%%/Object/props.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OOTools/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/OOTools
+@unexec rmdir %D/%%SITE_PERL%%/Class 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Object 2>/dev/null || true