aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/cargo.mk2
-rw-r--r--Mk/bsd.port.mk5
-rw-r--r--UPDATING11
-rw-r--r--databases/qdbm-plus/Makefile2
-rw-r--r--databases/qdbm/Makefile2
-rw-r--r--math/msieve/Makefile2
-rw-r--r--multimedia/vlc/Makefile2
-rw-r--r--net/linphone/Makefile2
-rw-r--r--net/mediastreamer/Makefile2
-rw-r--r--ports-mgmt/pkg/Makefile2
-rw-r--r--security/putty/Makefile2
11 files changed, 24 insertions, 10 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index 1037df26792b..87d1d9b22e69 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -103,7 +103,7 @@ CARGO_INSTALL_ARGS+= --features='${CARGO_FEATURES}'
CARGO_TEST_ARGS+= --features='${CARGO_FEATURES}'
.endif
-.if !defined(WITH_DEBUG) || defined(WITHOUT_DEBUG)
+.if !defined(WITH_DEBUG)
CARGO_BUILD_ARGS+= --release
CARGO_TEST_ARGS+= --release
.else
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 440b9eaec9ec..f22f2091fb1f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -337,6 +337,9 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# passed to the compiler by setting DEBUG_FLAGS. It is
# set to "-g" at default.
#
+# NOTE: to override a globally defined WITH_DEBUG at a
+# later time ".undef WITH_DEBUG" can be used
+#
# WITH_DEBUG_PORTS - A list of origins for which WITH_DEBUG will be set
#
# WITHOUT_SSP - Disable SSP.
@@ -1681,7 +1684,7 @@ CFLAGS:= ${CFLAGS:C/${_CPUCFLAGS}//}
.endif
# Reset value from bsd.own.mk.
-.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+.if defined(WITH_DEBUG)
.if !defined(INSTALL_STRIPPED)
STRIP= #none
MAKE_ENV+= DONTSTRIP=yes
diff --git a/UPDATING b/UPDATING
index 70a2d0acd5f8..460df830beeb 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,17 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20171015:
+ AFFECTS: people using WITHOUT_DEBUG
+ AUTHOR: madpilot@FreeBSD.org
+
+ The WITHOUT_DEBUG flag has been retired. It's only purpose was
+ to override a global WITH_DEBUG, if that was defined, but many
+ ports were ignoring such flag even if honouring WITH_DEBUG.
+
+ The same effect can be obtained using ".undef WITH_DEBUG" without
+ any special support in port Makefiles.
+
20171012:
AFFECTS: users of security/openssh-portable
AUTHOR: bdrewery@FreeBSD.org
diff --git a/databases/qdbm-plus/Makefile b/databases/qdbm-plus/Makefile
index a8a959af2135..228e68e51a76 100644
--- a/databases/qdbm-plus/Makefile
+++ b/databases/qdbm-plus/Makefile
@@ -27,7 +27,7 @@ CXXFLAGS+= -fsigned-char -fPIC
INSTALL_TARGET= install-strip
post-patch:
-.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+.if defined(WITH_DEBUG)
@${REINPLACE_CMD} 's/-DNDEBUG//' ${WRKSRC}/Makefile.in
.endif
diff --git a/databases/qdbm/Makefile b/databases/qdbm/Makefile
index 3137fe56d9eb..ef61b24c306a 100644
--- a/databases/qdbm/Makefile
+++ b/databases/qdbm/Makefile
@@ -30,7 +30,7 @@ INSTALL_TARGET= install-strip
PORTDOCS= ChangeLog NEWS
post-patch:
-.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+.if defined(WITH_DEBUG)
@${REINPLACE_CMD} 's/-DNDEBUG//' ${WRKSRC}/Makefile.in
.endif
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index ab86090d7197..bb8a00a7ad11 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -28,7 +28,7 @@ OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -O3 -ffast-math
-.if defined(WITHOUT_DEBUG) || !defined(WITH_DEBUG)
+.if !defined(WITH_DEBUG)
CFLAGS+= -fomit-frame-pointer -DNDEBUG
.endif
.endif
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 5c2e4bde021a..0fa22507a093 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -54,7 +54,7 @@ CONFIGURE_ARGS= --enable-avcodec --enable-avformat --enable-dvbpsi \
--disable-wasapi --disable-x26410b \
--with-kde-solid=${PREFIX}/share/apps/solid/actions \
ac_cv_search_pthread_rwlock_init=-pthread
-.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=--enable-debug
.endif
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index 69d603078134..78f53fd604d9 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -55,7 +55,7 @@ UPNP_LIB_DEPENDS= libupnp.so:devel/upnp
VIDEO_CONFIGURE_ENABLE= video
-.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=--enable-debug
.endif
diff --git a/net/mediastreamer/Makefile b/net/mediastreamer/Makefile
index 07333e30458b..2cef810ad48d 100644
--- a/net/mediastreamer/Makefile
+++ b/net/mediastreamer/Makefile
@@ -84,7 +84,7 @@ VPX_LIB_DEPENDS= libvpx.so:multimedia/libvpx
XVIDEO_CONFIGURE_ENABLE=x11 xv
XVIDEO_USE= XORG=videoproto,x11,xv
-.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=--enable-debug
.endif
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index dc8d63c44fd3..36bbf57635ba 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -33,7 +33,7 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-docs_pkg.8
.include <bsd.port.pre.mk>
-.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+.if defined(WITH_DEBUG)
MAKE_ARGS+= DEBUG_FLAGS="${DEBUG_FLAGS}"
.endif
diff --git a/security/putty/Makefile b/security/putty/Makefile
index 338deffb7b63..9a25d9aeec73 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -72,7 +72,7 @@ _COMPAT= -DNO_GSSAPI
_COMPAT+= -DOMIT_UTMP
-.if defined(WITH_DEBUG) && ${WITH_DEBUG} != "no"
+.if defined(WITH_DEBUG)
XFLAGS= -DDEBUG
.endif