aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/gohugo/Makefile80
-rw-r--r--www/gohugo/distinfo58
2 files changed, 62 insertions, 76 deletions
diff --git a/www/gohugo/Makefile b/www/gohugo/Makefile
index ceeb7b5939f2..42ebf766d0e1 100644
--- a/www/gohugo/Makefile
+++ b/www/gohugo/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= hugo
-PORTVERSION= 0.22.1
+PORTVERSION= 0.24.1
DISTVERSIONPREFIX= v
CATEGORIES= www
PKGNAMEPREFIX= go
@@ -12,20 +12,19 @@ COMMENT= Fast and modern static website engine
LICENSE= APACHE20
-BUILD_DEPENDS= go>=1.8.0:lang/go
-
+USES= go
USE_GITHUB= yes
-GH_ACCOUNT= spf13
+GH_ACCOUNT= gohugoio
GH_SUBDIR= src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}
-GH_TUPLE= BurntSushi:toml:b26d9c3:toml/src/github.com/BurntSushi/toml \
+GH_TUPLE= BurntSushi:toml:8fb9fdc:toml/src/github.com/BurntSushi/toml \
PuerkitoBio:purell:b938d81:purell/src/github.com/PuerkitoBio/purell \
PuerkitoBio:urlesc:bbf7a2a:urlesc/src/github.com/PuerkitoBio/urlesc \
- bep:gitmap:dcb907b:gitmap/src/github.com/bep/gitmap \
+ bep:gitmap:de8030e:gitmap/src/github.com/bep/gitmap \
bep:inflect:b896c45:inflect/src/github.com/bep/inflect \
chaseadamsio:goorgeous:677defd:goorgeous/src/github.com/chaseadamsio/goorgeous \
- cpuguy83:go-md2man:bcc0a71:go_md2man/src/github.com/cpuguy83/go-md2man \
+ cpuguy83:go-md2man:23709d0:go_md2man/src/github.com/cpuguy83/go-md2man \
dchest:cssmin:fb8d9b4:cssmin/src/github.com/dchest/cssmin \
- eknkc:amber:f0d8fdb:amber/src/github.com/eknkc/amber \
+ eknkc:amber:5fa7895:amber/src/github.com/eknkc/amber \
fortytw2:leaktest:7dad533:leaktest/src/github.com/fortytw2/leaktest \
fsnotify:fsnotify:4da3e2c:fsnotify/src/github.com/fsnotify/fsnotify \
gorilla:websocket:a91eba7:websocket/src/github.com/gorilla/websocket \
@@ -41,39 +40,49 @@ GH_TUPLE= BurntSushi:toml:b26d9c3:toml/src/github.com/BurntSushi/toml \
mitchellh:mapstructure:d0303fe:mapstructure/src/github.com/mitchellh/mapstructure \
nicksnyder:go-i18n:3e70a1a:go_i18n/src/github.com/nicksnyder/go-i18n \
pelletier:go-buffruneio:c37440a:go_buffruneio/src/github.com/pelletier/go-buffruneio \
- pelletier:go-toml:26ae43f:go_toml/src/github.com/pelletier/go-toml \
+ pelletier:go-toml:fe7536c:go_toml/src/github.com/pelletier/go-toml \
pkg:errors:c605e28:errors/src/github.com/pkg/errors \
pkg:sftp:a5f8514:sftp/src/github.com/pkg/sftp \
- russross:blackfriday:0ba0f2b:blackfriday/src/github.com/russross/blackfriday \
+ russross:blackfriday:067529f:blackfriday/src/github.com/russross/blackfriday \
shurcooL:sanitized_anchor_name:541ff5e:sanitized_anchor_name/src/github.com/shurcooL/sanitized_anchor_name \
spf13:afero:9be6508:afero/src/github.com/spf13/afero \
spf13:cast:acbeb36:cast/src/github.com/spf13/cast \
- spf13:cobra:ca57f0f:cobra/src/github.com/spf13/cobra \
+ spf13:cobra:b4dbd37:cobra/src/github.com/spf13/cobra \
spf13:fsync:12a01e6:fsync/src/github.com/spf13/fsync \
spf13:jWalterWeatherman:0efa520:jWalterWeatherman/src/github.com/spf13/jwalterweatherman \
spf13:nitro:24d7ef3:nitro/src/github.com/spf13/nitro \
spf13:pflag:e57e3ee:pflag/src/github.com/spf13/pflag \
- spf13:viper:0967fc9:viper/src/github.com/spf13/viper \
- stretchr:testify:4d4bfba:testify/src/github.com/stretchr/testify \
+ spf13:viper:c1de958:viper/src/github.com/spf13/viper \
+ stretchr:testify:f6abca5:testify/src/github.com/stretchr/testify \
yosssi:ace:ea038f4:ace/src/github.com/yosssi/ace \
- golang:crypto:7e91053:crypto/src/golang.org/x/crypto \
- golang:net:5961165:net/src/golang.org/x/net \
- golang:sys:dbc2be9:sys/src/golang.org/x/sys \
- golang:text:19e5161:text/src/golang.org/x/text \
+ golang:crypto:850760c:crypto/src/golang.org/x/crypto \
+ golang:net:ddf80d0:net/src/golang.org/x/net \
+ golang:sys:fb4cac3:sys/src/golang.org/x/sys \
+ golang:text:9e2f80a:text/src/golang.org/x/text \
go-yaml:yaml:cd8b52f:yaml/src/gopkg.in/yaml.v2 \
davecgh:go-spew:04cdfd4:go_spew/src/github.com/davecgh/go-spew \
pmezard:go-difflib:d8ed262:go_difflib/src/github.com/pmezard/go-difflib
-OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT= MANPAGES
+OPTIONS_SUB= MANPAGES
+
MANPAGES_DESC= Build and/or install manual pages
-OPTIONS_SUB= MANPAGES
-OPTIONS_DEFAULT= MANPAGES
+GOENV= GOPATH=${WRKSRC} CGO_CFLAGS="${CGO_CFLAGS}" \
+ CGO_LDFLAGS="${CGO_LDFLAGS}" GOBIN=""
-STRIP= # stripping can break go binaries
+PORTMANS= hugo-benchmark.1 hugo-config.1 hugo-convert-toJSON.1 \
+ hugo-convert-toTOML.1 hugo-convert-toYAML.1 hugo-convert.1 \
+ hugo-env.1 hugo-gen-autocomplete.1 hugo-gen-doc.1 hugo-gen-man.1 \
+ hugo-gen.1 hugo-import-jekyll.1 hugo-import.1 hugo-list-drafts.1 \
+ hugo-list-expired.1 hugo-list-future.1 hugo-list.1 hugo-new-site.1 \
+ hugo-new-theme.1 hugo-new.1 hugo-server.1 hugo-undraft.1 \
+ hugo-version.1 hugo.1
do-build:
- @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME} && ${SETENV} GOPATH=${WRKSRC} go build -o bin/${PORTNAME}
+ @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME} && \
+ ${SETENV} ${MAKE_ENV} ${GOENV} ${GO_CMD} build -o bin/${PORTNAME}
do-build-MANPAGES-on:
@cd ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME} && ./bin/${PORTNAME} gen man --dir man/man1/
@@ -82,31 +91,8 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}/bin/${PORTNAME} ${STAGEDIR}/${PREFIX}/bin/${PORTNAME}
do-install-MANPAGES-on:
-.for i in hugo-benchmark.1 \
- hugo-config.1 \
- hugo-convert-toJSON.1 \
- hugo-convert-toTOML.1 \
- hugo-convert-toYAML.1 \
- hugo-convert.1 \
- hugo-env.1 \
- hugo-gen-autocomplete.1 \
- hugo-gen-doc.1 \
- hugo-gen-man.1 \
- hugo-gen.1 \
- hugo-import-jekyll.1 \
- hugo-import.1 \
- hugo-list-drafts.1 \
- hugo-list-expired.1 \
- hugo-list-future.1 \
- hugo-list.1 \
- hugo-new-site.1 \
- hugo-new-theme.1 \
- hugo-new.1 \
- hugo-server.1 \
- hugo-undraft.1 \
- hugo-version.1 \
- hugo.1
- ${INSTALL_MAN} ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}/man/man1/$i ${STAGEDIR}/${PREFIX}/man/man1
+.for i in ${PORTMANS}
+ ${INSTALL_MAN} ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}/man/man1/$i ${STAGEDIR}/${PREFIX}/man/man1
.endfor
.include <bsd.port.mk>
diff --git a/www/gohugo/distinfo b/www/gohugo/distinfo
index 7e9f16b40e75..af61f5b78f2f 100644
--- a/www/gohugo/distinfo
+++ b/www/gohugo/distinfo
@@ -1,24 +1,24 @@
-TIMESTAMP = 1497385590
-SHA256 (gohugo/spf13-hugo-v0.22.1_GH0.tar.gz) = cb7b5a653595e0c19f4509c15cd18a3d64df53689e6c028bdd9dfef74a4414ce
-SIZE (gohugo/spf13-hugo-v0.22.1_GH0.tar.gz) = 10740947
-SHA256 (gohugo/BurntSushi-toml-b26d9c3_GH0.tar.gz) = 9a822907202320fc6e49635c0b0e5efe455db3c8023e0e0903ca2a359d1f1f82
-SIZE (gohugo/BurntSushi-toml-b26d9c3_GH0.tar.gz) = 41562
+TIMESTAMP = 1498387605
+SHA256 (gohugo/gohugoio-hugo-v0.24.1_GH0.tar.gz) = c7a5d56b528dde7c8a12044f7ede1f9d8c1c8401969ebef9a11695d00f8d3d55
+SIZE (gohugo/gohugoio-hugo-v0.24.1_GH0.tar.gz) = 1103602
+SHA256 (gohugo/BurntSushi-toml-8fb9fdc_GH0.tar.gz) = 65f0d8182f1bdebcd52a40dd51a6ef2071b3f08aff6de98b7fc69dd5e4bb7436
+SIZE (gohugo/BurntSushi-toml-8fb9fdc_GH0.tar.gz) = 41610
SHA256 (gohugo/PuerkitoBio-purell-b938d81_GH0.tar.gz) = b10cdc245094af0100616b8ea71cb68658b3dd29ce8fc32d0b956e1508288067
SIZE (gohugo/PuerkitoBio-purell-b938d81_GH0.tar.gz) = 11658
SHA256 (gohugo/PuerkitoBio-urlesc-bbf7a2a_GH0.tar.gz) = fd91f9ffc347499c37eb5e44a5891a4743b4508453f04c2369228a51e0cf80c6
SIZE (gohugo/PuerkitoBio-urlesc-bbf7a2a_GH0.tar.gz) = 6797
-SHA256 (gohugo/bep-gitmap-dcb907b_GH0.tar.gz) = a5135d26ca92bbf67bb1a1ad72ed88e1724d52ebe5446004a044ea009f1a1a60
-SIZE (gohugo/bep-gitmap-dcb907b_GH0.tar.gz) = 4458
+SHA256 (gohugo/bep-gitmap-de8030e_GH0.tar.gz) = c418e80c4ca2cce9199d36d7c36f940a1768a1caa0003d0a4aad3be02562111e
+SIZE (gohugo/bep-gitmap-de8030e_GH0.tar.gz) = 4489
SHA256 (gohugo/bep-inflect-b896c45_GH0.tar.gz) = 11918dab4c6b5f81a40830259cacec50b4d671e08a634a24da292040718211ee
SIZE (gohugo/bep-inflect-b896c45_GH0.tar.gz) = 9661
SHA256 (gohugo/chaseadamsio-goorgeous-677defd_GH0.tar.gz) = 5f98a67899cb89d790a6640bdd335eee7028c7cd77d6d0297d2ace40c143cedc
SIZE (gohugo/chaseadamsio-goorgeous-677defd_GH0.tar.gz) = 32908
-SHA256 (gohugo/cpuguy83-go-md2man-bcc0a71_GH0.tar.gz) = 096afc7a3cb68fc2c495dcd664e5749c32a4e501cb88fd8610fcd3a26660d921
-SIZE (gohugo/cpuguy83-go-md2man-bcc0a71_GH0.tar.gz) = 40354
+SHA256 (gohugo/cpuguy83-go-md2man-23709d0_GH0.tar.gz) = 890d40e3e9634ac9992d1578c89c41c3b8c462c8f562c1b9e4d71972fc50fe01
+SIZE (gohugo/cpuguy83-go-md2man-23709d0_GH0.tar.gz) = 40861
SHA256 (gohugo/dchest-cssmin-fb8d9b4_GH0.tar.gz) = fce78d1a1de9f9e516c24cd38856034f23fce22807ecb3c9566c383602109417
SIZE (gohugo/dchest-cssmin-fb8d9b4_GH0.tar.gz) = 3354
-SHA256 (gohugo/eknkc-amber-f0d8fdb_GH0.tar.gz) = 8bed0742837f23431c4a57f44db01c0521f49fa46bc074d7af1e7152409bd83f
-SIZE (gohugo/eknkc-amber-f0d8fdb_GH0.tar.gz) = 21955
+SHA256 (gohugo/eknkc-amber-5fa7895_GH0.tar.gz) = 2886a0888302f035b7b3513be3cd8995aa53d53e54329f64e27d8a32ac464944
+SIZE (gohugo/eknkc-amber-5fa7895_GH0.tar.gz) = 21963
SHA256 (gohugo/fortytw2-leaktest-7dad533_GH0.tar.gz) = b732d88c9f7c475d4282d96812cb49726cbc736603bc5e1aeda5062be75838f3
SIZE (gohugo/fortytw2-leaktest-7dad533_GH0.tar.gz) = 3677
SHA256 (gohugo/fsnotify-fsnotify-4da3e2c_GH0.tar.gz) = 0134c6c5617a87ba737ca3a136de027800595cf91b32b1b3901f97b8c85c156a
@@ -49,22 +49,22 @@ SHA256 (gohugo/nicksnyder-go-i18n-3e70a1a_GH0.tar.gz) = c98c71d6db47877c7bc532c3
SIZE (gohugo/nicksnyder-go-i18n-3e70a1a_GH0.tar.gz) = 39646
SHA256 (gohugo/pelletier-go-buffruneio-c37440a_GH0.tar.gz) = d2bdcd763e33d9bdda4058b10dc2b4fc25aeb1b752b7e1bb9b4713dc06e24af4
SIZE (gohugo/pelletier-go-buffruneio-c37440a_GH0.tar.gz) = 3027
-SHA256 (gohugo/pelletier-go-toml-26ae43f_GH0.tar.gz) = f9874b4267d8f0e036ab7077c3f2af6d94dff27080c0b023a39197f79617a67f
-SIZE (gohugo/pelletier-go-toml-26ae43f_GH0.tar.gz) = 47494
+SHA256 (gohugo/pelletier-go-toml-fe7536c_GH0.tar.gz) = 4ad9773a409dcb4f057b730e629820a7f33c69f0501abc1481bbd22ee4fcfbc7
+SIZE (gohugo/pelletier-go-toml-fe7536c_GH0.tar.gz) = 48266
SHA256 (gohugo/pkg-errors-c605e28_GH0.tar.gz) = 06fa83babc1d9aa80b0decb6d36504090bbde8a38d9a722a1f7a26616590a0d0
SIZE (gohugo/pkg-errors-c605e28_GH0.tar.gz) = 11476
SHA256 (gohugo/pkg-sftp-a5f8514_GH0.tar.gz) = 3842786f442f0cab46a255a277dd77bae0a21538189b269e693e8160f6d8d72e
SIZE (gohugo/pkg-sftp-a5f8514_GH0.tar.gz) = 59467
-SHA256 (gohugo/russross-blackfriday-0ba0f2b_GH0.tar.gz) = 23c7c51647ce253607c4c3ab3e19ad177bf45b042280fd3a7b75678005370c83
-SIZE (gohugo/russross-blackfriday-0ba0f2b_GH0.tar.gz) = 73534
+SHA256 (gohugo/russross-blackfriday-067529f_GH0.tar.gz) = dbbdb9b4e9754a549e98283563ffe18eb9d8e1c131a1ed97323a4110adff44ad
+SIZE (gohugo/russross-blackfriday-067529f_GH0.tar.gz) = 73858
SHA256 (gohugo/shurcooL-sanitized_anchor_name-541ff5e_GH0.tar.gz) = b1ca801fa24eaa938d0a26cc4d77e1da74afb3d4a091475a2660cb977b7c8f54
SIZE (gohugo/shurcooL-sanitized_anchor_name-541ff5e_GH0.tar.gz) = 2063
SHA256 (gohugo/spf13-afero-9be6508_GH0.tar.gz) = 6814d3c2e2c55540cbc190def53324924cf44b06ac4ec39b4cb09c3416a5dcb5
SIZE (gohugo/spf13-afero-9be6508_GH0.tar.gz) = 40630
SHA256 (gohugo/spf13-cast-acbeb36_GH0.tar.gz) = 403d9ba0ea7655ad375cf31e9ff1fece4425b3795fc47eb86e824ab6ac6ef620
SIZE (gohugo/spf13-cast-acbeb36_GH0.tar.gz) = 9588
-SHA256 (gohugo/spf13-cobra-ca57f0f_GH0.tar.gz) = a7046d354f82b36200980441efae97ad88dcf9dd0791efcf42c65e9c570ccc9f
-SIZE (gohugo/spf13-cobra-ca57f0f_GH0.tar.gz) = 96573
+SHA256 (gohugo/spf13-cobra-b4dbd37_GH0.tar.gz) = 1122eed69295450848f7dfd14017bd417db51af4c1fd9a60727b0c94a7dece09
+SIZE (gohugo/spf13-cobra-b4dbd37_GH0.tar.gz) = 96950
SHA256 (gohugo/spf13-fsync-12a01e6_GH0.tar.gz) = f3d5520a8dba6d57618db9a869abeb23f349ec20c177f5fa8957588bb987e0aa
SIZE (gohugo/spf13-fsync-12a01e6_GH0.tar.gz) = 4840
SHA256 (gohugo/spf13-jWalterWeatherman-0efa520_GH0.tar.gz) = 30724b69b0975bd29ee722fb46bb2ad332f0648194c40d6edddccd660db5ed9b
@@ -73,20 +73,20 @@ SHA256 (gohugo/spf13-nitro-24d7ef3_GH0.tar.gz) = e64c8d195990c3aa57c47cc4f090b1f
SIZE (gohugo/spf13-nitro-24d7ef3_GH0.tar.gz) = 6741
SHA256 (gohugo/spf13-pflag-e57e3ee_GH0.tar.gz) = 16556b4873f12211cffec75aa4d3a6332efa26e64ff0476fdbd99f672ca37d51
SIZE (gohugo/spf13-pflag-e57e3ee_GH0.tar.gz) = 38998
-SHA256 (gohugo/spf13-viper-0967fc9_GH0.tar.gz) = 29aa393a01b5e899b1f72709349661120a2030e0741b6db4a91f10bb9c36badd
-SIZE (gohugo/spf13-viper-0967fc9_GH0.tar.gz) = 30669
-SHA256 (gohugo/stretchr-testify-4d4bfba_GH0.tar.gz) = 071fd64d54b7f863b92c1b7504c95744f0cbb1f3aa449e9c33d58c02063d6702
-SIZE (gohugo/stretchr-testify-4d4bfba_GH0.tar.gz) = 85617
+SHA256 (gohugo/spf13-viper-c1de958_GH0.tar.gz) = f8b1b751dd9133cadac7225061a5b8a3437ba0e3d75fa6289a1a29f43f03c820
+SIZE (gohugo/spf13-viper-c1de958_GH0.tar.gz) = 30664
+SHA256 (gohugo/stretchr-testify-f6abca5_GH0.tar.gz) = c254665dbd1a155475dc685ca58bfae991c78e672c4dc6707fd3c1973724cf9f
+SIZE (gohugo/stretchr-testify-f6abca5_GH0.tar.gz) = 94085
SHA256 (gohugo/yosssi-ace-ea038f4_GH0.tar.gz) = 0d8da272af4618613b62f6f28fff6142d285c70de0658b8c328f588a690e4b85
SIZE (gohugo/yosssi-ace-ea038f4_GH0.tar.gz) = 23269
-SHA256 (gohugo/golang-crypto-7e91053_GH0.tar.gz) = 10a7cbc5f6fedffb9fd51b6b5609eb5f625cff83ffd4b55cb473f57151ce3290
-SIZE (gohugo/golang-crypto-7e91053_GH0.tar.gz) = 1336460
-SHA256 (gohugo/golang-net-5961165_GH0.tar.gz) = 33b19437b6ed80a5e9895523e62d89207e85780e4a2b3e81d8bcf23599849251
-SIZE (gohugo/golang-net-5961165_GH0.tar.gz) = 885513
-SHA256 (gohugo/golang-sys-dbc2be9_GH0.tar.gz) = 4bdeba7b679561aeb6362c6d8ec6a5d3d855b2da98343065ba0f47eb4e970bfa
-SIZE (gohugo/golang-sys-dbc2be9_GH0.tar.gz) = 713183
-SHA256 (gohugo/golang-text-19e5161_GH0.tar.gz) = 05e0c53b51e833c700312b9fa259fbddb66712669a26aaae9747c218869b0d58
-SIZE (gohugo/golang-text-19e5161_GH0.tar.gz) = 4551121
+SHA256 (gohugo/golang-crypto-850760c_GH0.tar.gz) = 74642f7b77a90eecadb5bf991dfbc904d4d47ac41a6ca429e9ae4c725a2a0c3b
+SIZE (gohugo/golang-crypto-850760c_GH0.tar.gz) = 1342005
+SHA256 (gohugo/golang-net-ddf80d0_GH0.tar.gz) = 2078d7f9af052dbf8f25891fcc1ccfef977203c3d3f04546acb87f2988f48efb
+SIZE (gohugo/golang-net-ddf80d0_GH0.tar.gz) = 906236
+SHA256 (gohugo/golang-sys-fb4cac3_GH0.tar.gz) = ac1a0f4779ba3938f6ceedb247e6ca3f7b7d36a71c7fb39763385f97c4ccddae
+SIZE (gohugo/golang-sys-fb4cac3_GH0.tar.gz) = 716814
+SHA256 (gohugo/golang-text-9e2f80a_GH0.tar.gz) = a43eb0b61642e1127997cc2bbc80b56475fe58459e1ee2012627dc841cda503f
+SIZE (gohugo/golang-text-9e2f80a_GH0.tar.gz) = 4578976
SHA256 (gohugo/go-yaml-yaml-cd8b52f_GH0.tar.gz) = b1c9f89593f27734ba7fe9cf8573bac332641e59d7cfe17383db1572960913b6
SIZE (gohugo/go-yaml-yaml-cd8b52f_GH0.tar.gz) = 60718
SHA256 (gohugo/davecgh-go-spew-04cdfd4_GH0.tar.gz) = 4347d25b61ad89e85d86d3df33539578254e57078fa0acbfb93c5bc393d0175d