aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/fprint_demo/Makefile9
-rw-r--r--security/gnutls-devel/Makefile10
-rw-r--r--security/gsasl/Makefile5
-rw-r--r--security/gss/Makefile11
-rw-r--r--security/heimdal/Makefile3
-rw-r--r--security/hydra/Makefile5
-rw-r--r--security/libfprint/Makefile3
-rw-r--r--security/libp11/Makefile3
-rw-r--r--security/opencdk/Makefile3
-rw-r--r--security/openct/Makefile3
-rw-r--r--security/pam_fprint/Makefile8
-rw-r--r--security/pam_p11/Makefile8
-rw-r--r--security/pkcs11-helper/Makefile2
-rw-r--r--security/snort/Makefile2
-rw-r--r--security/sssd/Makefile4
15 files changed, 29 insertions, 50 deletions
diff --git a/security/fprint_demo/Makefile b/security/fprint_demo/Makefile
index d63a97d9ac3e..a660e0b77573 100644
--- a/security/fprint_demo/Makefile
+++ b/security/fprint_demo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fprint_demo
-# Date created: April 12 2008
-# Whom: barner
-#
+# Created by: barner
# $FreeBSD$
-#
PORTNAME= fprint_demo
PORTVERSION= 20080303
@@ -21,7 +17,8 @@ LIB_DEPENDS= fprint:${PORTSDIR}/security/libfprint
USE_AUTOTOOLS= autoconf automake
AUTOMAKE_ARGS= -a
GNU_CONFIGURE= yes
-USE_GNOME= atk glib20 gtk20 pango pkgconfig
+USES= pkgconfig
+USE_GNOME= atk glib20 gtk20 pango
INSTALLS_ICONS= yes
WRKSRC= ${WRKDIR}
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
index 0eb89c8b41eb..ed54c4becc07 100644
--- a/security/gnutls-devel/Makefile
+++ b/security/gnutls-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gnutls-devel
-# Date created: 8 Jan 2009
-# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
-#
+# Created by: Roman Bogorodskiy <novel@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gnutls
PORTVERSION= 2.99.4
@@ -23,8 +19,8 @@ LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error \
CONFLICTS= gnutls-[0-9]*
USE_XZ= yes
-USES= iconv
-USE_GNOME= pkgconfig ltverhack
+USES= iconv pkgconfig
+USE_GNOME= ltverhack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
diff --git a/security/gsasl/Makefile b/security/gsasl/Makefile
index 941283a69581..80928c825b3a 100644
--- a/security/gsasl/Makefile
+++ b/security/gsasl/Makefile
@@ -16,9 +16,8 @@ LIB_DEPENDS= idn.17:${PORTSDIR}/dns/libidn \
gnutls.26:${PORTSDIR}/security/gnutls \
ntlm.0:${PORTSDIR}/security/libntlm
-USES= charsetfix
-USE_GNOME= gnomehack pkgconfig
-USE_PERL5_BUILD= yes
+USES= charsetfix pathfix perl5 pkgconfig
+USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/gss/Makefile b/security/gss/Makefile
index da1ad8e33706..6ac2edaf7cef 100644
--- a/security/gss/Makefile
+++ b/security/gss/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: gss
-# Date created: Oct 19, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= gss
PORTVERSION= 1.0.2
@@ -18,8 +13,8 @@ LIB_DEPENDS= shishi.1:${PORTSDIR}/security/shishi
CONFLICTS= heimdal-[0-9]*
-USE_PERL5_BUILD= yes
-USE_GNOME= gnomehack pkgconfig
+USES= pathfix pkgconfig perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-kerberos5
USE_LDCONFIG= yes
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index 3e53eab87cd5..2cb47c55d5da 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -28,9 +28,8 @@ CRACKLIB_DESC= Use CrackLib for password quality checking
X11_DESC= Build X11 utilies
USE_AUTOTOOLS= autoconf autoheader libtool
-USE_GNOME= gnomehack pkgconfig
USE_OPENSSL= yes
-USES= gettext
+USES= gettext pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS+= --with-libintl=${LOCALBASE} \
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index c3e92a204cdd..d88620bca4f8 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -21,7 +21,7 @@ CONFLICTS= hydra-[0-9]*
NO_LATEST_LINK= yes
PLIST_FILES= bin/hydra bin/pw-inspector bin/dpl4hydra.sh
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_OPENSSL= yes
WANT_GNOME= yes
@@ -48,7 +48,8 @@ LIB_DEPENDS+= svn_client-1:${PORTSDIR}/devel/subversion
.endif
.if ${PORT_OPTIONS:MX11}
-USE_GNOME= gtk20 pkgconfig
+USES+= pkgconfig
+USE_GNOME= gtk20
PLIST_FILES+= bin/xhydra
MAN1+= xhydra.1
.else
diff --git a/security/libfprint/Makefile b/security/libfprint/Makefile
index e173b7b9bbe9..23c7bb962dd3 100644
--- a/security/libfprint/Makefile
+++ b/security/libfprint/Makefile
@@ -17,7 +17,8 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USE_GNOME= gnomehack glib20 pkgconfig
+USES= pathfix pkgconfig
+USE_GNOME= glib20
CFLAGS+= -DHAVE_MEMMEM
MAKE_JOBS_UNSAFE=yes
diff --git a/security/libp11/Makefile b/security/libp11/Makefile
index e7cd25e54b32..8063977894c5 100644
--- a/security/libp11/Makefile
+++ b/security/libp11/Makefile
@@ -16,7 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_AUTOTOOLS= libltdl libtool
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig ltverhack
+USES= pkgconfig
+USE_GNOME= ltverhack
USE_LDCONFIG= yes
CONFIGURE_ENV= LTLIB_CFLAGS="-I${LOCALBASE}/include" \
diff --git a/security/opencdk/Makefile b/security/opencdk/Makefile
index 01f0151e2956..5446232ae181 100644
--- a/security/opencdk/Makefile
+++ b/security/opencdk/Makefile
@@ -16,7 +16,8 @@ LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig ltverhack
+USES= pkgconfig
+USE_GNOME= ltverhack
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-libgcrypt-prefix=${LOCALBASE}
diff --git a/security/openct/Makefile b/security/openct/Makefile
index becc46b941e6..1ce1fb20c153 100644
--- a/security/openct/Makefile
+++ b/security/openct/Makefile
@@ -16,8 +16,7 @@ PCSC_DESC= Enable PC/SC support
USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GNOME= pkgconfig
+USES= gmake pkgconfig
USE_LDCONFIG= yes
USE_RC_SUBR= openct
SUB_FILES= etoken.conf
diff --git a/security/pam_fprint/Makefile b/security/pam_fprint/Makefile
index 47379d16a0d0..e0ef36766697 100644
--- a/security/pam_fprint/Makefile
+++ b/security/pam_fprint/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pam_fprint
-# Date created: April 12 2008
-# Whom: barner
-#
+# Created by: barner
# $FreeBSD$
-#
PORTNAME= pam_fprint
PORTVERSION= 20080330
@@ -23,7 +19,7 @@ AUTOMAKE_ARGS= -a
CONFIGURE_ENV+= FPRINT_CFLAGS=-I${LOCALBASE}/include
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig
+USES= pkgconfig
WRKSRC= ${WRKDIR}
diff --git a/security/pam_p11/Makefile b/security/pam_p11/Makefile
index 318bc7104ca0..c18e7165e077 100644
--- a/security/pam_p11/Makefile
+++ b/security/pam_p11/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pam_p11
-# Date created: 1 Jun 2006
-# Whom: Alex Dupre <ale@FreeBSD.org>
-#
+# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= pam_p11
PORTVERSION= 0.1.5
@@ -19,7 +15,7 @@ LIB_DEPENDS= p11.2:${PORTSDIR}/security/libp11
USE_AUTOTOOLS= libtool
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig
+USES= pkgconfig
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
diff --git a/security/pkcs11-helper/Makefile b/security/pkcs11-helper/Makefile
index 898f43e5681e..70811235e133 100644
--- a/security/pkcs11-helper/Makefile
+++ b/security/pkcs11-helper/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING.GPL
USE_BZIP2= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack pkgconfig
+USES= pathfix pkgconfig
USE_LDCONFIG= yes
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 1cb2a66bad5f..05bac250b569 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -136,7 +136,7 @@ CONFIGURE_ARGS+=--enable-react
.if ${PORT_OPTIONS:MSNORTSAM}
BROKEN= current snortsam patch fails to apply
USE_AUTOTOOLS+= automake
-USE_GNOME= pkgconfig
+USES+= pkgconfig
PATCH_SITES+= http://www.snortsam.net/files/snort-plugin/:snortsam
PATCHFILES+= snortsam-2.9.2.2.diff.gz:snortsam
.endif
diff --git a/security/sssd/Makefile b/security/sssd/Makefile
index 506a92f3bb41..f6a821a1191e 100644
--- a/security/sssd/Makefile
+++ b/security/sssd/Makefile
@@ -48,9 +48,7 @@ AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
USE_PYTHON= yes
USE_OPENLDAP= yes
-USE_GMAKE= yes
-USE_GNOME= pkgconfig
-USES= gettext iconv
+USES= gettext iconv gmake pkgconfig
USE_PYTHON= yes
USE_RC_SUBR= ${PORTNAME}