aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING18
-rw-r--r--devel/git/Makefile5
-rw-r--r--devel/git/distinfo12
-rw-r--r--devel/git/files/git_daemon.in2
-rw-r--r--devel/git/files/patch-Makefile33
-rw-r--r--devel/git/pkg-plist301
6 files changed, 196 insertions, 175 deletions
diff --git a/UPDATING b/UPDATING
index 27a1364e567e..068ce7fecbcb 100644
--- a/UPDATING
+++ b/UPDATING
@@ -7,6 +7,24 @@ time you update your ports collection, before attempting any port
upgrades.
20080827:
+ AFFECTS: users of devel/git
+ AUTHOR: wxs@FreeBSD.org
+
+ With the default Makefile settings, most of the programs are now
+ installed outside your $PATH, except for "git", "gitk" and
+ some server side programs that need to be accessible for technical
+ reasons. Invoking a git subcommand as "git-xyzzy" from the command
+ line has been deprecated since early 2006 (and officially announced in
+ 1.5.4 release notes); use of them from your scripts after adding
+ output from "git --exec-path" to the $PATH is still supported in this
+ release, but users are again strongly encouraged to adjust their
+ scripts to use "git xyzzy" form, as we will stop installing
+ "git-xyzzy" hardlinks for built-in commands in later releases.
+
+ Please see this URL for more information:
+ http://www.kernel.org/pub/software/scm/git/docs/RelNotes-1.6.0.txt
+
+20080827:
AFFECTS: users of mail/qmhandle
AUTHOR: garga@FreeBSD.org
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 6288855d09a8..803653f9bc92 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= git
-PORTVERSION= 1.5.6.4
+PORTVERSION= 1.6.0.1
CATEGORIES= devel
MASTER_SITES= http://www.kernel.org/pub/software/scm/git/
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
@@ -208,9 +208,6 @@ PLIST_SUB+= GITWEB=""
PLIST_SUB+= GITWEB="@comment "
.endif
-pre-patch:
- @${REINPLACE_CMD} -e 's|OPENSSLDIR|OPENSSLBASE|g' ${WRKSRC}/Makefile
-
post-patch:
@${REINPLACE_CMD} -e 's|share/man/man3|man/man3|' ${WRKSRC}/perl/Makefile.PL
diff --git a/devel/git/distinfo b/devel/git/distinfo
index 003836196295..b9eff3ed2b7a 100644
--- a/devel/git/distinfo
+++ b/devel/git/distinfo
@@ -1,6 +1,6 @@
-MD5 (git-1.5.6.4.tar.bz2) = b5f248c71d32921ff0ff7e35f7770003
-SHA256 (git-1.5.6.4.tar.bz2) = 25ae4f93c14efd84c8dbce1598f182bc4bbfafdccb22bc7965b54473600aafd9
-SIZE (git-1.5.6.4.tar.bz2) = 1740619
-MD5 (git-manpages-1.5.6.4.tar.bz2) = dbc8948797f19b9b39f471e0ad548afa
-SHA256 (git-manpages-1.5.6.4.tar.bz2) = ecac874e85d88f7b8ddb976157ca5569931cb71e07a02b83a7f68c2e3a066555
-SIZE (git-manpages-1.5.6.4.tar.bz2) = 214972
+MD5 (git-1.6.0.1.tar.bz2) = 264701ebd9036ca2458358f01aa6c093
+SHA256 (git-1.6.0.1.tar.bz2) = 0bd0f4eb5da015913c6415d5f8ffecd4f6233daef7f275b99f6120935fc1f6ee
+SIZE (git-1.6.0.1.tar.bz2) = 1861853
+MD5 (git-manpages-1.6.0.1.tar.bz2) = 07b357210b59a1140200815c682fda34
+SHA256 (git-manpages-1.6.0.1.tar.bz2) = 7e0708f61157beee32dbf8c6630bcbc6e83168ce28cea7242e61b7211db94da5
+SIZE (git-manpages-1.6.0.1.tar.bz2) = 221756
diff --git a/devel/git/files/git_daemon.in b/devel/git/files/git_daemon.in
index 92495ff66bc2..e0481d26b2ee 100644
--- a/devel/git/files/git_daemon.in
+++ b/devel/git/files/git_daemon.in
@@ -23,7 +23,7 @@ load_rc_config $name
: ${git_daemon_directory:=%%PREFIX%%/git}
: ${git_daemon_flags:="--syslog"}
-command="%%PREFIX%%/bin/git-daemon"
+command="%%PREFIX%%/libexec/git-core/git-daemon"
command_args="${git_daemon_directory} &"
run_rc_command "$1"
diff --git a/devel/git/files/patch-Makefile b/devel/git/files/patch-Makefile
index 527af550b0c4..305c77df3537 100644
--- a/devel/git/files/patch-Makefile
+++ b/devel/git/files/patch-Makefile
@@ -1,6 +1,6 @@
---- ./Makefile.orig 2008-06-07 21:03:58.000000000 -0400
-+++ ./Makefile 2008-06-14 18:18:52.000000000 -0400
-@@ -164,16 +164,16 @@
+--- ./Makefile.orig 2008-08-27 08:55:18.000000000 -0400
++++ ./Makefile 2008-08-27 08:57:19.000000000 -0400
+@@ -164,8 +164,8 @@
# CFLAGS and LDFLAGS are for the users to override from the command line.
@@ -11,19 +11,9 @@
ALL_CFLAGS = $(CFLAGS)
ALL_LDFLAGS = $(LDFLAGS)
STRIP ?= strip
+@@ -217,15 +217,15 @@
- prefix = $(HOME)
- bindir = $(prefix)/bin
--mandir = $(prefix)/share/man
--infodir = $(prefix)/share/info
-+mandir = $(prefix)/man
-+infodir = $(prefix)/info
- gitexecdir = $(bindir)
- sharedir = $(prefix)/share
- template_dir = $(sharedir)/git-core/templates
-@@ -206,15 +206,15 @@
-
- export prefix bindir gitexecdir sharedir template_dir htmldir sysconfdir
+ export prefix bindir sharedir htmldir sysconfdir
-CC = gcc
-AR = ar
@@ -46,3 +36,16 @@
export TCL_PATH TCLTK_PATH
+@@ -826,9 +826,9 @@
+ endif
+ ifndef NO_OPENSSL
+ OPENSSL_LIBSSL = -lssl
+- ifdef OPENSSLDIR
+- BASIC_CFLAGS += -I$(OPENSSLDIR)/include
+- OPENSSL_LINK = -L$(OPENSSLDIR)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLDIR)/$(lib)
++ ifdef OPENSSLBASE
++ BASIC_CFLAGS += -I$(OPENSSLBASE)/include
++ OPENSSL_LINK = -L$(OPENSSLBASE)/$(lib) $(CC_LD_DYNPATH)$(OPENSSLBASE)/$(lib)
+ else
+ OPENSSL_LINK =
+ endif
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 4dc49aa1a1b2..2ddc1bb8280b 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -1,146 +1,148 @@
bin/git
-bin/git-add
-bin/git-add--interactive
-bin/git-am
-bin/git-annotate
-bin/git-apply
-bin/git-archimport
-bin/git-archive
-bin/git-bisect
-bin/git-blame
-bin/git-branch
-bin/git-bundle
-bin/git-cat-file
-bin/git-check-attr
-bin/git-check-ref-format
-bin/git-checkout
-bin/git-checkout-index
-bin/git-cherry
-bin/git-cherry-pick
-%%GUI%%bin/git-citool
-bin/git-clean
-bin/git-clone
-bin/git-commit
-bin/git-commit-tree
-bin/git-config
-bin/git-count-objects
-bin/git-cvsexportcommit
-bin/git-cvsimport
-bin/git-cvsserver
-bin/git-daemon
-bin/git-describe
-bin/git-diff
-bin/git-diff-files
-bin/git-diff-index
-bin/git-diff-tree
-bin/git-fast-export
-bin/git-fast-import
-bin/git-fetch
-bin/git-fetch--tool
-bin/git-fetch-pack
-bin/git-filter-branch
-bin/git-fmt-merge-msg
-bin/git-for-each-ref
-bin/git-format-patch
-bin/git-fsck
-bin/git-fsck-objects
-bin/git-gc
-bin/git-get-tar-commit-id
-bin/git-grep
-%%GUI%%bin/git-gui
-bin/git-hash-object
-bin/git-http-fetch
-bin/git-http-push
-bin/git-imap-send
-bin/git-index-pack
-bin/git-init
-bin/git-init-db
-bin/git-instaweb
-bin/git-log
-bin/git-lost-found
-bin/git-ls-files
-bin/git-ls-remote
-bin/git-ls-tree
-bin/git-mailinfo
-bin/git-mailsplit
-bin/git-merge
-bin/git-merge-base
-bin/git-merge-file
-bin/git-merge-index
-bin/git-merge-octopus
-bin/git-merge-one-file
-bin/git-merge-ours
-bin/git-merge-recursive
-bin/git-merge-resolve
-bin/git-merge-stupid
-bin/git-merge-subtree
-bin/git-merge-tree
-bin/git-mergetool
-bin/git-mktag
-bin/git-mktree
-bin/git-mv
-bin/git-name-rev
bin/git-p4
bin/git-p4import
-bin/git-pack-objects
-bin/git-pack-redundant
-bin/git-pack-refs
-bin/git-parse-remote
-bin/git-patch-id
-bin/git-peek-remote
-bin/git-prune
-bin/git-prune-packed
-bin/git-pull
-bin/git-push
-bin/git-quiltimport
-bin/git-read-tree
-bin/git-rebase
-bin/git-rebase--interactive
+bin/git-upload-pack
bin/git-receive-pack
-bin/git-reflog
-bin/git-relink
-bin/git-remote
-bin/git-repack
-bin/git-repo-config
-bin/git-request-pull
-bin/git-rerere
-bin/git-reset
-bin/git-rev-list
-bin/git-rev-parse
-bin/git-revert
-bin/git-rm
-bin/git-send-email
-bin/git-send-pack
-bin/git-sh-setup
-bin/git-shell
+bin/git-upload-archive
+libexec/git-core/git-add
+libexec/git-core/git-add--interactive
+libexec/git-core/git-am
+libexec/git-core/git-annotate
+libexec/git-core/git-apply
+libexec/git-core/git-archimport
+libexec/git-core/git-archive
+libexec/git-core/git-bisect
+libexec/git-core/git-blame
+libexec/git-core/git-branch
+libexec/git-core/git-bundle
+libexec/git-core/git-cat-file
+libexec/git-core/git-check-attr
+libexec/git-core/git-check-ref-format
+libexec/git-core/git-checkout
+libexec/git-core/git-checkout-index
+libexec/git-core/git-cherry
+libexec/git-core/git-cherry-pick
+%%GUI%%libexec/git-core/git-citool
+libexec/git-core/git-clean
+libexec/git-core/git-clone
+libexec/git-core/git-commit
+libexec/git-core/git-commit-tree
+libexec/git-core/git-config
+libexec/git-core/git-count-objects
+libexec/git-core/git-cvsexportcommit
+libexec/git-core/git-cvsimport
+libexec/git-core/git-cvsserver
+libexec/git-core/git-daemon
+libexec/git-core/git-describe
+libexec/git-core/git-diff
+libexec/git-core/git-diff-files
+libexec/git-core/git-diff-index
+libexec/git-core/git-diff-tree
+libexec/git-core/git-fast-export
+libexec/git-core/git-fast-import
+libexec/git-core/git-fetch
+libexec/git-core/git-fetch--tool
+libexec/git-core/git-fetch-pack
+libexec/git-core/git-filter-branch
+libexec/git-core/git-fmt-merge-msg
+libexec/git-core/git-for-each-ref
+libexec/git-core/git-format-patch
+libexec/git-core/git-fsck
+libexec/git-core/git-fsck-objects
+libexec/git-core/git-gc
+libexec/git-core/git-get-tar-commit-id
+libexec/git-core/git-grep
+%%GUI%%libexec/git-core/git-gui
+libexec/git-core/git-hash-object
+libexec/git-core/git-http-fetch
+libexec/git-core/git-http-push
+libexec/git-core/git-imap-send
+libexec/git-core/git-index-pack
+libexec/git-core/git-init
+libexec/git-core/git-init-db
+libexec/git-core/git-instaweb
+libexec/git-core/git-log
+libexec/git-core/git-lost-found
+libexec/git-core/git-ls-files
+libexec/git-core/git-ls-remote
+libexec/git-core/git-ls-tree
+libexec/git-core/git-mailinfo
+libexec/git-core/git-mailsplit
+libexec/git-core/git-merge
+libexec/git-core/git-merge-base
+libexec/git-core/git-merge-file
+libexec/git-core/git-merge-index
+libexec/git-core/git-merge-octopus
+libexec/git-core/git-merge-one-file
+libexec/git-core/git-merge-ours
+libexec/git-core/git-merge-recursive
+libexec/git-core/git-merge-resolve
+libexec/git-core/git-merge-subtree
+libexec/git-core/git-merge-tree
+libexec/git-core/git-mergetool
+libexec/git-core/git-mktag
+libexec/git-core/git-mktree
+libexec/git-core/git-mv
+libexec/git-core/git-name-rev
+libexec/git-core/git-pack-objects
+libexec/git-core/git-pack-redundant
+libexec/git-core/git-pack-refs
+libexec/git-core/git-parse-remote
+libexec/git-core/git-patch-id
+libexec/git-core/git-peek-remote
+libexec/git-core/git-prune
+libexec/git-core/git-prune-packed
+libexec/git-core/git-pull
+libexec/git-core/git-push
+libexec/git-core/git-quiltimport
+libexec/git-core/git-read-tree
+libexec/git-core/git-rebase
+libexec/git-core/git-rebase--interactive
+libexec/git-core/git-receive-pack
+libexec/git-core/git-reflog
+libexec/git-core/git-relink
+libexec/git-core/git-remote
+libexec/git-core/git-repack
+libexec/git-core/git-repo-config
+libexec/git-core/git-request-pull
+libexec/git-core/git-rerere
+libexec/git-core/git-reset
+libexec/git-core/git-rev-list
+libexec/git-core/git-rev-parse
+libexec/git-core/git-revert
+libexec/git-core/git-rm
+libexec/git-core/git-send-email
+libexec/git-core/git-send-pack
+libexec/git-core/git-sh-setup
+libexec/git-core/git-shell
@exec echo "Updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells; rm -f /etc/shells.bak
@unexec echo "Updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells; rm -f /etc/shells.bak
-bin/git-shortlog
-bin/git-show
-bin/git-show-branch
-bin/git-show-index
-bin/git-show-ref
-bin/git-stash
-bin/git-status
-bin/git-stripspace
-bin/git-submodule
-bin/git-svn
-bin/git-symbolic-ref
-bin/git-tag
-bin/git-tar-tree
-bin/git-unpack-file
-bin/git-unpack-objects
-bin/git-update-index
-bin/git-update-ref
-bin/git-update-server-info
-bin/git-upload-archive
-bin/git-upload-pack
-bin/git-var
-bin/git-verify-pack
-bin/git-verify-tag
-bin/git-web--browse
-bin/git-whatchanged
-bin/git-write-tree
+libexec/git-core/git-shortlog
+libexec/git-core/git-show
+libexec/git-core/git-show-branch
+libexec/git-core/git-show-index
+libexec/git-core/git-show-ref
+libexec/git-core/git-stash
+libexec/git-core/git-status
+libexec/git-core/git-stripspace
+libexec/git-core/git-submodule
+libexec/git-core/git-svn
+libexec/git-core/git-symbolic-ref
+libexec/git-core/git-tag
+libexec/git-core/git-tar-tree
+libexec/git-core/git-unpack-file
+libexec/git-core/git-unpack-objects
+libexec/git-core/git-update-index
+libexec/git-core/git-update-ref
+libexec/git-core/git-update-server-info
+libexec/git-core/git-upload-archive
+libexec/git-core/git-upload-pack
+libexec/git-core/git-var
+libexec/git-core/git-verify-pack
+libexec/git-core/git-verify-tag
+libexec/git-core/git-web--browse
+libexec/git-core/git-whatchanged
+libexec/git-core/git-write-tree
%%GUI%%bin/gitk
%%SITE_PERL%%/Git.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Git/.packlist
@@ -149,16 +151,16 @@ lib/xemacs/site-lisp/git/vc-git.el
share/emacs/site-lisp/git/git.el
share/emacs/site-lisp/git/vc-git.el
share/git-core/templates/description
-share/git-core/templates/hooks/applypatch-msg
-share/git-core/templates/hooks/commit-msg
-share/git-core/templates/hooks/post-commit
-share/git-core/templates/hooks/post-receive
-share/git-core/templates/hooks/post-update
-share/git-core/templates/hooks/pre-applypatch
-share/git-core/templates/hooks/pre-commit
-share/git-core/templates/hooks/pre-rebase
-share/git-core/templates/hooks/prepare-commit-msg
-share/git-core/templates/hooks/update
+share/git-core/templates/hooks/applypatch-msg.sample
+share/git-core/templates/hooks/commit-msg.sample
+share/git-core/templates/hooks/post-commit.sample
+share/git-core/templates/hooks/post-receive.sample
+share/git-core/templates/hooks/post-update.sample
+share/git-core/templates/hooks/pre-applypatch.sample
+share/git-core/templates/hooks/pre-commit.sample
+share/git-core/templates/hooks/pre-rebase.sample
+share/git-core/templates/hooks/prepare-commit-msg.sample
+share/git-core/templates/hooks/update.sample
share/git-core/templates/info/exclude
%%GUI%%share/git-gui/lib/tclIndex
%%GUI%%share/git-gui/lib/about.tcl
@@ -225,8 +227,9 @@ share/git-core/templates/info/exclude
%%GUI%%@dirrm share/git-gui/lib/msgs
%%GUI%%@dirrm share/git-gui/lib
%%GUI%%@dirrm share/git-gui
+@dirrm libexec/git-core
@dirrm share/git-core/templates/branches
-@dirrm share/git-core/templates/hooks
+@dirrmtry share/git-core/templates/hooks
@dirrm share/git-core/templates/info
-@dirrm share/git-core/templates
+@dirrmtry share/git-core/templates
@dirrm share/git-core