aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/innotop/Makefile9
-rw-r--r--databases/mariadb-scripts/Makefile2
-rw-r--r--databases/mysql51-scripts/Makefile8
-rw-r--r--databases/mysqlsla/Makefile7
-rw-r--r--databases/p5-Amazon-SimpleDB/Makefile9
-rw-r--r--databases/p5-CDB_File/Makefile10
-rw-r--r--databases/p5-DBD-Multi/Makefile9
-rw-r--r--databases/p5-DBICx-Deploy/Makefile9
-rw-r--r--databases/p5-DBICx-TestDatabase/Makefile9
-rw-r--r--databases/p5-DBIx-Abstract/Makefile9
-rw-r--r--databases/p5-DBIx-Class-DynamicSubclass/Makefile9
-rw-r--r--databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/Makefile4
-rw-r--r--databases/p5-DBIx-Class-PassphraseColumn/Makefile3
-rw-r--r--databases/p5-DBIx-Connector/Makefile3
-rw-r--r--databases/p5-DBIx-Wrapper/Makefile9
-rw-r--r--databases/p5-Data-Pageset/Makefile9
-rw-r--r--databases/p5-KyotoCabinet/Makefile9
-rw-r--r--databases/p5-SQL-Abstract-Plugin-InsertMulti/Makefile8
-rw-r--r--databases/p5-tokyotyrant/Makefile9
19 files changed, 49 insertions, 95 deletions
diff --git a/databases/innotop/Makefile b/databases/innotop/Makefile
index 2f4042654cb4..4e12354d3be6 100644
--- a/databases/innotop/Makefile
+++ b/databases/innotop/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: innotop
-# Date created: 23 October 2006
-# Whom: Steven Kreuzer <skreuzer@f2o.org>
-#
+# Created by: Steven Kreuzer <skreuzer@f2o.org>
# $FreeBSD$
-#
PORTNAME= innotop
PORTVERSION= 1.9.1
@@ -23,7 +19,8 @@ RUN_DEPENDS= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
p5-DBI>=1.46:${PORTSDIR}/databases/p5-DBI \
p5-Term-ReadKey>=2.10:${PORTSDIR}/devel/p5-Term-ReadKey
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
USE_MYSQL= yes
MAN1= innotop.1
diff --git a/databases/mariadb-scripts/Makefile b/databases/mariadb-scripts/Makefile
index 81b837c44056..6390d698d5fd 100644
--- a/databases/mariadb-scripts/Makefile
+++ b/databases/mariadb-scripts/Makefile
@@ -8,7 +8,7 @@ COMMENT= Scripts for mariadb - drop-in replacement for MySQL
LICENSE= GPLv2
UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
-USE_PERL5= yes
+USES= perl5
MASTERDIR= ${.CURDIR}/../mariadb-server
MARIADB_SCRIPTS_SLAVE= yes
diff --git a/databases/mysql51-scripts/Makefile b/databases/mysql51-scripts/Makefile
index bb4acfcf8a31..daaefd22161d 100644
--- a/databases/mysql51-scripts/Makefile
+++ b/databases/mysql51-scripts/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: MySQL-scripts
-# Date created: 28 Jan 2006
-# Whom: Alex Dupre <ale@FreeBSD.org>
-#
+# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mysql
PKGNAMESUFFIX= -scripts
@@ -17,6 +13,6 @@ PKGMESSAGE= mustnotexist
PLIST= ${PKGDIR}/pkg-plist.scripts
SCRIPTS_ONLY= yes
-USE_PERL5= yes
+USES= perl5
.include "${MASTERDIR}/Makefile"
diff --git a/databases/mysqlsla/Makefile b/databases/mysqlsla/Makefile
index c37140ac2d39..64cf253fe4f1 100644
--- a/databases/mysqlsla/Makefile
+++ b/databases/mysqlsla/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: mysqlsla
-# Date created: 2006-11-23
-# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
-#
+# Created by: Alexander Zhuravlev <zaa@zaa.pp.ru>
# $FreeBSD$
PORTNAME= mysqlsla
@@ -16,7 +13,7 @@ COMMENT= Mysqlsla analyzes general, slow, and raw MySQL statement logs
RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
PLIST_FILES= bin/mysqlsla
diff --git a/databases/p5-Amazon-SimpleDB/Makefile b/databases/p5-Amazon-SimpleDB/Makefile
index a52e0e3bdf0f..00dde245a7c3 100644
--- a/databases/p5-Amazon-SimpleDB/Makefile
+++ b/databases/p5-Amazon-SimpleDB/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Amazon-SimpleDB
-# Date created: 2009-02-02
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Amazon-SimpleDB
PORTVERSION= 0.03
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-Digest-HMAC>0:${PORTSDIR}/security/p5-Digest-HMAC \
p5-libwww>0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Amazon::SimpleDB.3 \
Amazon::SimpleDB::Domain.3 \
diff --git a/databases/p5-CDB_File/Makefile b/databases/p5-CDB_File/Makefile
index 012895910279..c0f4a9dcc0e6 100644
--- a/databases/p5-CDB_File/Makefile
+++ b/databases/p5-CDB_File/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: p5-CDB_Fiile
-# Date created: 24 June 2001
-# Whom: Jon Nistor <nistor@snickers.org>
-#
+# Created by: Jon Nistor <nistor@snickers.org>
# $FreeBSD$
-#
PORTNAME= CDB_File
PORTVERSION= 0.97
@@ -15,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= nistor@snickers.org
COMMENT= Perl5 interface to the CDB package
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CDB_File.3
diff --git a/databases/p5-DBD-Multi/Makefile b/databases/p5-DBD-Multi/Makefile
index d03c866a54c8..aef56fa7f630 100644
--- a/databases/p5-DBD-Multi/Makefile
+++ b/databases/p5-DBD-Multi/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-DBD-Multi
-# Date created: 2007-07-07
-# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
-#
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
# $FreeBSD$
-#
PORTNAME= DBD-Multi
PORTVERSION= 0.16
@@ -28,7 +24,8 @@ TEST_DEPENDS= p5-DBD-SQLite>=1.09:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1.04:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBD::Multi.3
diff --git a/databases/p5-DBICx-Deploy/Makefile b/databases/p5-DBICx-Deploy/Makefile
index 0f519989d0db..5c1d8d1bc592 100644
--- a/databases/p5-DBICx-Deploy/Makefile
+++ b/databases/p5-DBICx-Deploy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DBICx-Deploy
-# Date created: 23 Oct 2008
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= DBICx-Deploy
PORTVERSION= 0.02
@@ -22,7 +18,8 @@ BUILD_DEPENDS= p5-DBIx-Class>=0.07003:${PORTSDIR}/databases/p5-DBIx-Class \
RUN_DEPENDS= p5-DBIx-Class>=0.07003:${PORTSDIR}/databases/p5-DBIx-Class \
p5-SQL-Translator>=0:${PORTSDIR}/databases/p5-SQL-Translator
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= dbicdeploy.1
MAN3= DBICx::Deploy.3
diff --git a/databases/p5-DBICx-TestDatabase/Makefile b/databases/p5-DBICx-TestDatabase/Makefile
index a9f3cea12a1a..11762d6808fc 100644
--- a/databases/p5-DBICx-TestDatabase/Makefile
+++ b/databases/p5-DBICx-TestDatabase/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: DBICx-TestDatabase
-# Date created: 23 Oct 2008
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= DBICx-TestDatabase
PORTVERSION= 0.04
@@ -24,7 +20,8 @@ RUN_DEPENDS= p5-DBD-SQLite>=1.12:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-File-Temp>0:${PORTSDIR}/devel/p5-File-Temp
TEST_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBICx::TestDatabase.3 \
DBICx::TestDatabase::Subclass.3
diff --git a/databases/p5-DBIx-Abstract/Makefile b/databases/p5-DBIx-Abstract/Makefile
index b8d2f4ea2604..0545777d6ea7 100644
--- a/databases/p5-DBIx-Abstract/Makefile
+++ b/databases/p5-DBIx-Abstract/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-DBIx-Abstract
-# Date created: 6 Jan 2006
-# Whom: Jon Nistor <nistor@snickers.org>
-#
+# Created by: Jon Nistor <nistor@snickers.org>
# $FreeBSD$
-#
PORTNAME= DBIx-Abstract
PORTVERSION= 1.010
@@ -21,7 +17,8 @@ RUN_DEPENDS= p5-Check-ISA>=0:${PORTSDIR}/devel/p5-Check-ISA \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Abstract.3
diff --git a/databases/p5-DBIx-Class-DynamicSubclass/Makefile b/databases/p5-DBIx-Class-DynamicSubclass/Makefile
index 2793a0c14b8f..19047adae5e4 100644
--- a/databases/p5-DBIx-Class-DynamicSubclass/Makefile
+++ b/databases/p5-DBIx-Class-DynamicSubclass/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-DBIx-Class-DynamicSubclass
-# Date created: 2008-07-15
-# Whom: Vladimir Timofeev <vovkasm@gmail.com>
-#
+# Created by: Vladimir Timofeev <vovkasm@gmail.com>
# $FreeBSD$
-#
PORTNAME= DBIx-Class-DynamicSubclass
PORTVERSION= 0.03
@@ -17,7 +13,8 @@ COMMENT= Use dynamic subclassing with DBIx::Class
RUN_DEPENDS= p5-DBIx-Class>=0.07003:${PORTSDIR}/databases/p5-DBIx-Class
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Class::DynamicSubclass.3
diff --git a/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/Makefile b/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/Makefile
index d595dbb61eef..156303c61ac9 100644
--- a/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/Makefile
+++ b/databases/p5-DBIx-Class-InflateColumn-Authen-Passphrase/Makefile
@@ -1,4 +1,3 @@
-# Created by Frank Wall <fw@moov.de>
# $FreeBSD$
PORTNAME= DBIx-Class-InflateColumn-Authen-Passphrase
@@ -18,7 +17,8 @@ BUILD_DEPENDS:= p5-DBIx-Class-DynamicDefault>=0.03:${PORTSDIR}/databases/p5-DBIx
p5-DBIx-Class>=0.08009:${PORTSDIR}/databases/p5-DBIx-Class \
p5-Authen-Passphrase>=0:${PORTSDIR}/security/p5-Authen-Passphrase
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Class::InflateColumn::Authen::Passphrase.3
diff --git a/databases/p5-DBIx-Class-PassphraseColumn/Makefile b/databases/p5-DBIx-Class-PassphraseColumn/Makefile
index d6baf631a46a..997dac1f06ec 100644
--- a/databases/p5-DBIx-Class-PassphraseColumn/Makefile
+++ b/databases/p5-DBIx-Class-PassphraseColumn/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-DBIx-Class-DynamicDefault>=0.03:${PORTSDIR}/databases/p5-DBIx-Cl
p5-DBIx-Class>=0.08009:${PORTSDIR}/databases/p5-DBIx-Class
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Class::PassphraseColumn.3
diff --git a/databases/p5-DBIx-Connector/Makefile b/databases/p5-DBIx-Connector/Makefile
index 0258f2f0e1e6..8dcd8cb17fed 100644
--- a/databases/p5-DBIx-Connector/Makefile
+++ b/databases/p5-DBIx-Connector/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-MockModule>=0:${PORTSDIR}/devel/p5-Test-MockModule
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= DBIx::Connector.3 \
DBIx::Connector::Driver.3 \
diff --git a/databases/p5-DBIx-Wrapper/Makefile b/databases/p5-DBIx-Wrapper/Makefile
index 886547dd38c1..9e26741366bc 100644
--- a/databases/p5-DBIx-Wrapper/Makefile
+++ b/databases/p5-DBIx-Wrapper/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-DBIx-Wrapper
-# Date created: 8 January 2012
-# Whom: Don Owens <don@regexguy.com>
-#
+# Created by: Don Owens <don@regexguy.com>
# $FreeBSD$
-#
PORTNAME= DBIx-Wrapper
PORTVERSION= 0.28
@@ -16,7 +12,8 @@ COMMENT= A wrapper around Perl's DBI module
RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DBIx::Wrapper.3 \
DBIx::Wrapper::Request.3
diff --git a/databases/p5-Data-Pageset/Makefile b/databases/p5-Data-Pageset/Makefile
index cc64d4ef9199..6b7cbca23d16 100644
--- a/databases/p5-Data-Pageset/Makefile
+++ b/databases/p5-Data-Pageset/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Data-Pageset
-# Date created: 29 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Data-Pageset
PORTVERSION= 1.06
@@ -20,6 +16,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Data::Pageset.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/databases/p5-KyotoCabinet/Makefile b/databases/p5-KyotoCabinet/Makefile
index 5c9fb9a14259..5b4ad05d40ec 100644
--- a/databases/p5-KyotoCabinet/Makefile
+++ b/databases/p5-KyotoCabinet/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-KyotoCabinet
-# Date created: 2011-09-19
-# Whom: Geraud CONTINSOUZAS <geraud@gcu.info>
-#
+# Created by: Geraud CONTINSOUZAS <geraud@gcu.info>
# $FreeBSD$
-#
PORTNAME= KyotoCabinet
PORTVERSION= 1.18
@@ -20,7 +16,8 @@ LICENSE= GPLv3
LIB_DEPENDS= kyotocabinet:${PORTSDIR}/databases/kyotocabinet
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= KyotoCabinet.3
diff --git a/databases/p5-SQL-Abstract-Plugin-InsertMulti/Makefile b/databases/p5-SQL-Abstract-Plugin-InsertMulti/Makefile
index 73c76105157d..f640fc8d06a7 100644
--- a/databases/p5-SQL-Abstract-Plugin-InsertMulti/Makefile
+++ b/databases/p5-SQL-Abstract-Plugin-InsertMulti/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: SQL::Abstract::Plugin::InsertMulti
-# Date created: 26 Dec 2010
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= SQL-Abstract-Plugin-InsertMulti
PORTVERSION= 0.03
@@ -19,7 +14,8 @@ RUN_DEPENDS= \
p5-Sub-Exporter>0:${PORTSDIR}/devel/p5-Sub-Exporter
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SQL::Abstract::Plugin::InsertMulti.3
diff --git a/databases/p5-tokyotyrant/Makefile b/databases/p5-tokyotyrant/Makefile
index ebd4d90c7449..186b38e16e64 100644
--- a/databases/p5-tokyotyrant/Makefile
+++ b/databases/p5-tokyotyrant/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: perl interface to TokyoTyrant
-# Date created: 17 February 2010
-# Whom: Hiroyuki Hanai <hanai@FreeBSD.org>
-#
+# Created by: Hiroyuki Hanai <hanai@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= tokyotyrant
PORTVERSION= 1.16
@@ -19,7 +15,8 @@ COMMENT= Perl5 interface to the TokyoTyrant
BUILD_DEPENDS= tokyotyrant>=1.1.40:${PORTSDIR}/databases/tokyotyrant
LIB_DEPENDS= tokyotyrant:${PORTSDIR}/databases/tokyotyrant
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= TokyoTyrant.3