aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING13
-rw-r--r--sysutils/ansible/Makefile20
-rw-r--r--sysutils/ansible1/Makefile2
-rw-r--r--sysutils/ansible23/Makefile2
-rw-r--r--sysutils/ansible24/Makefile2
5 files changed, 34 insertions, 5 deletions
diff --git a/UPDATING b/UPDATING
index daed52516571..347913670ea6 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,19 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20180518:
+ AFFECTS: users of sysutils/ansible*
+ AUTHOR: lifanov@FreeBSD.org
+
+ Ansible ports are now flavored. Package names for Ansible changed
+ to include python version. Poudriere and package users don't need
+ to do anything.
+
+ To rename an installed package to match the new naming scheme,
+ for example, for ansible24, run:
+
+ # pkg set -n ansible24:py27-ansible24
+
20180514:
AFFECTS: users of www/gitlab
AUTHOR: mfechner@FreeBSD.org
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index b475badde32e..6030ab9893d7 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -2,9 +2,10 @@
PORTNAME= ansible
PORTVERSION?= 2.5.2
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= lifanov@FreeBSD.org
COMMENT= Radically simple IT automation
@@ -18,6 +19,14 @@ RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}paramiko>0:security/py-paramiko@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+TEST_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-xdist>0:devel/py-pytest-xdist@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-mock>0:devel/py-pytest-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}passlib>0:security/py-passlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}boto3>0:www/py-boto3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
CONFLICTS?= ansible1-* ansible23-* ansible24-*
@@ -25,7 +34,7 @@ EXTRA_PATCHES?= ${FILESDIR}/extra-patch-sesu
NO_ARCH= yes
USES?= cpe python
-USE_PYTHON= autoplist distutils noflavors
+USE_PYTHON= distutils autoplist concurrent
CPE_VENDOR= ansibleworks
SUB_FILES= pkg-message
@@ -60,4 +69,11 @@ post-install-EXAMPLES-on:
${INSTALL_DATA} ${WRKSRC}/examples/ansible.cfg ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/hosts ${STAGEDIR}${EXAMPLESDIR}
+TEST_WRKSRC=${WRKSRC}/test
+
+do-test:
+# ${PYTHON_CMD} ${TEST_WRKSRC}/runner/ansible-test sanity --python ${PYTHON_VER} -v
+ ${RM} ${TEST_WRKSRC}/units/modules/net_tools/test_nmcli.py # not conditional/doesn't work with nose
+ ${PYTHON_CMD} ${TEST_WRKSRC}/runner/ansible-test units --python ${PYTHON_VER} -v
+
.include <bsd.port.mk>
diff --git a/sysutils/ansible1/Makefile b/sysutils/ansible1/Makefile
index be97ce0ffe21..30274e084d4f 100644
--- a/sysutils/ansible1/Makefile
+++ b/sysutils/ansible1/Makefile
@@ -2,7 +2,7 @@
PKGNAMESUFFIX= 1
PORTVERSION= 1.9.6
-PORTREVISION= 2
+PORTREVISION= 3
CONFLICTS= ansible-* ansible23-* ansible24-*
diff --git a/sysutils/ansible23/Makefile b/sysutils/ansible23/Makefile
index b94a1db05195..88886a5c077b 100644
--- a/sysutils/ansible23/Makefile
+++ b/sysutils/ansible23/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTVERSION= 2.3.3.0
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= 23
CONFLICTS= ansible-* ansible1-* ansible24-*
diff --git a/sysutils/ansible24/Makefile b/sysutils/ansible24/Makefile
index 8b3d273bd38a..14bda0585f9e 100644
--- a/sysutils/ansible24/Makefile
+++ b/sysutils/ansible24/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTVERSION= 2.4.4.0
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= 24
CONFLICTS= ansible-* ansible1-* ansible23-*