aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING7
-rw-r--r--net-im/uTox/Makefile12
-rw-r--r--net-im/uTox/distinfo4
-rw-r--r--net-im/uTox/files/patch-Makefile64
4 files changed, 60 insertions, 27 deletions
diff --git a/UPDATING b/UPDATING
index 69d6b47ef482..5aa851bfbc6b 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,13 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20160127:
+ AFFECTS: users of net-im/uTox
+ AUTHOR: amdmi3@FreeBSD.org
+
+ Before upgrading uTox port, please set maximum font scale in the
+ program options.
+
20160119:
AFFECTS: users of security/tor, security/tor-devel
AUTHOR: amdmi3@FreeBSD.org
diff --git a/net-im/uTox/Makefile b/net-im/uTox/Makefile
index 738238f626fb..c80111498cd0 100644
--- a/net-im/uTox/Makefile
+++ b/net-im/uTox/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= uTox
-DISTVERSION= 0.4.4.20151120
+PORTVERSION= 0.5.1.20160121
CATEGORIES= net-im net-p2p
MAINTAINER= fidaj@ukr.net
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= GrayHatter
-GH_TAGNAME= 8eaef84
+GH_TAGNAME= b623d58
USES= compiler:c11 desktop-file-utils gmake openal:al pkgconfig
USE_XORG= x11 xext xrender
@@ -34,12 +34,10 @@ DBUS_LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
DBUS_MAKE_ARGS_OFF= DBUS=0
pre-configure:
- ${REINPLACE_CMD} -e 's|$$(GIT_V)|${DISTVERSION}-${GH_TAGNAME}|' \
- ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's|$$(GIT_V)|${DISTVERSION}-${GH_TAGNAME}|' \
+ -e 's|share/man|man|' ${WRKSRC}/${MAKEFILE}
post-install:
- ${MV} ${WRKSRC}/utox.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
- ${RM} -rf ${STAGEDIR}${MAN1PREFIX}/share/man
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/utox
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/utox
.include <bsd.port.mk>
diff --git a/net-im/uTox/distinfo b/net-im/uTox/distinfo
index 2dc171e70438..0d7d3b4447b0 100644
--- a/net-im/uTox/distinfo
+++ b/net-im/uTox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (GrayHatter-uTox-0.4.4.20151120-8eaef84_GH0.tar.gz) = e30a87cbfa2139e7b7d8b434b53e848c749cdf0bfe476edb085d58cc97575cca
-SIZE (GrayHatter-uTox-0.4.4.20151120-8eaef84_GH0.tar.gz) = 960162
+SHA256 (GrayHatter-uTox-0.5.1.20160121-b623d58_GH0.tar.gz) = eaaeccc253c6262b9316783ed51d87b9103bef54f5dbf60b4ef9f124a9a342c0
+SIZE (GrayHatter-uTox-0.5.1.20160121-b623d58_GH0.tar.gz) = 978712
diff --git a/net-im/uTox/files/patch-Makefile b/net-im/uTox/files/patch-Makefile
index 7610df3372f6..2dc6d978f1d1 100644
--- a/net-im/uTox/files/patch-Makefile
+++ b/net-im/uTox/files/patch-Makefile
@@ -1,21 +1,49 @@
---- Makefile.orig 2015-06-13 00:14:56 UTC
-+++ Makefile
-@@ -16,10 +16,6 @@ ifeq ($(V4LCONVERT), 1)
- DEPS += libv4lconvert
- endif
+--- Makefile.orig 2015-12-29 12:13:36.418539000 +0200
++++ Makefile 2015-12-29 12:16:20.089265000 +0200
+@@ -2,7 +2,7 @@
+ # set to anything else to disable them
+ DBUS = 1
+ V4LCONVERT = 1
+-FILTER_AUDIO = 0
++FILTER_AUDIO = 1
+ UNITY = 0
--ifeq ($(FILTER_AUDIO), 1)
-- DEPS += filteraudio
--endif
--
- ifeq ($(UNITY), 1)
- DEPS += messaging-menu unity
- endif
-@@ -41,6 +37,7 @@ endif
+ DEPS = libtoxav libtoxcore openal vpx libsodium
+@@ -50,6 +50,37 @@
- ifeq ($(FILTER_AUDIO), 1)
- CFLAGS += -DAUDIO_FILTERING
-+ LDFLAGS += -lfilteraudio
- endif
+ TRAY_OBJ = icons/utox-128x128.o
+ TRAY_GEN = $(LD) -r -b binary icons/utox-128x128.png -o
++else ifeq ($(UNAME_S), FreeBSD)
++ OUT_FILE = utox
++
++ DEPS += fontconfig freetype2 x11 xext xrender
++
++ ifeq ($(V4LCONVERT), 1)
++ DEPS += libv4lconvert
++ else
++ CFLAGS += -DNO_V4LCONVERT
++ endif
++
++ ifeq ($(UNITY), 1)
++ DEPS += messaging-menu unity
++ CFLAGS += -DUNITY
++ endif
++
++ ifeq ($(DBUS), 1)
++ DEPS += dbus-1
++ else
++ CFLAGS += -DNO_DBUS
++ endif
++
++ CFLAGS += $(shell pkg-config --cflags $(DEPS))
++
++ LDFLAGS += $(shell pkg-config --libs $(DEPS))
++
++ OS_SRC = $(wildcard src/xlib/*.c)
++ OS_OBJ = $(OS_SRC:.c=.o)
++
++ TRAY_OBJ = icons/utox-128x128.o
++ TRAY_GEN = $(LD) -r -b binary icons/utox-128x128.png -o
+ else ifeq ($(UNAME_O), Cygwin)
+ OUT_FILE = utox.exe
- ifeq ($(UNITY), 1)