aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/cannonball/Makefile15
-rw-r--r--emulators/cannonball/distinfo6
-rw-r--r--emulators/cannonball/files/patch-cmake_linux.cmake20
3 files changed, 31 insertions, 10 deletions
diff --git a/emulators/cannonball/Makefile b/emulators/cannonball/Makefile
index cb33ca863a12..b1656b1d28ba 100644
--- a/emulators/cannonball/Makefile
+++ b/emulators/cannonball/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= cannonball
-DISTVERSION= g20191023
-PORTREVISION= 1
+DISTVERSION= 0.31
CATEGORIES= emulators games
MAINTAINER= fox@FreeBSD.org
@@ -13,18 +12,20 @@ LICENSE_NAME= MAME license
LICENSE_FILE= ${WRKSRC}/docs/license.txt
LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
-LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/exception/all.hpp:devel/boost-libs
-USES= cmake:insource pkgconfig sdl
+USES= cmake:insource gl pkgconfig sdl
USE_SDL= sdl2
+USE_GL= gl glu
CMAKE_ARGS+= ${WRKSRC}/cmake \
- -DBSD_PREFIX_PATH=${LOCALBASE} \
- -DTARGET=bsd
+ -DTARGET=linux.cmake
+
+CFLAGS+= -I${LOCALBASE}/include
USE_GITHUB= yes
GH_ACCOUNT= djyt
-GH_TAGNAME= b6aa525
+GH_TAGNAME= v${DISTVERSION}
BUILD_WRKSRC= ${WRKSRC}/cmake
CONFIGURE_WRKSRC= ${WRKSRC}/cmake
diff --git a/emulators/cannonball/distinfo b/emulators/cannonball/distinfo
index 7030a63031b5..fb8b58c662dd 100644
--- a/emulators/cannonball/distinfo
+++ b/emulators/cannonball/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1571852926
-SHA256 (djyt-cannonball-g20191023-b6aa525_GH0.tar.gz) = 4ddc436505392c635eed6d0f770792cab115a440db586851196c82ce33c2c196
-SIZE (djyt-cannonball-g20191023-b6aa525_GH0.tar.gz) = 278312
+TIMESTAMP = 1615884344
+SHA256 (djyt-cannonball-0.31-v0.31_GH0.tar.gz) = 8743fcfabeeaf8820ab47196e1b29b1702c1f71b784b6336f79d5f8725bc561b
+SIZE (djyt-cannonball-0.31-v0.31_GH0.tar.gz) = 269125
diff --git a/emulators/cannonball/files/patch-cmake_linux.cmake b/emulators/cannonball/files/patch-cmake_linux.cmake
new file mode 100644
index 000000000000..c2bc805f8646
--- /dev/null
+++ b/emulators/cannonball/files/patch-cmake_linux.cmake
@@ -0,0 +1,20 @@
+Adds support for building in BSD.
+
+Will be removed once upstream makes a release with
+https://github.com/djyt/cannonball/commit/a9c71cbf229b9f808ae172a09d12a773fc869209
+
+--- cmake/linux.cmake.orig 2021-03-16 11:22:26 UTC
++++ cmake/linux.cmake
+@@ -0,0 +1,12 @@
++# -----------------------------------------------------------------------------
++# CannonBall BSD Setup
++# -----------------------------------------------------------------------------
++
++# Use OpenGL for rendering.
++find_package(OpenGL REQUIRED)
++
++# Platform Specific Libraries
++set(platform_link_libs
++ ${OPENGL_LIBRARIES}
++)
++