aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/pd/Makefile8
-rw-r--r--audio/tse3/Makefile4
-rw-r--r--comms/obexapp/Makefile4
-rw-r--r--devel/cc65/Makefile3
-rw-r--r--games/abridge/Makefile8
-rw-r--r--lang/yap/Makefile4
-rw-r--r--sysutils/progsreiserfs/Makefile4
-rw-r--r--www/wsmake/Makefile8
8 files changed, 38 insertions, 5 deletions
diff --git a/audio/pd/Makefile b/audio/pd/Makefile
index 3ef1d77b2bab..9f468869c9dd 100644
--- a/audio/pd/Makefile
+++ b/audio/pd/Makefile
@@ -30,6 +30,12 @@ USE_X_PREFIX= yes
USE_AUTOCONF_VER= 259
WRKSRC= ${WRKDIR}/pd-0.37-1test1/src
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
pre-patch:
${RM} -f ${WRKSRC}/configure
@@ -86,4 +92,4 @@ do-install:
${MKDIR} ${DATADIR}
cd ${WRKSRC}/../extra && ${PAX} -r -w * ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/tse3/Makefile b/audio/tse3/Makefile
index d55d8e3c3a64..6d2f4d2f1a05 100644
--- a/audio/tse3/Makefile
+++ b/audio/tse3/Makefile
@@ -26,6 +26,10 @@ MAN3= tse3.3
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} -n "checking for SNDCTL_SEQ_GETTIME in sys/soundcard.h... "
diff --git a/comms/obexapp/Makefile b/comms/obexapp/Makefile
index 979c826562a6..639a6dc9cebc 100644
--- a/comms/obexapp/Makefile
+++ b/comms/obexapp/Makefile
@@ -32,4 +32,8 @@ IGNORE= Needs -CURRENT from 20 Jan 2004 or later (sdpd)
ONLY_FOR_ARCHS= i386
.endif
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/cc65/Makefile b/devel/cc65/Makefile
index 95d8383cc3eb..edf02e498a24 100644
--- a/devel/cc65/Makefile
+++ b/devel/cc65/Makefile
@@ -29,6 +29,9 @@ CFLAGS+= -DCC65_INC=\\\"${PREFIX}/lib/cc65/include\\\" \
# Need ${WRKSRC} so that the (slightly ugly) != assignments work
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
WRKDIR?= ${WRKDIRPREFIX}${.CURDIR}/work
WRKSRC= ${WRKDIR}/cc65-${PORTVERSION}
diff --git a/games/abridge/Makefile b/games/abridge/Makefile
index 041c914c157f..aec7c188920f 100644
--- a/games/abridge/Makefile
+++ b/games/abridge/Makefile
@@ -22,4 +22,10 @@ CONFIGURE_ARGS= --with-wx-config=${X11BASE}/bin/wxgtk2-2.4-config
MAN1= abridge.1
PLIST_FILES= bin/abridge
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/yap/Makefile b/lang/yap/Makefile
index 692c41ccde99..e7c8431a4d5b 100644
--- a/lang/yap/Makefile
+++ b/lang/yap/Makefile
@@ -27,8 +27,8 @@ INFO= yap
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha"
-BROKEN= "Does not compile on alpha"
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
.endif
post-extract:
diff --git a/sysutils/progsreiserfs/Makefile b/sysutils/progsreiserfs/Makefile
index 53d6d785263c..93edd6c8c48c 100644
--- a/sysutils/progsreiserfs/Makefile
+++ b/sysutils/progsreiserfs/Makefile
@@ -34,6 +34,10 @@ MAN8= cpfs.reiserfs.8 mkfs.reiserfs.8 reiserfs.8 \
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
.if ${OSVERSION} >= 500041
CFLAGS+= -Dgetopt_long_only=getopt_long
EXTRA_PATCHES= ${FILESDIR}/extrapatch-progsreiserfs::libmisc::Makefile.in
diff --git a/www/wsmake/Makefile b/www/wsmake/Makefile
index 1a9e5d3a4e72..3299be1cfc2e 100644
--- a/www/wsmake/Makefile
+++ b/www/wsmake/Makefile
@@ -25,6 +25,12 @@ USE_REINPLACE= yes
DISTFILES+= user-manual-html.tar.gz
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,void\*,char\*,g' ${WRKSRC}/libwsmake/wsUtil.cpp
@@ -44,4 +50,4 @@ post-install:
${LN} ${DOCSDIR}/user-manual/book1.html ${DOCSDIR}/user-manual/index.html
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>