aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/ppm2fli/Makefile24
-rw-r--r--graphics/ppm2fli/distinfo1
-rw-r--r--graphics/ppm2fli/files/patch-aa19
-rw-r--r--graphics/ppm2fli/pkg-comment1
-rw-r--r--graphics/ppm2fli/pkg-descr19
-rw-r--r--graphics/ppm2fli/pkg-plist4
-rw-r--r--multimedia/ppm2fli/Makefile24
-rw-r--r--multimedia/ppm2fli/distinfo1
-rw-r--r--multimedia/ppm2fli/files/patch-aa19
-rw-r--r--multimedia/ppm2fli/pkg-comment1
-rw-r--r--multimedia/ppm2fli/pkg-descr19
-rw-r--r--multimedia/ppm2fli/pkg-plist4
12 files changed, 136 insertions, 0 deletions
diff --git a/graphics/ppm2fli/Makefile b/graphics/ppm2fli/Makefile
new file mode 100644
index 000000000000..21ce41fde951
--- /dev/null
+++ b/graphics/ppm2fli/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ppm2fli
+# Version required: b1.92
+# Date created: 7 Jan 1998
+# Whom: giffunip@asme.org
+#
+# $Id: $
+#
+
+DISTNAME= ppm2fli_b1.92
+PKGNAME= ppm2fli-b1
+CATEGORIES= graphics misc
+MASTER_SITES= ftp://crusty.er.usgs.gov/pub/animation/fli/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= giffunip@asme.org
+
+MAN1= ppm2fli.1 unflick.1
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ppm2fli ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/unflick ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ppm2fli.man ${PREFIX}/man/man1/ppm2fli.1
+ ${INSTALL_MAN} ${WRKSRC}/unflick.man ${PREFIX}/man/man1/unflick.1
+
+.include <bsd.port.mk>
diff --git a/graphics/ppm2fli/distinfo b/graphics/ppm2fli/distinfo
new file mode 100644
index 000000000000..abd08aeafb36
--- /dev/null
+++ b/graphics/ppm2fli/distinfo
@@ -0,0 +1 @@
+MD5 (ppm2fli_b1.92.tar.Z) = 259c85a90f12e2332c56ca75560bfbd2
diff --git a/graphics/ppm2fli/files/patch-aa b/graphics/ppm2fli/files/patch-aa
new file mode 100644
index 000000000000..ab8fcfd06a68
--- /dev/null
+++ b/graphics/ppm2fli/files/patch-aa
@@ -0,0 +1,19 @@
+*** Makefile.orig Fri Feb 13 01:15:45 1998
+--- Makefile Fri Feb 13 01:16:02 1998
+***************
+*** 9,15 ****
+ #
+ # Cflags
+ #
+! CFLAGS=-O2 -Wall
+ # ------------------------------------------------------------------
+
+ .c.o:
+--- 9,15 ----
+ #
+ # Cflags
+ #
+! CFLAGS+=-O2 -Wall
+ # ------------------------------------------------------------------
+
+ .c.o:
diff --git a/graphics/ppm2fli/pkg-comment b/graphics/ppm2fli/pkg-comment
new file mode 100644
index 000000000000..49a90efc7944
--- /dev/null
+++ b/graphics/ppm2fli/pkg-comment
@@ -0,0 +1 @@
+Utilities to merge PPM files into animated FLI and backwards.
diff --git a/graphics/ppm2fli/pkg-descr b/graphics/ppm2fli/pkg-descr
new file mode 100644
index 000000000000..13e9cd78d5a9
--- /dev/null
+++ b/graphics/ppm2fli/pkg-descr
@@ -0,0 +1,19 @@
+PPM2FLI can read directly PPM,PGM,PBM and FBM files. If necessary it
+performs a quantization. The filters of the NETPBM, PBMPLUS and FBM package
+can be used as read filters. Together with one of this packages
+a large number of image formats can be handled.
+
+UNFLICK writes images in PPM or FBM format.
+
+In contrast to FBM2FLI no additional package is required to build
+PPM2FLI and UNFLICK. So it can be used without any of the above mentioned
+packages, if another source of PPM,PGM,PBM or FBM images is available.
+For example, PS images can be animated using ghostscript.
+
+The current version is call `beta' because some parts are relative new
+and not totally tested. I made tests on SUN sparc-stations (various versions
+of SUN-OS), on PC running LINUX and under MSDOS using the DJGPP DOS-extender.
+In all cases the GCC compiler was used. Under MSDOS I used a modified
+makefile. Anyway, in some environments changes in the makefile are necessary.
+
+-- Klaus Ehrenfried (klaus@es.go.dlr.de)
diff --git a/graphics/ppm2fli/pkg-plist b/graphics/ppm2fli/pkg-plist
new file mode 100644
index 000000000000..729157bda847
--- /dev/null
+++ b/graphics/ppm2fli/pkg-plist
@@ -0,0 +1,4 @@
+bin/ppm2fli
+bin/unflick
+man/man1/ppm2fli.1.gz
+man/man1/unflick.1.gz
diff --git a/multimedia/ppm2fli/Makefile b/multimedia/ppm2fli/Makefile
new file mode 100644
index 000000000000..21ce41fde951
--- /dev/null
+++ b/multimedia/ppm2fli/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: ppm2fli
+# Version required: b1.92
+# Date created: 7 Jan 1998
+# Whom: giffunip@asme.org
+#
+# $Id: $
+#
+
+DISTNAME= ppm2fli_b1.92
+PKGNAME= ppm2fli-b1
+CATEGORIES= graphics misc
+MASTER_SITES= ftp://crusty.er.usgs.gov/pub/animation/fli/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= giffunip@asme.org
+
+MAN1= ppm2fli.1 unflick.1
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ppm2fli ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/unflick ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ppm2fli.man ${PREFIX}/man/man1/ppm2fli.1
+ ${INSTALL_MAN} ${WRKSRC}/unflick.man ${PREFIX}/man/man1/unflick.1
+
+.include <bsd.port.mk>
diff --git a/multimedia/ppm2fli/distinfo b/multimedia/ppm2fli/distinfo
new file mode 100644
index 000000000000..abd08aeafb36
--- /dev/null
+++ b/multimedia/ppm2fli/distinfo
@@ -0,0 +1 @@
+MD5 (ppm2fli_b1.92.tar.Z) = 259c85a90f12e2332c56ca75560bfbd2
diff --git a/multimedia/ppm2fli/files/patch-aa b/multimedia/ppm2fli/files/patch-aa
new file mode 100644
index 000000000000..ab8fcfd06a68
--- /dev/null
+++ b/multimedia/ppm2fli/files/patch-aa
@@ -0,0 +1,19 @@
+*** Makefile.orig Fri Feb 13 01:15:45 1998
+--- Makefile Fri Feb 13 01:16:02 1998
+***************
+*** 9,15 ****
+ #
+ # Cflags
+ #
+! CFLAGS=-O2 -Wall
+ # ------------------------------------------------------------------
+
+ .c.o:
+--- 9,15 ----
+ #
+ # Cflags
+ #
+! CFLAGS+=-O2 -Wall
+ # ------------------------------------------------------------------
+
+ .c.o:
diff --git a/multimedia/ppm2fli/pkg-comment b/multimedia/ppm2fli/pkg-comment
new file mode 100644
index 000000000000..49a90efc7944
--- /dev/null
+++ b/multimedia/ppm2fli/pkg-comment
@@ -0,0 +1 @@
+Utilities to merge PPM files into animated FLI and backwards.
diff --git a/multimedia/ppm2fli/pkg-descr b/multimedia/ppm2fli/pkg-descr
new file mode 100644
index 000000000000..13e9cd78d5a9
--- /dev/null
+++ b/multimedia/ppm2fli/pkg-descr
@@ -0,0 +1,19 @@
+PPM2FLI can read directly PPM,PGM,PBM and FBM files. If necessary it
+performs a quantization. The filters of the NETPBM, PBMPLUS and FBM package
+can be used as read filters. Together with one of this packages
+a large number of image formats can be handled.
+
+UNFLICK writes images in PPM or FBM format.
+
+In contrast to FBM2FLI no additional package is required to build
+PPM2FLI and UNFLICK. So it can be used without any of the above mentioned
+packages, if another source of PPM,PGM,PBM or FBM images is available.
+For example, PS images can be animated using ghostscript.
+
+The current version is call `beta' because some parts are relative new
+and not totally tested. I made tests on SUN sparc-stations (various versions
+of SUN-OS), on PC running LINUX and under MSDOS using the DJGPP DOS-extender.
+In all cases the GCC compiler was used. Under MSDOS I used a modified
+makefile. Anyway, in some environments changes in the makefile are necessary.
+
+-- Klaus Ehrenfried (klaus@es.go.dlr.de)
diff --git a/multimedia/ppm2fli/pkg-plist b/multimedia/ppm2fli/pkg-plist
new file mode 100644
index 000000000000..729157bda847
--- /dev/null
+++ b/multimedia/ppm2fli/pkg-plist
@@ -0,0 +1,4 @@
+bin/ppm2fli
+bin/unflick
+man/man1/ppm2fli.1.gz
+man/man1/unflick.1.gz