aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/superkaramba/Makefile3
-rw-r--r--devel/py-krosspython/Makefile3
-rw-r--r--devel/py-pykde4/Makefile3
-rw-r--r--devel/py-pykdeuic4/Makefile3
-rw-r--r--devel/py-qt4-qscintilla2/Makefile2
-rw-r--r--devel/py-qt4/Makefile2
-rw-r--r--devel/py-qt4/bsd.pyqt.mk2
-rw-r--r--devel/py-sip/Makefile3
-rw-r--r--editors/kate-plugin-pate/Makefile3
-rw-r--r--games/kajongg/Makefile3
-rw-r--r--lang/qt5-qml/Makefile3
-rw-r--r--math/cantor/Makefile3
-rw-r--r--misc/py-qt4-demo/Makefile3
-rw-r--r--misc/py-qt4-doc/Makefile3
-rw-r--r--net-im/telepathy-logger-qt4/Makefile3
-rw-r--r--net-im/telepathy-logger/Makefile3
-rw-r--r--sysutils/qzeitgeist/Makefile3
-rw-r--r--www/webkit-qt5/Makefile3
-rw-r--r--x11/plasma-scriptengine-python/Makefile3
19 files changed, 21 insertions, 33 deletions
diff --git a/deskutils/superkaramba/Makefile b/deskutils/superkaramba/Makefile
index c64ad8375e16..8ad7a7506908 100644
--- a/deskutils/superkaramba/Makefile
+++ b/deskutils/superkaramba/Makefile
@@ -10,9 +10,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Widget framework for KDE
-USE_PYTHON= 2
USE_KDE4= kdehier kdelibs kdeprefix automoc4 qimageblitz
-USES= cmake:outsource tar:xz
+USES= cmake:outsource python:2 tar:xz
USE_QT4= qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/devel/py-krosspython/Makefile b/devel/py-krosspython/Makefile
index 5a9e294a688e..8b2a2e73feed 100644
--- a/devel/py-krosspython/Makefile
+++ b/devel/py-krosspython/Makefile
@@ -13,9 +13,8 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Kross Python scripting library
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-USE_PYTHON= 2
USE_QT4= corelib gui qmake_build moc_build uic_build rcc_build
-USES= cmake:outsource tar:xz
+USES= cmake:outsource python:2 tar:xz
CMAKE_ARGS+= -DBUILD_falcon:BOOL=FALSE \
-DBUILD_ruby:BOOL=FALSE \
-DBUILD_java:BOOL=FALSE
diff --git a/devel/py-pykde4/Makefile b/devel/py-pykde4/Makefile
index c8240db2cbd3..d04e68dad0c6 100644
--- a/devel/py-pykde4/Makefile
+++ b/devel/py-pykde4/Makefile
@@ -28,10 +28,9 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
USE_KDE4= kdehier kdelibs kdeprefix okular pimlibs \
akonadi automoc4 soprano
-USE_PYTHON= 2
USE_QT4= corelib dbus designer_build gui network xml \
qmake_build moc_build uic_build rcc_build
-USES= cmake:outsource tar:xz
+USES= cmake:outsource python:2 tar:xz
CMAKE_ARGS+= -DWITH_PolkitQt:BOOL=FALSE
SUB_FILES= kdebindings4.pth
diff --git a/devel/py-pykdeuic4/Makefile b/devel/py-pykdeuic4/Makefile
index 3fd903b86b6a..cadc24aa30f2 100644
--- a/devel/py-pykdeuic4/Makefile
+++ b/devel/py-pykdeuic4/Makefile
@@ -13,10 +13,9 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Enhanced version of pyuic4
USE_KDE4= kdelibs automoc4 pykde4
-USE_PYTHON= 2
USE_QT4= moc_build qmake_build rcc_build uic_build
DISTINFO_FILE= ${PORTSDIR}/devel/py-pykde4/distinfo
-USES= cmake:outsource tar:xz
+USES= cmake:outsource python:2 tar:xz
WRKSRC= ${WRKDIR}/${DISTNAME}/tools/${PORTNAME}
diff --git a/devel/py-qt4-qscintilla2/Makefile b/devel/py-qt4-qscintilla2/Makefile
index 0639eeaef3f2..bd88dd9ec9f7 100644
--- a/devel/py-qt4-qscintilla2/Makefile
+++ b/devel/py-qt4-qscintilla2/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
DESTDIRNAME= INSTALL_ROOT
DISTINFO_FILE= ${QSCI2_DISTINFO_FILE}
HAS_CONFIGURE= yes
-USE_PYTHON= yes
+USES= python
USE_QT4= gui moc_build qmake_build
QT_NONSTANDARD= yes # Do not add unknown arguments to CONFIGURE_ARGS.
diff --git a/devel/py-qt4/Makefile b/devel/py-qt4/Makefile
index 4ecda7b3cdeb..8c8df74170fc 100644
--- a/devel/py-qt4/Makefile
+++ b/devel/py-qt4/Makefile
@@ -13,7 +13,7 @@ EXTRACT_ONLY= # empty
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt 4 toolkit (meta port)
-USE_PYTHON= yes
+USES= python
NO_BUILD= yes
NO_INSTALL= yes
diff --git a/devel/py-qt4/bsd.pyqt.mk b/devel/py-qt4/bsd.pyqt.mk
index fe82606e22ac..abc2b3161868 100644
--- a/devel/py-qt4/bsd.pyqt.mk
+++ b/devel/py-qt4/bsd.pyqt.mk
@@ -93,7 +93,7 @@ DISTNAME= ${PYQT4_DISTNAME}
DISTINFO_FILE= ${PYQT4_DISTINFO_FILE}
HAS_CONFIGURE= yes
-USE_PYTHON= yes
+USES= python
QT_NONSTANDARD= yes # Do not add unknown arguments to CONFIGURE_ARGS.
diff --git a/devel/py-sip/Makefile b/devel/py-sip/Makefile
index 32c739767d95..866687e2dfef 100644
--- a/devel/py-sip/Makefile
+++ b/devel/py-sip/Makefile
@@ -12,8 +12,7 @@ DISTNAME= ${SIP_DISTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= Python to C and C++ bindings generator
-USE_PYTHON= yes
-PYTHON_PY3K_PLIST_HACK= yes
+USE= python:py3kplist
DATADIR= ${PREFIX}/share/py-${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
diff --git a/editors/kate-plugin-pate/Makefile b/editors/kate-plugin-pate/Makefile
index d0c3af253c5f..868753a39dd6 100644
--- a/editors/kate-plugin-pate/Makefile
+++ b/editors/kate-plugin-pate/Makefile
@@ -11,12 +11,11 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Support for Python plugins in Kate
-USES= cmake:outsource tar:xz
+USES= cmake:outsource python tar:xz
USE_KDE4= kdelibs kdeprefix kdehier automoc4 kate \
pykde4_build pykde4_run
USE_QT4= gui webkit \
moc_build qmake_build rcc_build uic_build
-USE_PYTHON= yes
DISTINFO_FILE= ${PORTSDIR}/editors/kate/distinfo
diff --git a/games/kajongg/Makefile b/games/kajongg/Makefile
index c6794865fc7b..301e347b90cf 100644
--- a/games/kajongg/Makefile
+++ b/games/kajongg/Makefile
@@ -10,10 +10,9 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource tar:xz twisted:run
+USES= cmake:outsource python tar:xz twisted:run
USE_KDE4= kdehier kdelibs kdeprefix pykde4 automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
-USE_PYTHON= yes
USE_SQLITE= 3
CMAKE_ARGS= -DINSTALL_KAJONGG:BOOL=TRUE
diff --git a/lang/qt5-qml/Makefile b/lang/qt5-qml/Makefile
index 2a28a4528518..dff964d18527 100644
--- a/lang/qt5-qml/Makefile
+++ b/lang/qt5-qml/Makefile
@@ -11,8 +11,7 @@ COMMENT= Qt QML and JavaScript language module
USE_QT5= core network buildtools_build
QT_DIST= declarative
-USES= qmake
-USE_PYTHON_BUILD= yes
+USES= python:build qmake
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
WRKSRC_SUBDIR= src/${PORTNAME}
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index afdfec4d00a0..2aa366c9dead 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -15,10 +15,9 @@ LIB_DEPENDS= libspectre.so:${PORTSDIR}/print/libspectre \
libanalitza.so:${PORTSDIR}/math/analitza
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-USES= cmake:outsource pkgconfig tar:xz
+USES= cmake:outsource pkgconfig python:2 tar:xz
USE_QT4= corelib qtestlib_build xml xmlpatterns \
moc_build qmake_build rcc_build uic_build
-USE_PYTHON= 2
USE_LDCONFIG= yes
OPTIONS_DEFINE= MAXIMA OCTAVE R SAGE SCILAB
diff --git a/misc/py-qt4-demo/Makefile b/misc/py-qt4-demo/Makefile
index 29f09a2e3ac6..d0435e879048 100644
--- a/misc/py-qt4-demo/Makefile
+++ b/misc/py-qt4-demo/Makefile
@@ -13,7 +13,8 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt4 toolkit, Qt demo and examples
DISTINFO_FILE= ${PYQT4_DISTINFO_FILE}
-USE_PYTHON= yes
+
+USES= python
EXAMPLESDIR= ${PREFIX}/share/examples/py-qt4
diff --git a/misc/py-qt4-doc/Makefile b/misc/py-qt4-doc/Makefile
index fbaaa190448a..7e8fc69ffb42 100644
--- a/misc/py-qt4-doc/Makefile
+++ b/misc/py-qt4-doc/Makefile
@@ -14,7 +14,8 @@ COMMENT= Python bindings for the Qt4 toolkit, documentation
DISTINFO_FILE= ${PYQT4_DISTINFO_FILE}
NO_BUILD= yes
-USE_PYTHON= yes
+
+USES= python
DOCSDIR= ${PREFIX}/share/doc/py-qt4
diff --git a/net-im/telepathy-logger-qt4/Makefile b/net-im/telepathy-logger-qt4/Makefile
index 058151add150..1eae98b2a97f 100644
--- a/net-im/telepathy-logger-qt4/Makefile
+++ b/net-im/telepathy-logger-qt4/Makefile
@@ -22,9 +22,8 @@ LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
USE_GNOME= glib20 libxml2
USE_GSTREAMER= qt4
USE_KDE4= # empty
-USE_PYTHON_BUILD= yes
USE_QT4= corelib dbus moc_build qmake_build rcc_build uic_build
-USES= bison:build cmake pkgconfig tar:bzip2
+USES= bison:build cmake pkgconfig python:build tar:bzip2
CMAKE_ARGS= -DUSE_COMMON_CMAKE_PACKAGE_CONFIG_DIR:BOOL=True
USE_LDCONFIG= yes
diff --git a/net-im/telepathy-logger/Makefile b/net-im/telepathy-logger/Makefile
index 2a8155838743..47850c6f82b4 100644
--- a/net-im/telepathy-logger/Makefile
+++ b/net-im/telepathy-logger/Makefile
@@ -16,13 +16,12 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
LICENSE= LGPL21
-USES= pkgconfig gmake libtool pathfix tar:bzip2
+USES= pkgconfig gmake libtool pathfix python:build tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= glib20 intltool gnomedocutils libxml2 \
libxslt:build introspection:build
USE_SQLITE= yes
-USE_PYTHON_BUILD= yes
GLIB_SCHEMAS= org.freedesktop.Telepathy.Logger.gschema.xml
post-patch:
diff --git a/sysutils/qzeitgeist/Makefile b/sysutils/qzeitgeist/Makefile
index db4028a14df4..4217f9acda46 100644
--- a/sysutils/qzeitgeist/Makefile
+++ b/sysutils/qzeitgeist/Makefile
@@ -22,10 +22,9 @@ BUILD_DEPENDS= rapper:${PORTSDIR}/textproc/raptor2 \
${PYTHON_SITELIBDIR}/rdflib/__init__.py:${PORTSDIR}/textproc/py-rdflib
USE_KDE4= automoc4
-USE_PYTHON_BUILD= yes
USE_QT4= dbus declarative qtestlib \
moc_build qmake_build rcc_build uic_build
-USES= tar:bzip2 cmake
+USES= cmake python:build tar:bzip2
USE_LDCONFIG= yes
# To be kept in sync with sysutils/zeitgeist.
diff --git a/www/webkit-qt5/Makefile b/www/webkit-qt5/Makefile
index d8a08e4f497d..8162892c3f79 100644
--- a/www/webkit-qt5/Makefile
+++ b/www/webkit-qt5/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
USE_GL= gl
USE_GNOME= libxml2 libxslt
USE_PERL5= build
-USE_PYTHON_BUILD= yes
USE_QT5= core gui network opengl printsupport qml quick sql \
testlib widgets buildtools_build
QT_DIST= ${PORTNAME}
@@ -27,7 +26,7 @@ USE_RUBY= yes
RUBY_NO_RUN_DEPENDS= yes
USE_SQLITE= 3
USE_XORG= x11 xcomposite xrender
-USES= bison:build gmake perl5 pkgconfig qmake:outsource
+USES= bison:build gmake perl5 pkgconfig python:build qmake:outsource
# Keep make(1) from descending into obj/ subdirectories during tests.
CONFIGURE_ENV= MAKEOBJDIR=.
# Use flex(1) from ports.
diff --git a/x11/plasma-scriptengine-python/Makefile b/x11/plasma-scriptengine-python/Makefile
index 6961d4aaa182..4dd90248e734 100644
--- a/x11/plasma-scriptengine-python/Makefile
+++ b/x11/plasma-scriptengine-python/Makefile
@@ -13,9 +13,8 @@ COMMENT= Plasma scriptengine for Python
USE_KDE4= kdehier kdelibs kdeprefix pykde4 automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build
-USE_PYTHON= 2
DISTINFO_FILE= ${PORTSDIR}/x11/kde4-workspace/distinfo
-USES= cmake:outsource tar:xz
+USES= cmake:outsource python:2 tar:xz
CMAKE_SOURCE_PATH= ${WRKSRC}/plasma/generic/scriptengines/python