aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING8
-rw-r--r--news/cnews/Makefile93
-rw-r--r--news/cnews/files/patch-cpto11
-rw-r--r--news/cnews/files/patch-input-makefile11
-rw-r--r--news/cnews/files/patch-mkdirs14
-rw-r--r--news/cnews/files/pkg-message.in9
-rw-r--r--news/cnews/pkg-plist129
7 files changed, 168 insertions, 107 deletions
diff --git a/UPDATING b/UPDATING
index f1e847143ba0..1dffacb2cb67 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20131218:
+ AFFECTS: users of news/cnews
+ AUTHOR: dinoex@FreeBSD.org
+
+ The default path for overview files has changed.
+ Rebuild your overview files after the update with:
+ su - news /usr/local/libexec/cnews/nov/initov
+
20131217:
AFFECTS: users of databases/ruby-bdb or ports-mgmt/portupgrade and databases/db5 or databases/db6
AUTHOR: mandree@FreeBSD.org
diff --git a/news/cnews/Makefile b/news/cnews/Makefile
index 21fc4ece1e8f..e81824052202 100644
--- a/news/cnews/Makefile
+++ b/news/cnews/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cnews
PORTVERSION= cr.g
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= news
MASTER_SITES= ftp://ftp.cs.toronto.edu/pub/c-news/ \
ftp://ftp.funet.fi/pub/unix/news/cnews/ \
@@ -36,13 +36,13 @@ LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
USE_GCC= any
DIST_SUBDIR= ${DISTNAME}
NO_WRKSUBDIR= yes
MAKEFILE= makefile
+SUB_FILES= pkg-message
MAN1= checknews.1cn inews.1cn postnews.1cn readnews.1cn
MAN5= controlperm.5 news.5 newsctl.5 newsdb.5 newsoverview.5 \
newssys.5
@@ -50,10 +50,14 @@ MAN8= cnewsdo.8cn expire.8cn explode.8cn mergeactive.8 \
mkhistory.8cn newsaux.8cn newsbatch.8cn newsmail.8cn \
newsmaint.8cn newsoverview.8 relaynews.8cn report.8cn \
rnews.8cn
+NO_EG_FILES= active.times inews organization postdefltgroup readnews.ctl \
+ readnews.help report.ctl versionname
NEWSCTL_FILES= active active.times batchparms controlperm explist \
history history.dir history.pag inews mailname mailpaths \
organization postdefltgroup readnews.ctl readnews.help \
report.ctl sys versionname whoami
+
+SUB_LIST+= NEWSCTL=${NEWSCTL}
PLIST_SUB+= VARBASE=${VARBASE}
PLIST_SUB+= NEWSBIN=${NEWSBIN:S=^${PREFIX}/==}
PLIST_SUB+= NEWSCTL=${NEWSCTL:S=^${VARBASE}/==}
@@ -62,92 +66,71 @@ PLIST_SUB+= NEWSARTS=${NEWSARTS:S=^${VARBASE}/==}
PLIST_SUB+= NEWSOV=${NEWSOV:S=^${VARBASE}/==}
PLIST_SUB+= NEWSCTL_FILES="${NEWSCTL_FILES}"
-MODIFY= conf/quiz.def \
- conf/substitutions \
- include/config.make
+OPTIONS_DEFINE= SENDMAIL
+SENDMAIL_DESC= use sendmail instead of /bin/mail
VARBASE?= /var
NEWSBIN?= ${PREFIX}/libexec/cnews
NEWSCTL?= ${VARBASE}/lib/news
NEWSARTS?= ${VARBASE}/news
-NEWSOV?= ${VARBASE}/news
+NEWSOV?= ${VARBASE}/news/over.view
PGPVERIFY?= pgpverify-1.12
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if make(makesum) || defined(FETCH_ALL)
PATCHFILES+= c-news-patch-gawk3
.endif
-.if defined(WITH_SENDMAIL) || defined(WITH_CNEWS_SENDMAIL)
+.if ${PORT_OPTIONS:MSENDMAIL}
EXTRA_PATCHES+= ${FILESDIR}/sendmail.patch
.endif
pre-patch:
- @${CP} ${DISTDIR}/${DIST_SUBDIR}/${PGPVERIFY} ${WRKSRC}/${PGPVERIFY}
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${PGPVERIFY} ${WRKSRC}/${PGPVERIFY}
pre-configure:
-.for i in ${MODIFY}
- @${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.sed
- ${SED} \
+.for i in conf/quiz.def conf/substitutions include/config.make
+ ${REINPLACE_CMD} \
-e "s=/usr/local/news/lib/bin/config=${NEWSBIN}/config=" \
-e "s=/usr/local/news/cnewsbin=${NEWSBIN}=" \
-e "s=/usr/local/news/lib=${NEWSCTL}=" \
-e "s=/var/news/over.view=${NEWSOV}=" \
-e "s=/var/news=${NEWSARTS}=" \
-e "s=/usr/local/bin=${PREFIX}/bin=" \
- ${WRKSRC}/${i}.sed > ${WRKSRC}/${i}
+ ${WRKSRC}/${i}
.endfor
do-install:
- ${RM} -f ${PREFIX}/bin/inews
- ${INSTALL_DATA} ${WRKSRC}/libdbz/dbz.h ${PREFIX}/include
- ${INSTALL_DATA} ${WRKSRC}/libcnews.a ${PREFIX}/lib
- ${MKDIR} ${NEWSARTS} ${NEWSOV} ${NEWSBIN} ${NEWSCTL}
- ${CHOWN} ${BINOWN}:${BINGRP} ${NEWSBIN}
- ${INSTALL_SCRIPT} ${WRKSRC}/${PGPVERIFY} ${NEWSBIN}/pgpverify
- cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install
- cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} setup
- cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ui readpostcheck
-.for f in checknews cnewsdo inews injnews postnews readnews
- ${CHOWN} ${BINOWN}:${BINGRP} ${PREFIX}/bin/$f
+ ${INSTALL_DATA} ${WRKSRC}/libdbz/dbz.h ${STAGEDIR}${PREFIX}/include/
+ ${INSTALL_DATA} ${WRKSRC}/libcnews.a ${STAGEDIR}${PREFIX}/lib/
+ ${MKDIR} ${STAGEDIR}${NEWSARTS} ${STAGEDIR}${NEWSOV} \
+ ${STAGEDIR}${NEWSCTL} ${STAGEDIR}${NEWSBIN}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PGPVERIFY} ${STAGEDIR}${NEWSBIN}/pgpverify
+ ${INSTALL_SCRIPT} ${WRKSRC}/conf/config ${STAGEDIR}${NEWSBIN}/
+ cd ${WRKSRC} && ${MAKE} ${MAKE_ARGS} ${MAKE_FLAGS} ${MAKEFILE} install
+ cd ${WRKSRC} && ${MAKE} ${MAKE_ARGS} ${MAKE_FLAGS} ${MAKEFILE} ui readpostcheck
+ cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN1} ${STAGEDIR}${PREFIX}/man/man1/
+ cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN5} ${STAGEDIR}${PREFIX}/man/man5/
+ cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN8} ${STAGEDIR}${PREFIX}/man/man8/
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/newsctl
+ cd ${WRKSRC} && ${INSTALL_DATA} ${NO_EG_FILES:S,^,*/,} \
+ ${STAGEDIR}${EXAMPLESDIR}/newsctl/
+.for f in active batchparms controlperm explist mailname mailpaths sys whoami
+ cd ${WRKSRC} && ${CP} -p */${f}.eg ${STAGEDIR}${EXAMPLESDIR}/newsctl/${f}
.endfor
- ${CHOWN} news:news ${NEWSARTS} ${NEWSOV} ${NEWSCTL} ${NEWSCTL}/bin
+ ${TOUCH} ${STAGEDIR}${EXAMPLESDIR}/newsctl/history
+ cd ${STAGEDIR}${EXAMPLESDIR}/newsctl && \
+ ${STAGEDIR}${NEWSBIN}/dbz history
+.endif
.for d in control junk news/announce/newusers news/announce news \
in.coming/bad in.coming out.going out.master out.nntp
- ${CHOWN} news:news ${NEWSARTS}/${d}
-.endfor
- ${CHOWN} news:news ${NEWSBIN}/input/newsspool
- ${CHMOD} 6555 ${NEWSBIN}/input/newsspool
-.for i in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/man/${i} ${PREFIX}/man/man1
+ ${MKDIR} ${STAGEDIR}${NEWSARTS}/${d}
.endfor
-.for i in ${MAN5}
- ${INSTALL_MAN} ${WRKSRC}/man/${i} ${PREFIX}/man/man5
-.endfor
-.for i in ${MAN8}
- ${INSTALL_MAN} ${WRKSRC}/man/${i} ${PREFIX}/man/man8
-.endfor
- ${MKDIR} ${EXAMPLESDIR}/newsctl
- @${TAR} -C ${NEWSCTL} -cf - . | ${TAR} -C ${EXAMPLESDIR}/newsctl -xf -
- @${ECHO_MSG} ""
- @${ECHO_MSG} "!!!!!!!!"
- @${ECHO_MSG} "you MUST change the configuration of this news setup:"
- @${ECHO_MSG} " cd to ${NEWSCTL} and change the following files..."
- @${ECHO_MSG} "mailname, whoami, organization, mailpaths, sys, readnews.ctl, postdefltgroup"
- @${ECHO_MSG} " to suit your local system and news topology."
- @${ECHO_MSG} "check that you have vaild aliases in report.ctl,"
- @${ECHO_MSG} " so any problem can be reported."
- @${ECHO_MSG} "!!!!!!!!"
- @${ECHO_MSG} ""
-.if !defined(BATCH)
- @if test "$$(pw usershow news)" != "news:*:8:8::0:0:News Subsystem:${NEWSCTL}:${SHELL}"; then \
- pw usermod news -d "${NEWSCTL}" -s ${SHELL}; fi
- @pw usershow news
-.endif
test:
(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} r)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/news/cnews/files/patch-cpto b/news/cnews/files/patch-cpto
new file mode 100644
index 000000000000..c9626d5956e2
--- /dev/null
+++ b/news/cnews/files/patch-cpto
@@ -0,0 +1,11 @@
+--- conf/cpto.orig 1994-09-15 22:42:45.000000000 +0200
++++ conf/cpto 2013-12-18 11:12:51.000000000 +0100
+@@ -21,7 +21,7 @@
+ 0|1) echo "Usage: $0 dir file ..." >&2 ; exit 2 ;;
+ esac
+
+-dest="$1"
++dest="${DESTDIR}$1"
+ shift
+ if test ! -d "$dest"
+ then
diff --git a/news/cnews/files/patch-input-makefile b/news/cnews/files/patch-input-makefile
new file mode 100644
index 000000000000..0beef71164fa
--- /dev/null
+++ b/news/cnews/files/patch-input-makefile
@@ -0,0 +1,11 @@
+--- input/makefile.orig 1995-01-02 22:48:40.000000000 +0100
++++ input/makefile 2013-12-18 11:20:24.000000000 +0100
+@@ -17,7 +17,7 @@
+
+ install: $(PROGS)
+ $(MKDIR) $(DEST) $(DBIN)
+- rm -f $(DEST)/newsspool
++ rm -f ${DESTDIR}$(DEST)/newsspool
+ $(TO) $(DEST) $(PROGS)
+ $(TO) $(RBIN) $(RCVRS)
+ $(TO) $(DBIN) $(DECS)
diff --git a/news/cnews/files/patch-mkdirs b/news/cnews/files/patch-mkdirs
new file mode 100644
index 000000000000..7af0ec163667
--- /dev/null
+++ b/news/cnews/files/patch-mkdirs
@@ -0,0 +1,14 @@
+--- conf/mkdirs.orig 1993-07-11 05:10:40.000000000 +0200
++++ conf/mkdirs 2013-12-18 11:18:16.000000000 +0100
+@@ -1,9 +1,9 @@
+ #! /bin/sh
+ for d
+ do
+- if test ! -d "$d"
++ if test ! -d "${DESTDIR}$d"
+ then
+- mkdir "$d" || exit 1
++ mkdir "${DESTDIR}$d" || exit 1
+ fi
+ done
+ exit 0
diff --git a/news/cnews/files/pkg-message.in b/news/cnews/files/pkg-message.in
new file mode 100644
index 000000000000..b780102da41f
--- /dev/null
+++ b/news/cnews/files/pkg-message.in
@@ -0,0 +1,9 @@
+you MUST change the configuration of this news setup:
+ cd to %%NEWSCTL%% and change the following files...
+mailname, whoami, organization, mailpaths, sys, readnews.ctl, postdefltgroup
+ to suit your local system and news topology.
+check that you have vaild aliases in report.ctl,
+ so any problem can be reported.
+
+for ease of administration you may add a shell:
+pw usermod news -d %%NEWSCTL%% -s /bin/csh
diff --git a/news/cnews/pkg-plist b/news/cnews/pkg-plist
index a3dab80da8cf..e0daf512ac55 100644
--- a/news/cnews/pkg-plist
+++ b/news/cnews/pkg-plist
@@ -1,6 +1,3 @@
-@comment Package is not complete without minimal /var/news installation :-(
-@comment Basically just in.* and out.* /var/news might be a symbolic link
-@comment and it might not exist yet :-(
bin/checknews
bin/cnewsdo
bin/inews
@@ -9,6 +6,29 @@ bin/postnews
bin/readnews
include/dbz.h
lib/libcnews.a
+man/man1/checknews.1cn.gz
+man/man1/inews.1cn.gz
+man/man1/postnews.1cn.gz
+man/man1/readnews.1cn.gz
+man/man5/controlperm.5.gz
+man/man5/news.5.gz
+man/man5/newsctl.5.gz
+man/man5/newsdb.5.gz
+man/man5/newsoverview.5.gz
+man/man5/newssys.5.gz
+man/man8/cnewsdo.8cn.gz
+man/man8/expire.8cn.gz
+man/man8/explode.8cn.gz
+man/man8/mergeactive.8.gz
+man/man8/mkhistory.8cn.gz
+man/man8/newsaux.8cn.gz
+man/man8/newsbatch.8cn.gz
+man/man8/newsmail.8cn.gz
+man/man8/newsmaint.8cn.gz
+man/man8/newsoverview.8.gz
+man/man8/relaynews.8cn.gz
+man/man8/report.8cn.gz
+man/man8/rnews.8cn.gz
%%NEWSBIN%%/batch/batchcheck
%%NEWSBIN%%/batch/batcher
%%NEWSBIN%%/batch/batchih
@@ -118,6 +138,8 @@ lib/libcnews.a
%%NEWSBIN%%/unlock
%%NEWSBIN%%/pgpverify
%%NEWSBIN%%/config
+@exec chown news:news %D/%%NEWSBIN%%/input/newsspool
+@exec chmod 6555 %D/%%NEWSBIN%%/input/newsspool
@dirrm %%NEWSBIN%%/batch
@dirrm %%NEWSBIN%%/ctl
@dirrm %%NEWSBIN%%/decompressors
@@ -130,53 +152,56 @@ lib/libcnews.a
@dirrm %%NEWSBIN%%
@owner news
@group news
-@unexec for i in %%NEWSCTL_FILES%%; do if cmp -s %%VARBASE%%/%%NEWSCTL%%/$i %D/%%EXAMPLESDIR%%/newsctl/$i; then rm -f %%VARBASE%%/%%NEWSCTL%%/$i; else echo "Preserving %%VARBASE%%/%%NEWSCTL%%/$i"; fi; done
-%%EXAMPLESDIR%%/newsctl/active
-%%EXAMPLESDIR%%/newsctl/active.times
-%%EXAMPLESDIR%%/newsctl/batchparms
-%%EXAMPLESDIR%%/newsctl/controlperm
-%%EXAMPLESDIR%%/newsctl/explist
-%%EXAMPLESDIR%%/newsctl/history
-%%EXAMPLESDIR%%/newsctl/history.dir
-%%EXAMPLESDIR%%/newsctl/history.pag
-%%EXAMPLESDIR%%/newsctl/inews
-%%EXAMPLESDIR%%/newsctl/mailname
-%%EXAMPLESDIR%%/newsctl/mailpaths
-%%EXAMPLESDIR%%/newsctl/organization
-%%EXAMPLESDIR%%/newsctl/postdefltgroup
-%%EXAMPLESDIR%%/newsctl/readnews.ctl
-%%EXAMPLESDIR%%/newsctl/readnews.help
-%%EXAMPLESDIR%%/newsctl/report.ctl
-%%EXAMPLESDIR%%/newsctl/sys
-%%EXAMPLESDIR%%/newsctl/versionname
-%%EXAMPLESDIR%%/newsctl/whoami
-@exec mkdir -p %D/%%EXAMPLESDIR%%/newsctl/bin
-@exec mkdir -p %%VARBASE%%/%%NEWSCTL%%/bin
-@exec for i in %%NEWSCTL_FILES%%; do if test ! -f %%VARBASE%%/%%NEWSCTL%%/$i; then cp %D/%%EXAMPLESDIR%%/newsctl/$i %%VARBASE%%/%%NEWSCTL%%/$i; else echo "preservering %%VARBASE%%/%%NEWSCTL%%/$i"; fi; done
-@dirrm %%EXAMPLESDIR%%/newsctl/bin
-@dirrm %%EXAMPLESDIR%%/newsctl
-@dirrm %%EXAMPLESDIR%%
+@exec mkdir -p %%VARBASE%%/%%NEWSCTL%%
+@exec chown news:news %%VARBASE%%/%%NEWSCTL%%
+%%PORTEXAMPLES%%@unexec for i in %%NEWSCTL_FILES%%; do if cmp -s %%VARBASE%%/%%NEWSCTL%%/$i %D/%%EXAMPLESDIR%%/newsctl/$i; then rm -f %%VARBASE%%/%%NEWSCTL%%/$i; else echo "Preserving %%VARBASE%%/%%NEWSCTL%%/$i"; fi; done
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/active
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/active.times
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/batchparms
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/controlperm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/explist
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/history
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/history.dir
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/history.pag
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/inews
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/mailname
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/mailpaths
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/organization
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/postdefltgroup
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/readnews.ctl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/readnews.help
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/report.ctl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/sys
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/versionname
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/newsctl/whoami
+%%PORTEXAMPLES%%@exec for i in %%NEWSCTL_FILES%%; do if test ! -f %%VARBASE%%/%%NEWSCTL%%/$i; then cp -p %D/%%EXAMPLESDIR%%/newsctl/$i %%VARBASE%%/%%NEWSCTL%%/$i; else echo "preservering %%VARBASE%%/%%NEWSCTL%%/$i"; fi; done
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/newsctl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@exec mkdir -p %%VARBASE%%/%%NEWSARTS%%/control
+@exec mkdir -p %%VARBASE%%/%%NEWSARTS%%/junk
+@exec mkdir -p %%VARBASE%%/%%NEWSARTS%%/news/announce/newusers
+@exec mkdir -p %%VARBASE%%/%%NEWSARTS%%/in.coming/bad
+@exec chmod g+w %%VARBASE%%/%%NEWSARTS%%/in.coming
+@exec mkdir -p %%VARBASE%%/%%NEWSARTS%%/out.going
+@exec mkdir -p %%VARBASE%%/%%NEWSARTS%%/out.master
+@exec mkdir -p %%VARBASE%%/%%NEWSARTS%%/out.nntp
+@exec chown news:news %%VARBASE%%/%%NEWSARTS%%
+@exec chown news:news %%VARBASE%%/%%NEWSARTS%%/*
+@exec chown news:news %%VARBASE%%/%%NEWSARTS%%/news/announce
+@exec chown news:news %%VARBASE%%/%%NEWSARTS%%/news/announce/newusers
+@exec mkdir -p %%VARBASE%%/%%NEWSOV%%
+@exec chown news:news %%VARBASE%%/%%NEWSOV%%
@cwd %%VARBASE%%
-@dirrm %%NEWSCTL%%/bin
-@dirrm %%NEWSCTL%%
-@dirrm %%NEWSCTLBASE%%
-@dirrm %%NEWSARTS%%/control
-@dirrm %%NEWSARTS%%/junk
-@dirrm %%NEWSARTS%%/news/announce/newusers
-@dirrm %%NEWSARTS%%/news/announce
-@dirrm %%NEWSARTS%%/news
-@dirrm %%NEWSARTS%%/in.coming/bad
-@dirrm %%NEWSARTS%%/in.coming
-@dirrm %%NEWSARTS%%/out.going
-@dirrm %%NEWSARTS%%/out.master
-@dirrm %%NEWSARTS%%/out.nntp
-@dirrm %%NEWSARTS%%
-@exec mkdir -p %D/%%NEWSARTS%%/control
-@exec mkdir -p %D/%%NEWSARTS%%/junk
-@exec mkdir -p %D/%%NEWSARTS%%/news/announce/newusers
-@exec mkdir -p %D/%%NEWSARTS%%/in.coming/bad
-@exec chmod g+w %D/%%NEWSARTS%%/in.coming
-@exec mkdir -p %D/%%NEWSARTS%%/out.going
-@exec mkdir -p %D/%%NEWSARTS%%/out.master
-@exec mkdir -p %D/%%NEWSARTS%%/out.nntp
-@cwd
+@dirrmtry %%NEWSCTL%%
+@dirrmtry %%NEWSCTLBASE%%
+@dirrmtry %%NEWSARTS%%/control
+@dirrmtry %%NEWSARTS%%/junk
+@dirrmtry %%NEWSARTS%%/news/announce/newusers
+@dirrmtry %%NEWSARTS%%/news/announce
+@dirrmtry %%NEWSARTS%%/news
+@dirrmtry %%NEWSARTS%%/in.coming/bad
+@dirrmtry %%NEWSARTS%%/in.coming
+@dirrmtry %%NEWSARTS%%/out.going
+@dirrmtry %%NEWSARTS%%/out.master
+@dirrmtry %%NEWSARTS%%/out.nntp
+@dirrmtry %%NEWSARTS%%