aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING12
-rw-r--r--comms/gnokii/Makefile2
-rw-r--r--converters/ical2html/Makefile2
-rw-r--r--deskutils/kdepimlibs4/Makefile2
-rw-r--r--deskutils/orage/Makefile1
-rw-r--r--deskutils/osmo/Makefile2
-rw-r--r--deskutils/simpleagenda/Makefile2
-rw-r--r--devel/libical/Makefile28
-rw-r--r--devel/libical/distinfo4
-rw-r--r--devel/libical/files/patch-CMakeLists.txt8
-rw-r--r--devel/libical/files/patch-configure6
-rw-r--r--devel/libical/pkg-plist12
-rw-r--r--finance/kmymoney-kde4/Makefile1
-rw-r--r--mail/evolution/Makefile2
-rw-r--r--misc/wmcalendar/Makefile2
15 files changed, 49 insertions, 37 deletions
diff --git a/UPDATING b/UPDATING
index 78768e789492..9c2439184521 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,18 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20140112:
+ AFFECTS: users of devel/libical
+ AUTHOR: kwm@FreeBSD.org
+
+ The libical ports was updated to 1.0.0. Due to the shared library bump
+ and the removal of the .la file. All ports that use libical need to be
+ rebuild.
+
+ # portmaster -r libical
+ or
+ # pkg install -fR libical
+
20140111:
AFFECTS: users of lang/go
AUTHOR: jlaffaye@FreeBSD.org
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index 301f1f9dd0e3..3717132c492b 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnokii
PORTVERSION= 0.6.31
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= http://www.gnokii.org/download/gnokii/ \
diff --git a/converters/ical2html/Makefile b/converters/ical2html/Makefile
index 77574fb6f81e..5a328adcd763 100644
--- a/converters/ical2html/Makefile
+++ b/converters/ical2html/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ical2html
PORTVERSION= 2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters
MASTER_SITES= http://www.w3.org/Tools/Ical2html/
diff --git a/deskutils/kdepimlibs4/Makefile b/deskutils/kdepimlibs4/Makefile
index 02127b344bce..5d17ae63e232 100644
--- a/deskutils/kdepimlibs4/Makefile
+++ b/deskutils/kdepimlibs4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kdepimlibs
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/deskutils/orage/Makefile b/deskutils/orage/Makefile
index 9b065a17ed92..797f5cc91718 100644
--- a/deskutils/orage/Makefile
+++ b/deskutils/orage/Makefile
@@ -3,6 +3,7 @@
PORTNAME= orage
PORTVERSION= 4.10.0
+PORTREVISION= 1
CATEGORIES= deskutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=src/apps/${PORTNAME}/${PORTVERSION:R}
diff --git a/deskutils/osmo/Makefile b/deskutils/osmo/Makefile
index aa7a418dddf4..0893e525d87b 100644
--- a/deskutils/osmo/Makefile
+++ b/deskutils/osmo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= osmo
PORTVERSION= 0.2.10
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= deskutils
MASTER_SITES= SF/${PORTNAME}-pim/${PORTNAME}-pim/${PORTNAME}-${PORTVERSION}/
diff --git a/deskutils/simpleagenda/Makefile b/deskutils/simpleagenda/Makefile
index fd9587a3b023..be2b92bef3ae 100644
--- a/deskutils/simpleagenda/Makefile
+++ b/deskutils/simpleagenda/Makefile
@@ -2,7 +2,7 @@
PORTNAME= simpleagenda
PORTVERSION= 0.43
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= deskutils gnustep
MASTER_SITES= http://coyote.octets.fr/pub/gnustep/
DISTNAME= SimpleAgenda-${PORTVERSION}
diff --git a/devel/libical/Makefile b/devel/libical/Makefile
index 968eb1309f22..688d6cf540c9 100644
--- a/devel/libical/Makefile
+++ b/devel/libical/Makefile
@@ -2,32 +2,19 @@
# $FreeBSD$
PORTNAME= libical
-PORTVERSION= 0.48
+PORTVERSION= 1.0
CATEGORIES= devel
MASTER_SITES= SF/freeassociation/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
-COMMENT= An implementation of the IETF Calendaring and Scheduling protocols
+COMMENT= Implementation of the IETF Calendaring and Scheduling protocols
-USES= gmake perl5
+LICENSE_COMB= dual
+LICENSE= MPL LGPL21
+
+USES= cmake gmake pathfix perl5
USE_PERL5= build
-USE_GNOME= gnomehack ltverhack
-USE_AUTOTOOLS= libtool
-GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-
-OPTIONS_DEFINE= PYTHON
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPYTHON}
-CONFIGURE_ARGS= --enable-python=yes
-USE_PYTHON= yes
-.else
-CONFIGURE_ARGS= --enable-python=no
-.endif
.include <bsd.port.pre.mk>
@@ -35,4 +22,7 @@ CONFIGURE_ARGS= --enable-python=no
CFLAGS+= -fPIC
.endif
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libical*.so.1.0.0
+
.include <bsd.port.post.mk>
diff --git a/devel/libical/distinfo b/devel/libical/distinfo
index b11e30b0bce1..9ed01828cbe0 100644
--- a/devel/libical/distinfo
+++ b/devel/libical/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libical-0.48.tar.gz) = 2ae78b0757f0dd13431acf42a9a8d038339fd4767fd5134e650bf60ee0b4dff0
-SIZE (libical-0.48.tar.gz) = 1173620
+SHA256 (libical-1.0.tar.gz) = 7c39b3448e4927a2de2775d853f52b3aaeb42400970a3db0b01a78987e6ec0b7
+SIZE (libical-1.0.tar.gz) = 1199483
diff --git a/devel/libical/files/patch-CMakeLists.txt b/devel/libical/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..b92905150a5d
--- /dev/null
+++ b/devel/libical/files/patch-CMakeLists.txt
@@ -0,0 +1,8 @@
+--- CMakeLists.txt.orig 2013-05-04 23:25:27.000000000 +0200
++++ CMakeLists.txt 2013-12-01 00:16:33.000000000 +0100
+@@ -201,4 +201,4 @@
+ set(PTHREAD_LIBS "${CMAKE_THREAD_LIBS_INIT}")
+
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libical.pc.in ${CMAKE_CURRENT_BINARY_DIR}/libical.pc @ONLY)
+-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libical.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
++install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libical.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig)
diff --git a/devel/libical/files/patch-configure b/devel/libical/files/patch-configure
index 3d836c06bc3b..eeb0200e811b 100644
--- a/devel/libical/files/patch-configure
+++ b/devel/libical/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2009-04-13 19:05:37.000000000 -0400
-+++ configure 2009-04-13 19:05:00.000000000 -0400
-@@ -20096,7 +20096,7 @@ case "$host" in
+--- configure.orig 2013-11-30 20:59:36.000000000 +0100
++++ configure 2013-11-30 20:59:36.000000000 +0100
+@@ -15429,7 +15429,7 @@
use_builtin_timezone=yes
os_win32=yes
;;
diff --git a/devel/libical/pkg-plist b/devel/libical/pkg-plist
index 0e972e92ac62..ee1e688b8cd4 100644
--- a/devel/libical/pkg-plist
+++ b/devel/libical/pkg-plist
@@ -45,16 +45,16 @@ include/libical/vcaltmp.h
include/libical/vcc.h
include/libical/vobject.h
lib/libical.a
-lib/libical.la
lib/libical.so
-lib/libical.so.0
+lib/libical.so.1
+lib/libical.so.1.0.0
lib/libicalss.a
-lib/libicalss.la
lib/libicalss.so
-lib/libicalss.so.0
+lib/libicalss.so.1
+lib/libicalss.so.1.0.0
lib/libicalvcal.a
-lib/libicalvcal.la
lib/libicalvcal.so
-lib/libicalvcal.so.0
+lib/libicalvcal.so.1
+lib/libicalvcal.so.1.0.0
libdata/pkgconfig/libical.pc
@dirrm include/libical
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index ce43404f66f3..ab7979d698c9 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kmymoney
PORTVERSION= 4.6.4
+PORTREVISION= 1
CATEGORIES= finance kde
MASTER_SITES= SF/${PORTNAME}2/KMyMoney-KDE4/${PORTVERSION}
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 16f5376c87c7..ad7a0812ea39 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -4,7 +4,7 @@
PORTNAME= evolution
PORTVERSION= 2.32.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/misc/wmcalendar/Makefile b/misc/wmcalendar/Makefile
index ce54e9ed334f..176b17b9b599 100644
--- a/misc/wmcalendar/Makefile
+++ b/misc/wmcalendar/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wmcalendar
PORTVERSION= 0.5.2
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= misc windowmaker
MASTER_SITES= SF