aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/py-ws4py/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/www/py-ws4py/Makefile b/www/py-ws4py/Makefile
index 0c40de1deffa..011c2c4655ac 100644
--- a/www/py-ws4py/Makefile
+++ b/www/py-ws4py/Makefile
@@ -18,33 +18,29 @@ USE_PYTHON= distutils autoplist
NO_ARCH= yes
OPTIONS_DEFINE= CHERRYPY GEVENT TORNADO
-OPTIONS_DEFAULT= CHERRYPY GEVENT
+OPTIONS_DEFAULT=CHERRYPY GEVENT
CHERRYPY_DESC= CherryPy server support
GEVENT_DESC= gevent-based client/server support
TORNADO_DESC= Tornado client support
-CHERRYPY_RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cherrypy>=3.2.2:${PORTSDIR}/www/py-cherrypy
-GEVENT_RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gevent>=0.13.8:${PORTSDIR}/devel/py-gevent
-TORNADO_RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=3.1:${PORTSDIR}/www/py-tornado
-
-.include <bsd.port.options.mk>
+CHERRYPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cherrypy>=3.2.2:${PORTSDIR}/www/py-cherrypy
+GEVENT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gevent>=0.13.8:${PORTSDIR}/devel/py-gevent
+TORNADO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tornado>=3.1:${PORTSDIR}/www/py-tornado
# Do not install files which will not work
-post-patch:
-.if ! ${PORT_OPTIONS:MCHERRYPY}
+post-patch-CHERRYPY-off:
.for f in test/test_cherrypy.py ws4py/server/cherrypyserver.py
- ${RM} ${WRKSRC}/${f}
+ @${RM} ${WRKSRC}/${f}
.endfor
-.endif
-.if ! ${PORT_OPTIONS:MGEVENT}
+
+post-patch-GEVENT-off:
.for f in ws4py/client/geventclient.py ws4py/server/geventserver.py
- ${RM} ${WRKSRC}/${f}
+ @${RM} ${WRKSRC}/${f}
.endfor
-.endif
-.if ! ${PORT_OPTIONS:MTORNADO}
+
+post-patch-TORNADO-off:
.for f in ws4py/client/tornadoclient.py
- ${RM} ${WRKSRC}/${f}
+ @${RM} ${WRKSRC}/${f}
.endfor
-.endif
.include <bsd.port.mk>