aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Expr/Makefile27
-rw-r--r--math/p5-Math-Expr/distinfo1
-rw-r--r--math/p5-Math-Expr/pkg-comment1
-rw-r--r--math/p5-Math-Expr/pkg-descr7
-rw-r--r--math/p5-Math-Expr/pkg-plist14
6 files changed, 51 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index a11f5545b92a..e6f145741a9f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -41,6 +41,7 @@
SUBDIR += numpy
SUBDIR += octave
SUBDIR += oleo
+ SUBDIR += p5-Math-Expr
SUBDIR += p5-MatrixReal
SUBDIR += p5-Set-IntSpan
SUBDIR += pari
diff --git a/math/p5-Math-Expr/Makefile b/math/p5-Math-Expr/Makefile
new file mode 100644
index 000000000000..7cca78bec8d8
--- /dev/null
+++ b/math/p5-Math-Expr/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Math-Expr
+# Date created: 20 Sep 2000
+# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Expr
+PORTVERSION= 0.4
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lioux@linf.unb.br
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Math::Expr.3 Math::Expr::FormulaDB.3 \
+ Math::Expr::MatchSet.3 Math::Expr::Node.3 \
+ Math::Expr::Num.3 Math::Expr::Opp.3 \
+ Math::Expr::OpperationDB.3 Math::Expr::Rule.3 \
+ Math::Expr::TypeDB.3 Math::Expr::Var.3 \
+ Math::Expr::VarSet.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Expr/distinfo b/math/p5-Math-Expr/distinfo
new file mode 100644
index 000000000000..77ba1b0a928f
--- /dev/null
+++ b/math/p5-Math-Expr/distinfo
@@ -0,0 +1 @@
+MD5 (Math-Expr-0.4.tar.gz) = 2c4f7eb097bca918f4748f7843bca02b
diff --git a/math/p5-Math-Expr/pkg-comment b/math/p5-Math-Expr/pkg-comment
new file mode 100644
index 000000000000..b88fd8f97481
--- /dev/null
+++ b/math/p5-Math-Expr/pkg-comment
@@ -0,0 +1 @@
+Perl module for parsing mathematical expressions into a tree structure
diff --git a/math/p5-Math-Expr/pkg-descr b/math/p5-Math-Expr/pkg-descr
new file mode 100644
index 000000000000..2da05bf0c14e
--- /dev/null
+++ b/math/p5-Math-Expr/pkg-descr
@@ -0,0 +1,7 @@
+Math::Expr parses mathematical expressions into a tree structure.
+The expressions may contain integers, real numbers, alphanumeric
+variable names, alphanumeric function names and most other characters
+might be used as operators. The operators can consist of multiple
+characters. The only limitation is that a variable or function
+name may not start on a digit, and not all chars are accepted in
+operation names.
diff --git a/math/p5-Math-Expr/pkg-plist b/math/p5-Math-Expr/pkg-plist
new file mode 100644
index 000000000000..5a2e52afbfce
--- /dev/null
+++ b/math/p5-Math-Expr/pkg-plist
@@ -0,0 +1,14 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Expr/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Math/Expr.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/Expr/FormulaDB.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/Expr/MatchSet.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/Expr/Node.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/Expr/Num.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/Expr/Opp.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/Expr/OpperationDB.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/Expr/Rule.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/Expr/TypeDB.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/Expr/Var.pm
+lib/perl5/site_perl/%%PERL_VER%%/Math/Expr/VarSet.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Math/Expr
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Expr