aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/ifd-test/Makefile2
-rw-r--r--devel/ifd-test/files/patch-Makefile3
2 files changed, 2 insertions, 3 deletions
diff --git a/devel/ifd-test/Makefile b/devel/ifd-test/Makefile
index 45876a1e0d05..88140e92bf29 100644
--- a/devel/ifd-test/Makefile
+++ b/devel/ifd-test/Makefile
@@ -13,8 +13,6 @@ MASTER_SITES= http://www.linuxnet.com/drivers/readers/files/
MAINTAINER= bms@spc.org
COMMENT= IFD Test Suite for PC/SC Lite
-BROKEN= "Does not link"
-
LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
USE_GMAKE= yes
diff --git a/devel/ifd-test/files/patch-Makefile b/devel/ifd-test/files/patch-Makefile
index 325cfb51557c..f41753cdf30b 100644
--- a/devel/ifd-test/files/patch-Makefile
+++ b/devel/ifd-test/files/patch-Makefile
@@ -7,9 +7,10 @@
+PREFIX?= /usr/local
+
CC = gcc
- CFLAGS = -g -w
+-CFLAGS = -g -w
-INCLUDE = -I/usr/local/pcsc/include
-LIBS = -L/usr/local/pcsc/lib -lpcsclite
++CFLAGS = -g -w -pthread
+INCLUDE = -I${PREFIX}/include
+LIBS = -L${PREFIX}/lib -lpcsclite
OBJS = testIBM.o testAMMI.o testSCHL.o testSIEMENS.o testBULL.o testGD.o commands.o testA.o testB.o