aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/logmon/Makefile23
-rw-r--r--sysutils/logmon/distinfo1
-rw-r--r--sysutils/logmon/pkg-comment1
-rw-r--r--sysutils/logmon/pkg-descr12
-rw-r--r--sysutils/logmon/pkg-plist1
6 files changed, 39 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 7477285f9f36..ff2c535e51b3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -80,6 +80,7 @@
SUBDIR += libretto-config
SUBDIR += lmmon
SUBDIR += log_analysis
+ SUBDIR += logmon
SUBDIR += logrotate
SUBDIR += logtool
SUBDIR += lsmlib
diff --git a/sysutils/logmon/Makefile b/sysutils/logmon/Makefile
new file mode 100644
index 000000000000..6829ce265815
--- /dev/null
+++ b/sysutils/logmon/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: logmon
+# Date created: 12 September 2001
+# Whom: Gea-Suan Lin (gslin@ccca.nctu.edu.tw)
+#
+# $FreeBSD$
+#
+
+PORTNAME= logmon
+PORTVERSION= 0.3.3
+CATEGORIES= sysutils
+MASTER_SITES= http://www.edespot.com/plaidhat/code/LogMon/
+DISTNAME= LogMon-${PORTVERSION}
+EXTRACT_SUFX= .src.tgz
+
+MAINTAINER= gslin@ccca.nctu.edu.tw
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/LogMon ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/logmon/distinfo b/sysutils/logmon/distinfo
new file mode 100644
index 000000000000..0ceab27002fb
--- /dev/null
+++ b/sysutils/logmon/distinfo
@@ -0,0 +1 @@
+MD5 (LogMon-0.3.3.src.tgz) = 7ca7ff5715bde733d01ee7e63fa931c7
diff --git a/sysutils/logmon/pkg-comment b/sysutils/logmon/pkg-comment
new file mode 100644
index 000000000000..bce073c65ecb
--- /dev/null
+++ b/sysutils/logmon/pkg-comment
@@ -0,0 +1 @@
+An ncurses-based split window log monitoring program
diff --git a/sysutils/logmon/pkg-descr b/sysutils/logmon/pkg-descr
new file mode 100644
index 000000000000..6e475ea1f88c
--- /dev/null
+++ b/sysutils/logmon/pkg-descr
@@ -0,0 +1,12 @@
+This program will monitor one or more log files, updating when more data is
+available ala 'tail -f' , within a common terminal window via a "split window".
+User can scroll up/down/left/right through all the windows. A header displays
+each frames file name, and number of lines in the file. Very usefull when
+watching several log files at the same time. I've tested this under Linux, but
+it should work under other Unices. Please let me know if you get it working on
+another OS.
+
+WWW: http://www.edespot.com/plaidhat/code/LogMon/
+
+- Gea-Suan Lin
+ gslin@ccca.nctu.edu.tw
diff --git a/sysutils/logmon/pkg-plist b/sysutils/logmon/pkg-plist
new file mode 100644
index 000000000000..b7df8670b1f8
--- /dev/null
+++ b/sysutils/logmon/pkg-plist
@@ -0,0 +1 @@
+bin/LogMon