aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--editors/Makefile1
-rw-r--r--editors/mg-static/Makefile19
-rw-r--r--editors/mg/Makefile27
4 files changed, 24 insertions, 24 deletions
diff --git a/MOVED b/MOVED
index 93521e724ab2..4b4c13bc9402 100644
--- a/MOVED
+++ b/MOVED
@@ -16172,3 +16172,4 @@ sysutils/uefi-edk2-bhyve-devel|sysutils/uefi-edk2-bhyve|2021-02-17|Development v
graphics/py-graph-core|graphics/py-pygraph|2021-02-19|Is outdated and broken with python3, use graphics/py-pygraph instead
devel/allegro-devel|devel/allegro5|2021-02-20|Rename to better match upstream name
www/py-djangorestframework311||2021-02-26|Removed: Used as a transitional package for www/seahub, please use www/py-djangorestframework instead
+editors/mg-static|editors/mg@static|2021-02-28|Flavored
diff --git a/editors/Makefile b/editors/Makefile
index ac203792d6bb..c3e58f673f33 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -193,7 +193,6 @@
SUBDIR += madedit
SUBDIR += marker
SUBDIR += mg
- SUBDIR += mg-static
SUBDIR += micro
SUBDIR += mined
SUBDIR += mle
diff --git a/editors/mg-static/Makefile b/editors/mg-static/Makefile
deleted file mode 100644
index 64cf312a9d85..000000000000
--- a/editors/mg-static/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# $FreeBSD$
-
-PORTEPOCH= 0 # don't bump accidentally
-PKGNAMESUFFIX= -static
-
-COMMENT= Small, fast Emacs-like editor (rescue(8) version)
-
-MASTERDIR= ${.CURDIR}/../mg
-
-CONFIGURE_ARGS= --enable-static
-PLIST_FILES= /rescue/${PORTNAME}
-
-OPTIONS_EXCLUDE=DOCS
-
-do-install:
- ${MKDIR} ${STAGEDIR}${PLIST_FILES:[1]:H}
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PLIST_FILES:[1]}
-
-.include "${MASTERDIR}/Makefile"
diff --git a/editors/mg/Makefile b/editors/mg/Makefile
index 260b23d45988..10754f28c9e9 100644
--- a/editors/mg/Makefile
+++ b/editors/mg/Makefile
@@ -3,25 +3,44 @@
PORTNAME= mg
PORTVERSION= 6.8.1
-PORTEPOCH?= 1
+PORTEPOCH= 1
CATEGORIES= editors
MASTER_SITES= https://github.com/ibara/mg/releases/download/mg-${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
-COMMENT?= Small, fast Emacs-like editor
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Small, fast Emacs-like editor
LICENSE= PD
+FLAVORS= dynamic static
+FLAVOR?= ${FLAVORS:[1]}
+
+static_PKGNAMESUFFIX= -static
+.if ${FLAVOR} == static
+COMMENT+= (rescue(8) version)
+.endif
+
USES= ncurses
HAS_CONFIGURE= yes
-PLIST_FILES?= bin/mg \
+.if ${FLAVOR} == static
+CONFIGURE_ARGS= --enable-static
+PLIST_FILES= /rescue/mg
+.else
+PLIST_FILES= bin/mg \
man/man1/mg.1.gz
PORTDOCS= README-Mg README.md tutorial
OPTIONS_DEFINE= DOCS
+.endif
+.if ${FLAVOR} == static
+do-install:
+ @${MKDIR} ${STAGEDIR}/rescue
+ ${INSTALL_PROGRAM} ${WRKSRC}/mg ${STAGEDIR}/rescue
+.else
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+.endif
.include <bsd.port.mk>