aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING10
-rw-r--r--www/gitea/Makefile1
-rw-r--r--www/gitea/distinfo3
-rw-r--r--www/gitea/files/app.ini.sample.in17
-rw-r--r--www/gitea/pkg-message5
-rw-r--r--www/gitea/pkg-plist22
6 files changed, 51 insertions, 7 deletions
diff --git a/UPDATING b/UPDATING
index 5612b53ea6fa..a4029b2a1b0a 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,16 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20190506:
+ AFFECTS: users of www/gitea
+ AUTHOR: stb@lassitu.de
+
+ Gitea requires the addition of another secret to the config file in order to
+ start up. Either manually add JWT_SECRET to the
+ ${PREFIX}/etc/gitea/conf/app.ini config file (see app.ini.sample), or allow
+ Gitea to make the change for you by making the config file writable to the
+ git user.
+
20190424:
AFFECTS: users of www/node
AUTHOR: bhughes@FreeBSD.org
diff --git a/www/gitea/Makefile b/www/gitea/Makefile
index 1d79faeceae5..4bbc1726988e 100644
--- a/www/gitea/Makefile
+++ b/www/gitea/Makefile
@@ -4,6 +4,7 @@
PORTNAME= gitea
DISTVERSIONPREFIX= v
DISTVERSION= 1.7.6
+DISTVERSION= 1.8.0
CATEGORIES= www
MAINTAINER= stb@lassitu.de
diff --git a/www/gitea/distinfo b/www/gitea/distinfo
index 2eb5350b2c12..2aa48b73b986 100644
--- a/www/gitea/distinfo
+++ b/www/gitea/distinfo
@@ -1,3 +1,6 @@
TIMESTAMP = 1555482864
SHA256 (go-gitea-gitea-v1.7.6_GH0.tar.gz) = 4cc07ead2a842324a5bb76b78055cf1b93876a03845c3b38ffa5cbc0e1bac6f4
SIZE (go-gitea-gitea-v1.7.6_GH0.tar.gz) = 20868421
+TIMESTAMP = 1556897794
+SHA256 (go-gitea-gitea-v1.8.0_GH0.tar.gz) = cc9e7f3d01400391455f2ae5fdd78f0e16360158cf02e45f034a94d3fb0fa8fb
+SIZE (go-gitea-gitea-v1.8.0_GH0.tar.gz) = 24268907
diff --git a/www/gitea/files/app.ini.sample.in b/www/gitea/files/app.ini.sample.in
index 24f8cee51ca6..4c7780f543cb 100644
--- a/www/gitea/files/app.ini.sample.in
+++ b/www/gitea/files/app.ini.sample.in
@@ -6,11 +6,16 @@
# contains the settings incorporated into the gitea binary.
#
# This sample configuration runs Gitea with a local database. Before
-# running this configuration, make sure to change the SECRET_KEY and the
-# INTERNAL_TOKEN at the end of this file. SECRET_KEY is a password of your
-# choosing, INTERNAL_TOKEN is a 64-byte random number in BASE64 encoding.
+# running this configuration, make sure to change the INTERNAL_TOKEN,
+# JWT_SECRET, and SECRET_KEY variables. SECRET_KEY is a password of your
+# choosing, INTERNAL_TOKEN is a 64-byte random number in BASE64 encoding,
+# JWT_SECRET is a 32-byte random number in BASE64 encoding.
+#
# Your can generate the token using for example:
-# openssl rand -base64 64
+# openssl rand -base64 64
+#
+# You can let Gitea add these to the config for you; you need to make
+# app.ini writeable by the git user.
#
# There are no pre-configured users; the first user to register becomes an
# admin. In this sample configuration, the HTTP server only listens on
@@ -43,6 +48,9 @@ LEVEL = Info
[mailer]
ENABLED = false
+[oauth2]
+JWT_SECRET = D56bmu6xCtEKs9vKKgMKnsa4X9FDwo64HVyaS4fQ4mY
+
[picture]
AVATAR_UPLOAD_PATH = /var/db/gitea/data/avatars
DISABLE_GRAVATAR = false
@@ -83,4 +91,3 @@ ENABLE_NOTIFY_MAIL = false
DISABLE_REGISTRATION = false
ENABLE_CAPTCHA = true
REQUIRE_SIGNIN_VIEW = false
-
diff --git a/www/gitea/pkg-message b/www/gitea/pkg-message
new file mode 100644
index 000000000000..b1ab45868c77
--- /dev/null
+++ b/www/gitea/pkg-message
@@ -0,0 +1,5 @@
+When upgrading to Gitea 1.8, Gitea requires the addition of another secret
+to the config file in order to start up. Either manually add JWT_SECRET to
+the ${PREFIX}/etc/gitea/conf/app.ini config file (see app.ini.sample), or
+allow Gitea to make the change for you by making the config file writable to
+the git user.
diff --git a/www/gitea/pkg-plist b/www/gitea/pkg-plist
index f0efa980f84d..40281fdc1b36 100644
--- a/www/gitea/pkg-plist
+++ b/www/gitea/pkg-plist
@@ -576,6 +576,7 @@ sbin/gitea
%%DATADIR%%/options/locale/locale_sv-SE.ini
%%DATADIR%%/options/locale/locale_tr-TR.ini
%%DATADIR%%/options/locale/locale_uk-UA.ini
+%%DATADIR%%/options/locale/locale_vi-VN.ini
%%DATADIR%%/options/locale/locale_zh-CN.ini
%%DATADIR%%/options/locale/locale_zh-HK.ini
%%DATADIR%%/options/locale/locale_zh-TW.ini
@@ -585,6 +586,7 @@ sbin/gitea
%%DATADIR%%/public/img/404.png
%%DATADIR%%/public/img/500.png
%%DATADIR%%/public/img/auth/bitbucket.png
+%%DATADIR%%/public/img/auth/discord.png
%%DATADIR%%/public/img/auth/dropbox.png
%%DATADIR%%/public/img/auth/facebook.png
%%DATADIR%%/public/img/auth/github.png
@@ -637,6 +639,18 @@ sbin/gitea
%%DATADIR%%/public/vendor/assets/font-awesome/fonts/fontawesome-webfont.ttf
%%DATADIR%%/public/vendor/assets/font-awesome/fonts/fontawesome-webfont.woff
%%DATADIR%%/public/vendor/assets/font-awesome/fonts/fontawesome-webfont.woff2
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-bold.eot
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-bold.woff
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-bold.woff2
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-bolditalic.eot
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-bolditalic.woff
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-bolditalic.woff2
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-italic.eot
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-italic.woff
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-italic.woff2
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-regular.eot
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-regular.woff
+%%DATADIR%%/public/vendor/assets/lato-fonts/lato-regular.woff2
%%DATADIR%%/public/vendor/assets/lato-fonts/lato-v14-latin-700.eot
%%DATADIR%%/public/vendor/assets/lato-fonts/lato-v14-latin-700.svg
%%DATADIR%%/public/vendor/assets/lato-fonts/lato-v14-latin-700.ttf
@@ -1855,7 +1869,6 @@ sbin/gitea
%%DATADIR%%/public/vendor/plugins/emojify/images/zap.png
%%DATADIR%%/public/vendor/plugins/emojify/images/zero.png
%%DATADIR%%/public/vendor/plugins/emojify/images/zzz.png
-%%DATADIR%%/public/vendor/plugins/es6-promise/es6-promise.auto.min.js
%%DATADIR%%/public/vendor/plugins/gitgraph/LICENSE
%%DATADIR%%/public/vendor/plugins/gitgraph/gitgraph.css
%%DATADIR%%/public/vendor/plugins/gitgraph/gitgraph.js
@@ -1967,6 +1980,7 @@ sbin/gitea
%%DATADIR%%/public/vendor/plugins/pdfjs/web/viewer.css
%%DATADIR%%/public/vendor/plugins/pdfjs/web/viewer.html
%%DATADIR%%/public/vendor/plugins/pdfjs/web/viewer.js
+%%DATADIR%%/public/vendor/plugins/promise-polyfill/polyfill.min.js
%%DATADIR%%/public/vendor/plugins/semantic/LICENSE
%%DATADIR%%/public/vendor/plugins/semantic/semantic.min.css
%%DATADIR%%/public/vendor/plugins/semantic/semantic.min.js
@@ -2079,7 +2093,6 @@ sbin/gitea
%%DATADIR%%/templates/pwa/manifest_json.tmpl
%%DATADIR%%/templates/pwa/serviceworker_js.tmpl
%%DATADIR%%/templates/repo/activity.tmpl
-%%DATADIR%%/templates/repo/bare.tmpl
%%DATADIR%%/templates/repo/branch/list.tmpl
%%DATADIR%%/templates/repo/branch_dropdown.tmpl
%%DATADIR%%/templates/repo/commit_status.tmpl
@@ -2100,6 +2113,7 @@ sbin/gitea
%%DATADIR%%/templates/repo/editor/diff_preview.tmpl
%%DATADIR%%/templates/repo/editor/edit.tmpl
%%DATADIR%%/templates/repo/editor/upload.tmpl
+%%DATADIR%%/templates/repo/empty.tmpl
%%DATADIR%%/templates/repo/forks.tmpl
%%DATADIR%%/templates/repo/graph.tmpl
%%DATADIR%%/templates/repo/header.tmpl
@@ -2171,6 +2185,8 @@ sbin/gitea
%%DATADIR%%/templates/user/auth/change_passwd_inner.tmpl
%%DATADIR%%/templates/user/auth/finalize_openid.tmpl
%%DATADIR%%/templates/user/auth/forgot_passwd.tmpl
+%%DATADIR%%/templates/user/auth/grant.tmpl
+%%DATADIR%%/templates/user/auth/grant_error.tmpl
%%DATADIR%%/templates/user/auth/link_account.tmpl
%%DATADIR%%/templates/user/auth/prohibit_login.tmpl
%%DATADIR%%/templates/user/auth/reset_passwd.tmpl
@@ -2198,6 +2214,8 @@ sbin/gitea
%%DATADIR%%/templates/user/profile.tmpl
%%DATADIR%%/templates/user/settings/account.tmpl
%%DATADIR%%/templates/user/settings/applications.tmpl
+%%DATADIR%%/templates/user/settings/applications_oauth2.tmpl
+%%DATADIR%%/templates/user/settings/applications_oauth2_edit.tmpl
%%DATADIR%%/templates/user/settings/keys.tmpl
%%DATADIR%%/templates/user/settings/keys_gpg.tmpl
%%DATADIR%%/templates/user/settings/keys_ssh.tmpl