aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/c-lightning/Makefile1
-rw-r--r--net-p2p/c-lightning/files/lightningd.in9
2 files changed, 10 insertions, 0 deletions
diff --git a/net-p2p/c-lightning/Makefile b/net-p2p/c-lightning/Makefile
index b2b422276924..f8ad438aabb1 100644
--- a/net-p2p/c-lightning/Makefile
+++ b/net-p2p/c-lightning/Makefile
@@ -4,6 +4,7 @@
PORTNAME= c-lightning
# To build from an arbitrary git commit comment PORTVERSION and PORTREVISION (if present)
PORTVERSION= 0.8.0
+PORTREVISION= 1
DISTVERSIONPREFIX= v
# and uncomment the following two lines (use for example -git-HEAD or -git-f8d8348c)
#PORTVERSION= 0
diff --git a/net-p2p/c-lightning/files/lightningd.in b/net-p2p/c-lightning/files/lightningd.in
index c476da7e1105..97ae38757e29 100644
--- a/net-p2p/c-lightning/files/lightningd.in
+++ b/net-p2p/c-lightning/files/lightningd.in
@@ -36,9 +36,18 @@ command_args=""
command_args="${command_args} --lightning-dir=${lightningd_base_dir}"
command_args="${command_args} --network=${lightningd_network}"
command_args="${command_args} --daemon"
+# service(8) would execute us with LOCALBASE stripped out from PATH,
+# thus specify the full path to bitcoin-cli.
+command_args="${command_args} --bitcoin-cli=%%LOCALBASE%%/bin/bitcoin-cli"
+# bitcoin-cli(1) tries to create its "datadir" (by default ${HOME}/.bitcoin)
+# if it does not exist. Provide something that already exists to avoid the
+# creation of unnecessary empty directories.
+command_args="${command_args} --bitcoin-datadir=${lightningd_base_dir}"
if [ -e "${lightningd_conf}" ] ; then
command_args="${command_args} --conf=${lightningd_conf}"
fi
+command_args="${command_args} ${lightningd_extra_args}"
+
run_rc_command "$1"