aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/cgnslib/Makefile3
-rw-r--r--science/cgnslib/files/patch-src_cgnstools_cgnscalc_CMakeLists.txt15
-rw-r--r--science/cgnslib/files/patch-src_cgnstools_cgnscalc_Makefile.unix14
-rw-r--r--science/cgnslib/pkg-plist2
-rw-r--r--science/xcrysden/Makefile2
5 files changed, 32 insertions, 4 deletions
diff --git a/science/cgnslib/Makefile b/science/cgnslib/Makefile
index f76e99cc872b..3bdca251b72e 100644
--- a/science/cgnslib/Makefile
+++ b/science/cgnslib/Makefile
@@ -4,6 +4,7 @@
PORTNAME= cgnslib
PORTVERSION= 4.1.2
DISTVERSIONPREFIX= v
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= science
@@ -22,8 +23,6 @@ GH_PROJECT= CGNS
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
-CONFLICTS_INSTALL= xcrysden-1.* # bin/unitconv
-
TEST_TARGET= test
FFLAGS+= -std=legacy
diff --git a/science/cgnslib/files/patch-src_cgnstools_cgnscalc_CMakeLists.txt b/science/cgnslib/files/patch-src_cgnstools_cgnscalc_CMakeLists.txt
new file mode 100644
index 000000000000..49640d79f163
--- /dev/null
+++ b/science/cgnslib/files/patch-src_cgnstools_cgnscalc_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- src/cgnstools/cgnscalc/CMakeLists.txt.orig 2020-08-18 19:44:35 UTC
++++ src/cgnstools/cgnscalc/CMakeLists.txt
+@@ -77,10 +77,10 @@ else (WIN32)
+ cgnscalc.sh
+ DESTINATION bin
+ RENAME cgnscalc)
++ # Do not install as unitconv to avoid a conflicy with XCrySDen
+ install(PROGRAMS
+ unitconv.sh
+- DESTINATION bin
+- RENAME unitconv)
++ DESTINATION bin)
+ install(FILES
+ cgnscalc.tcl
+ unitconv.tcl
diff --git a/science/cgnslib/files/patch-src_cgnstools_cgnscalc_Makefile.unix b/science/cgnslib/files/patch-src_cgnstools_cgnscalc_Makefile.unix
new file mode 100644
index 000000000000..b4b8eb9e1ba6
--- /dev/null
+++ b/science/cgnslib/files/patch-src_cgnstools_cgnscalc_Makefile.unix
@@ -0,0 +1,14 @@
+--- src/cgnstools/cgnscalc/Makefile.unix.orig 2020-08-18 19:44:35 UTC
++++ src/cgnstools/cgnscalc/Makefile.unix
+@@ -45,8 +45,9 @@ install-prog :
+ @echo "installing cgnscalc shell scripts to $(BIN_INSTALL_DIR)"
+ @$(INSTALL_PROG) cgnscalc.sh $(BIN_INSTALL_DIR)/cgnscalc
+ @chmod +x $(BIN_INSTALL_DIR)/cgnscalc
+- @$(INSTALL_PROG) unitconv.sh $(BIN_INSTALL_DIR)/unitconv
+- @chmod +x $(BIN_INSTALL_DIR)/unitconv
++ # Do not install as unitconv to avoid a conflicy with XCrySDen
++ @$(INSTALL_PROG) unitconv.sh $(BIN_INSTALL_DIR)/unitconv.sh
++ @chmod +x $(BIN_INSTALL_DIR)/unitconv.sh
+ @if [ ! -f $(EXE_INSTALL_DIR)/cgconfig ] ; then \
+ echo "installing configuration file to $(EXE_INSTALL_DIR)"; \
+ $(INSTALL_DATA) ../cgconfig $(EXE_INSTALL_DIR)/cgconfig; \
diff --git a/science/cgnslib/pkg-plist b/science/cgnslib/pkg-plist
index 841e45954873..86ebc71c99af 100644
--- a/science/cgnslib/pkg-plist
+++ b/science/cgnslib/pkg-plist
@@ -26,7 +26,7 @@
%%TOOLS%%bin/cgnstools/update_ngon
%%TOOLS%%bin/cgnstools/vgrid_to_cgns
%%TOOLS%%bin/cgnsview
-%%TOOLS%%bin/unitconv
+%%TOOLS%%bin/unitconv.sh
bin/cgnscheck
bin/cgnscompress
bin/cgnsconvert
diff --git a/science/xcrysden/Makefile b/science/xcrysden/Makefile
index 880cd5db60db..457aa289524d 100644
--- a/science/xcrysden/Makefile
+++ b/science/xcrysden/Makefile
@@ -24,7 +24,7 @@ USES= fortran gl gmake localbase:ldflags tcl tk xorg
USE_GL= gl glu
USE_XORG= x11 xmu
-CONFLICTS_INSTALL= cgnslib-4.* # bin/unitconv
+CONFLICTS_INSTALL= cgnslib-4.1.2,1 # bin/unitconv
MAKE_ARGS= prefix=${STAGEDIR}${PREFIX}