aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/bird/Makefile11
-rw-r--r--net/bird/distinfo6
-rw-r--r--net/bird/files/bird.in32
-rw-r--r--net/bird/files/patch-sysdep-unix-krt.c10
-rw-r--r--net/bird/pkg-descr5
-rw-r--r--net/bird/pkg-plist10
-rw-r--r--net/bird6/Makefile31
-rw-r--r--net/bird6/distinfo3
-rw-r--r--net/bird6/files/bird6.in32
-rw-r--r--net/bird6/files/patch-tools-Makefile.in15
-rw-r--r--net/bird6/pkg-descr14
-rw-r--r--net/bird6/pkg-plist5
13 files changed, 151 insertions, 24 deletions
diff --git a/net/Makefile b/net/Makefile
index 0a9fdec4359e..3c0574a1c45a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -59,6 +59,7 @@
SUBDIR += bing
SUBDIR += binkd
SUBDIR += bird
+ SUBDIR += bird6
SUBDIR += bittwist
SUBDIR += blam
SUBDIR += bld
diff --git a/net/bird/Makefile b/net/bird/Makefile
index 6f5bd444bfb0..b50fddeec53f 100644
--- a/net/bird/Makefile
+++ b/net/bird/Makefile
@@ -6,23 +6,24 @@
#
PORTNAME= bird
-PORTVERSION= 1.2.1
+PORTVERSION= 1.2.3
CATEGORIES= net
MASTER_SITES= ftp://bird.network.cz/pub/bird/
MAINTAINER= pav@FreeBSD.org
-COMMENT= Dynamic IP routing daemon
+COMMENT= Dynamic IP routing daemon (IPv4 version)
USE_BISON= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-ipv6
MAKE_JOBS_UNSAFE= yes
+USE_RC_SUBR= bird
+
post-install:
- @if [ ! -f ${PREFIX}/etc/bird6.conf ]; then \
- ${CP} -p ${PREFIX}/etc/bird6.conf.example ${PREFIX}/etc/bird6.conf ; \
+ @if [ ! -f ${PREFIX}/etc/bird.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/bird.conf.example ${PREFIX}/etc/bird.conf ; \
fi
.include <bsd.port.mk>
diff --git a/net/bird/distinfo b/net/bird/distinfo
index be6bec3115f3..85f04f302afc 100644
--- a/net/bird/distinfo
+++ b/net/bird/distinfo
@@ -1,3 +1,3 @@
-MD5 (bird-1.2.1.tar.gz) = e158bd0a72e345841e39764975ee1d21
-SHA256 (bird-1.2.1.tar.gz) = 72d07e28a997b59136b6ccc084c82ad86c0572a8fca709bdeb1acc922f768fe9
-SIZE (bird-1.2.1.tar.gz) = 760026
+MD5 (bird-1.2.3.tar.gz) = bf1f4b24627050eead1dceb8c1fd24c3
+SHA256 (bird-1.2.3.tar.gz) = 503f25ef676c320be3db90b69b8a78da8fda4dc2d640d3aa9dbfae0cb4e66273
+SIZE (bird-1.2.3.tar.gz) = 865144
diff --git a/net/bird/files/bird.in b/net/bird/files/bird.in
new file mode 100644
index 000000000000..68dc9bd27141
--- /dev/null
+++ b/net/bird/files/bird.in
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: bird
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# bird_enable (bool): Set to NO by default.
+# Set it to YES to enable bird.
+# bird_config (path): Set to %%PREFIX%%/etc/bird.conf
+# by default.
+#
+
+. /etc/rc.subr
+
+name="bird"
+rcvar=${name}_enable
+
+command=%%PREFIX%%/sbin/${name}
+
+load_rc_config $name
+
+: ${bird_enable="NO"}
+: ${bird_config="%%PREFIX%%/etc/bird.conf"}
+
+command_args="-c $bird_config"
+
+run_rc_command "$1"
diff --git a/net/bird/files/patch-sysdep-unix-krt.c b/net/bird/files/patch-sysdep-unix-krt.c
deleted file mode 100644
index 94e0a966353e..000000000000
--- a/net/bird/files/patch-sysdep-unix-krt.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- sysdep/unix/krt.c.orig Mon Jun 7 18:51:23 2004
-+++ sysdep/unix/krt.c Thu May 12 20:41:53 2005
-@@ -639,6 +639,7 @@
- return;
- }
- #endif
-+ ;
- }
- rte_free(e);
- }
diff --git a/net/bird/pkg-descr b/net/bird/pkg-descr
index 5ae9826f66b5..04fcd78e58ca 100644
--- a/net/bird/pkg-descr
+++ b/net/bird/pkg-descr
@@ -4,8 +4,11 @@ The BIRD project aims to develop a fully functional dynamic IP routing daemon.
- Multiple routing tables
- BGP
- RIP
-- OSPF (IPv4 only)
+- OSPF
- Static routes
- Inter-table protocol
+- Command-line interface
+- Soft reconfiguration
+- Powerful language for route filtering
WWW: http://bird.network.cz/
diff --git a/net/bird/pkg-plist b/net/bird/pkg-plist
index 197fad3d7053..ec18be838b66 100644
--- a/net/bird/pkg-plist
+++ b/net/bird/pkg-plist
@@ -1,5 +1,5 @@
-@unexec if cmp -s %D/etc/bird6.conf.example %D/etc/bird6.conf; then rm -f %D/etc/bird6.conf; fi
-etc/bird6.conf.example
-@exec if [ ! -f %D/etc/bird6.conf ] ; then cp -p %D/%F %B/bird6.conf; fi
-sbin/bird6
-sbin/birdc6
+@unexec if cmp -s %D/etc/bird.conf.example %D/etc/bird.conf; then rm -f %D/etc/bird.conf; fi
+etc/bird.conf.example
+@exec if [ ! -f %D/etc/bird.conf ] ; then cp -p %D/%F %B/bird.conf; fi
+sbin/bird
+sbin/birdc
diff --git a/net/bird6/Makefile b/net/bird6/Makefile
new file mode 100644
index 000000000000..2e660cda7b0d
--- /dev/null
+++ b/net/bird6/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: bird
+# Date created: 12th May 2005
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bird6
+PORTVERSION= 1.2.3
+CATEGORIES= net
+MASTER_SITES= ftp://bird.network.cz/pub/bird/
+DISTNAME= bird-${PORTVERSION}
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Dynamic IP routing daemon (IPv6 version)
+
+USE_BISON= build
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-ipv6
+
+MAKE_JOBS_UNSAFE= yes
+
+USE_RC_SUBR= bird6
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/bird6.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/bird6.conf.example ${PREFIX}/etc/bird6.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/net/bird6/distinfo b/net/bird6/distinfo
new file mode 100644
index 000000000000..85f04f302afc
--- /dev/null
+++ b/net/bird6/distinfo
@@ -0,0 +1,3 @@
+MD5 (bird-1.2.3.tar.gz) = bf1f4b24627050eead1dceb8c1fd24c3
+SHA256 (bird-1.2.3.tar.gz) = 503f25ef676c320be3db90b69b8a78da8fda4dc2d640d3aa9dbfae0cb4e66273
+SIZE (bird-1.2.3.tar.gz) = 865144
diff --git a/net/bird6/files/bird6.in b/net/bird6/files/bird6.in
new file mode 100644
index 000000000000..58b2b4f4d554
--- /dev/null
+++ b/net/bird6/files/bird6.in
@@ -0,0 +1,32 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: bird6
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# bird6_enable (bool): Set to NO by default.
+# Set it to YES to enable bird6.
+# bird6_config (path): Set to %%PREFIX%%/etc/bird6.conf
+# by default.
+#
+
+. /etc/rc.subr
+
+name="bird6"
+rcvar=${name}_enable
+
+command=%%PREFIX%%/sbin/${name}
+
+load_rc_config $name
+
+: ${bird6_enable="NO"}
+: ${bird6_config="%%PREFIX%%/etc/bird6.conf"}
+
+command_args="-c $bird6_config"
+
+run_rc_command "$1"
diff --git a/net/bird6/files/patch-tools-Makefile.in b/net/bird6/files/patch-tools-Makefile.in
new file mode 100644
index 000000000000..51fa404385f6
--- /dev/null
+++ b/net/bird6/files/patch-tools-Makefile.in
@@ -0,0 +1,15 @@
+--- tools/Makefile.in.orig 2009-08-16 22:42:37.000000000 +0200
++++ tools/Makefile.in 2009-09-16 22:22:07.000000000 +0200
+@@ -60,11 +60,7 @@
+ if test -n "@CLIENT@" ; then \
+ $(INSTALL_PROGRAM) -s $(exedir)/birdc $(DESTDIR)/$(sbindir)/birdc@SUFFIX6@ ; \
+ fi
+- if ! test -f $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; then \
+- $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; \
+- else \
+- echo "Not overwriting old bird@SUFFIX@.conf" ; \
+- fi
++ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf.example ; \
+
+ install-docs:
+ $(INSTALL) -d $(DESTDIR)/$(docdir)
diff --git a/net/bird6/pkg-descr b/net/bird6/pkg-descr
new file mode 100644
index 000000000000..04fcd78e58ca
--- /dev/null
+++ b/net/bird6/pkg-descr
@@ -0,0 +1,14 @@
+The BIRD project aims to develop a fully functional dynamic IP routing daemon.
+
+- Both IPv4 and IPv6
+- Multiple routing tables
+- BGP
+- RIP
+- OSPF
+- Static routes
+- Inter-table protocol
+- Command-line interface
+- Soft reconfiguration
+- Powerful language for route filtering
+
+WWW: http://bird.network.cz/
diff --git a/net/bird6/pkg-plist b/net/bird6/pkg-plist
new file mode 100644
index 000000000000..197fad3d7053
--- /dev/null
+++ b/net/bird6/pkg-plist
@@ -0,0 +1,5 @@
+@unexec if cmp -s %D/etc/bird6.conf.example %D/etc/bird6.conf; then rm -f %D/etc/bird6.conf; fi
+etc/bird6.conf.example
+@exec if [ ! -f %D/etc/bird6.conf ] ; then cp -p %D/%F %B/bird6.conf; fi
+sbin/bird6
+sbin/birdc6