aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/virtualbox-ose-additions/Makefile3
-rw-r--r--emulators/virtualbox-ose-additions/distinfo6
-rw-r--r--emulators/virtualbox-ose-kmod/Makefile3
-rw-r--r--emulators/virtualbox-ose-kmod/distinfo6
-rw-r--r--emulators/virtualbox-ose/Makefile29
-rw-r--r--emulators/virtualbox-ose/distinfo10
-rw-r--r--emulators/virtualbox-ose/files/patch-Config.kmk44
-rw-r--r--emulators/virtualbox-ose/files/patch-src_VBox_Main_src-client_ConsoleImpl.cpp21
-rw-r--r--emulators/virtualbox-ose/pkg-plist2
9 files changed, 54 insertions, 70 deletions
diff --git a/emulators/virtualbox-ose-additions/Makefile b/emulators/virtualbox-ose-additions/Makefile
index d495c2490be3..579a3b54917a 100644
--- a/emulators/virtualbox-ose-additions/Makefile
+++ b/emulators/virtualbox-ose-additions/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= virtualbox-ose
-PORTVERSION= 5.2.22
-PORTREVISION= 2
+PORTVERSION= 5.2.24
CATEGORIES= emulators
MASTER_SITES= http://download.virtualbox.org/virtualbox/${PORTVERSION}/
PKGNAMESUFFIX?= -additions
diff --git a/emulators/virtualbox-ose-additions/distinfo b/emulators/virtualbox-ose-additions/distinfo
index 6ef950142a82..2dee6d52174b 100644
--- a/emulators/virtualbox-ose-additions/distinfo
+++ b/emulators/virtualbox-ose-additions/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541800381
-SHA256 (VirtualBox-5.2.22.tar.bz2) = 5580e875349341a1aabc6d5d2f697d242f277487316faaf1fbe68d9014f788d4
-SIZE (VirtualBox-5.2.22.tar.bz2) = 118757134
+TIMESTAMP = 1547573855
+SHA256 (VirtualBox-5.2.24.tar.bz2) = 6c8672ff74f9fbe0a73522baab5f5600d2c65c5df4b0314d983a5d096e746457
+SIZE (VirtualBox-5.2.24.tar.bz2) = 118369194
diff --git a/emulators/virtualbox-ose-kmod/Makefile b/emulators/virtualbox-ose-kmod/Makefile
index 6b52ebc89a5a..776cf9f404ef 100644
--- a/emulators/virtualbox-ose-kmod/Makefile
+++ b/emulators/virtualbox-ose-kmod/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= virtualbox-ose
-PORTVERSION= 5.2.22
-PORTREVISION= 1
+PORTVERSION= 5.2.24
CATEGORIES= emulators
MASTER_SITES= http://download.virtualbox.org/virtualbox/${PORTVERSION}/
PKGNAMESUFFIX= -kmod
diff --git a/emulators/virtualbox-ose-kmod/distinfo b/emulators/virtualbox-ose-kmod/distinfo
index 6ef950142a82..2dee6d52174b 100644
--- a/emulators/virtualbox-ose-kmod/distinfo
+++ b/emulators/virtualbox-ose-kmod/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541800381
-SHA256 (VirtualBox-5.2.22.tar.bz2) = 5580e875349341a1aabc6d5d2f697d242f277487316faaf1fbe68d9014f788d4
-SIZE (VirtualBox-5.2.22.tar.bz2) = 118757134
+TIMESTAMP = 1547573855
+SHA256 (VirtualBox-5.2.24.tar.bz2) = 6c8672ff74f9fbe0a73522baab5f5600d2c65c5df4b0314d983a5d096e746457
+SIZE (VirtualBox-5.2.24.tar.bz2) = 118369194
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 7bb5323ed798..3de2ce825dd0 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= virtualbox-ose
-PORTVERSION= 5.2.22
-PORTREVISION= 3
+PORTVERSION= 5.2.24
CATEGORIES= emulators
MASTER_SITES= http://download.virtualbox.org/virtualbox/${PORTVERSION}/
DISTFILES= VirtualBox-${PORTVERSION}${EXTRACT_SUFX} ${GUESTADDITIONS}
@@ -29,7 +28,7 @@ CPE_PRODUCT= vm_virtualbox
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
ONLY_FOR_ARCHS= i386 amd64
-USES= compiler:c++14-lang cpe iconv pkgconfig ssl tar:bzip2
+USES= compiler:c++14-lang cpe gnome iconv pkgconfig ssl tar:bzip2
USE_GNOME= libidl libxml2
HAS_CONFIGURE= yes
@@ -62,12 +61,13 @@ OPTIONS_SUB= yes
DEBUG_DESC= Debug symbols, additional logs and assertions
GUESTADDITIONS_DESC= Build with Guest Additions
MANUAL_DESC= Build with user manual
-QT5_DESC= Build with QT5 Frontend
-R0LOGGING_DESC= Enable R0 logging
+NLS_DESC= Native language support (requires QT5)
+QT5_DESC= Build with QT5 frontend (requires X11)
+R0LOGGING_DESC= Enable R0 logging (requires DEBUG)
UDPTUNNEL_DESC= Build with UDP tunnel support
VDE_DESC= Build with VDE support
VNC_DESC= Build with VNC support
-VPX_DESC= Use vpx for video capturing
+VPX_DESC= Use libvpx for video recording
WEBSERVICE_DESC= Build Webservice
ALSA_CONFIGURE_OFF= --disable-alsa
@@ -77,9 +77,12 @@ DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
DEBUG_CONFIGURE_ON= --build-debug
MANUAL_BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.4/docbookx.dtd:textproc/docbook-xml
MANUAL_CONFIGURE_OFF= --disable-docs
+NLS_IMPLIES= QT5
PULSEAUDIO_CONFIGURE_OFF= --disable-pulse
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PYTHON_CONFIGURE_OFF= --disable-python
+QT5_IMPLIES= X11
+R0LOGGING_IMPLIES= DEBUG
UDPTUNNEL_CONFIGURE_OFF= --disable-udptunnel
VDE_CONFIGURE_ON= --enable-vde
VDE_RUN_DEPENDS= vde_switch:net/vde2
@@ -114,14 +117,6 @@ CONFLICTS_INSTALL+= virtualbox-ose-[0-9]*
_ELF32!= kldstat -q -m elf32 && echo yes || echo no
.endif
-.if ${PORT_OPTIONS:MNLS} && empty(PORT_OPTIONS:MQT5)
-BROKEN= NLS support requires QT frontend. Run 'make config' again!
-.endif
-
-.if ${PORT_OPTIONS:MQT[45]} && empty(PORT_OPTIONS:MX11)
-BROKEN= QT frontend requires X11 support. Run 'make config' again!
-.endif
-
.if ${PORT_OPTIONS:MDEBUG}
KMK_BUILDTYPE= debug
KMK_FLAGS+= BUILD_TYPE=debug
@@ -129,10 +124,6 @@ KMK_FLAGS+= BUILD_TYPE=debug
KMK_BUILDTYPE= release
.endif
-.if ${PORT_OPTIONS:MR0LOGGING} && empty(PORT_OPTIONS:MDEBUG)
-BROKEN= R0 logging requires debug build
-.endif
-
.if ${PORT_OPTIONS:MGUESTADDITIONS}
GUESTADDITIONS= VBoxGuestAdditions_${PORTVERSION}.iso
RESTRICTED= for personal use only
@@ -157,8 +148,8 @@ USES+= python:2.7,build
.if ${PORT_OPTIONS:MQT5}
CONFIGURE_ARGS+= --enable-qt5
PLIST_SUB+= QT=""
+USES+= gl qmake:no_env qt:5
USE_GL= gl
-USES+= qmake:no_env qt:5
USE_QT= buildtools_build core dbus gui linguisttools_build opengl
USE_QT+= printsupport widgets x11extras
USE_XORG= xcb
diff --git a/emulators/virtualbox-ose/distinfo b/emulators/virtualbox-ose/distinfo
index cb5c3fd01a77..6eda5e32ee7a 100644
--- a/emulators/virtualbox-ose/distinfo
+++ b/emulators/virtualbox-ose/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1541800381
-SHA256 (VirtualBox-5.2.22.tar.bz2) = 5580e875349341a1aabc6d5d2f697d242f277487316faaf1fbe68d9014f788d4
-SIZE (VirtualBox-5.2.22.tar.bz2) = 118757134
-SHA256 (VBoxGuestAdditions_5.2.22.iso) = e51e33500a265b5c2d7bb2d03d32208df880523dfcb1e2dde2c78a0e0daa0603
-SIZE (VBoxGuestAdditions_5.2.22.iso) = 58013696
+TIMESTAMP = 1547573855
+SHA256 (VirtualBox-5.2.24.tar.bz2) = 6c8672ff74f9fbe0a73522baab5f5600d2c65c5df4b0314d983a5d096e746457
+SIZE (VirtualBox-5.2.24.tar.bz2) = 118369194
+SHA256 (VBoxGuestAdditions_5.2.24.iso) = cb217dbc3a34862d36ee0a5f5a6b0756e7b639c4852e675eeec7c4422dc02599
+SIZE (VBoxGuestAdditions_5.2.24.iso) = 58429440
diff --git a/emulators/virtualbox-ose/files/patch-Config.kmk b/emulators/virtualbox-ose/files/patch-Config.kmk
index 19349baf8ba4..53e9abd233bc 100644
--- a/emulators/virtualbox-ose/files/patch-Config.kmk
+++ b/emulators/virtualbox-ose/files/patch-Config.kmk
@@ -1,6 +1,6 @@
---- Config.kmk.orig 2017-10-18 07:06:30 UTC
+--- Config.kmk.orig 2019-01-14 14:53:56 UTC
+++ Config.kmk
-@@ -424,11 +424,11 @@ ifn1of ($(KBUILD_TARGET), win darwin)
+@@ -445,11 +445,11 @@ ifn1of ($(KBUILD_TARGET), win darwin)
# Enable OSS audio support.
VBOX_WITH_AUDIO_OSS = 1
endif
@@ -14,7 +14,7 @@
# Enable PulseAudio audio support.
VBOX_WITH_AUDIO_PULSE = 1
endif
-@@ -440,11 +440,11 @@ VBOX_WITH_AUDIO_MMNOTIFICATION_CLIENT = 1
+@@ -464,11 +464,11 @@ VBOX_WITH_AUDIO_MMNOTIFICATION_CLIENT = 1
# Enable PCI passthrough support.
VBOX_WITH_PCI_PASSTHROUGH = 1
# Enable statically linked dbus support.
@@ -28,7 +28,7 @@
VBOX_WITH_PAM = 1
endif
# Enable internal networking.
-@@ -648,7 +648,7 @@ VBOX_WITH_TESTCASES = 1
+@@ -664,7 +664,7 @@ VBOX_WITH_TESTCASES = 1
VBOX_WITH_VDITOOL =
# Enable this to build vbox-img even if VBOX_WITH_TESTCASES is disabled
VBOX_WITH_VBOX_IMG =
@@ -37,7 +37,7 @@
# Enables the video capturing support.
VBOX_WITH_VIDEOREC = 1
# Enable VPX (VP8 / VP9 codec), used for video capturing.
-@@ -978,10 +978,6 @@ ifeq ($(KBUILD_TARGET),darwin)
+@@ -992,10 +992,6 @@ ifeq ($(KBUILD_TARGET),darwin)
VBOX_WITH_VBOXSDL=
endif
@@ -48,7 +48,7 @@
ifeq ($(KBUILD_TARGET),haiku)
# Don't bother with SDL ttf for now.
VBOX_WITH_SECURELABEL=
-@@ -1141,7 +1137,7 @@ ifdef VBOX_OSE
+@@ -1155,7 +1151,7 @@ ifdef VBOX_OSE
VBOX_WITH_KCHMVIEWER=
VBOX_WITH_PLUGIN_CRYPT=
VBOX_WITH_DRAG_AND_DROP_PROMISES=
@@ -57,7 +57,25 @@
VBOX_WITH_DOCS=
VBOX_WITH_DOCS_PACKING=
endif
-@@ -4360,7 +4356,7 @@ TEMPLATE_VBOXR0DRV_CFLAGS = \
+@@ -1176,13 +1172,13 @@ ifdef VBOX_OSE
+ ifn1of ($(KBUILD_TARGET), darwin linux solaris win)
+ VBOX_WITH_INSTALLER=
+ endif
++ # Undefine codec libraries which are not needed.
++ VBOX_WITH_LIBOPUS=
++ # Disable video recording (with audio support).
++ VBOX_WITH_AUDIO_VIDEOREC=
+ if1of ($(KBUILD_TARGET), win)
+- # Undefine codec libraries which are not needed.
+ VBOX_WITH_LIBVPX=
+- VBOX_WITH_LIBOPUS=
+- # Disable video recording (with audio support).
+ VBOX_WITH_VIDEOREC=
+- VBOX_WITH_AUDIO_VIDEOREC=
+ endif
+ # branding
+ VBOX_BRAND_LICENSE_HTML := $(PATH_ROOT)/doc/License-gpl-2.0.html
+@@ -4541,7 +4537,7 @@ TEMPLATE_VBOXR0DRV_CFLAGS = \
-O2 -ffreestanding -fno-strict-aliasing -fno-common -finline-limit=8000 \
$(VBOX_GCC_fno-stack-protector) $(VBOX_GCC_R0_OPT) $(VBOX_GCC_R0_FP) \
-nostdinc -std=c99
@@ -66,7 +84,7 @@
TEMPLATE_VBOXR0DRV_CFLAGS.amd64 = -m64 --param inline-unit-growth=100 --param large-function-growth=1000 \
-fno-omit-frame-pointer -mcmodel=kernel -mno-red-zone -mfpmath=387 -mno-sse -mno-sse2 -mno-mmx \
-mno-3dnow -msoft-float -fno-asynchronous-unwind-tables -Wundef
-@@ -4689,12 +4685,8 @@ TEMPLATE_VBOXR3EXE_LDFLAGS += -fno-pic
+@@ -4878,12 +4874,8 @@ TEMPLATE_VBOXR3EXE_LDFLAGS += -fno-pic
TEMPLATE_VBOXR3EXE_TOOL = GXX3
TEMPLATE_VBOXR3EXE_LIBS = pthread
TEMPLATE_VBOXR3EXE_INCS += \
@@ -79,7 +97,7 @@
/usr/local/lib
else ifeq ($(KBUILD_TARGET),netbsd)
TEMPLATE_VBOXR3EXE_TOOL = GXX3
-@@ -4984,7 +4976,7 @@ ifeq ($(KBUILD_TARGET),win) # No CRT!
+@@ -5168,7 +5160,7 @@ ifeq ($(KBUILD_TARGET),win) # No CRT!
TEMPLATE_VBOXR3HARDENEDEXE_LDFLAGS.win.amd64 = $(TEMPLATE_VBOXR3EXE_LDFLAGS.win.amd64) /entry:suplibHardenedWindowsMain
TEMPLATE_VBOXR3HARDENEDEXE_LIBS.x86 = $(NOT_SUCH_VARIABLE)
TEMPLATE_VBOXR3HARDENEDEXE_LIBS.amd64 = $(NOT_SUCH_VARIABLE)
@@ -88,7 +106,7 @@
# We want to keep the RPATH on Solaris to be able to find libgcc_1/libstdc++ within $(VBOX_WITH_RUNPATH)
TEMPLATE_VBOXR3HARDENEDEXE_LDFLAGS = $(filter-out '$(VBOX_GCC_RPATH_OPT)%,$(TEMPLATE_VBOXR3EXE_LDFLAGS))
TEMPLATE_VBOXR3HARDENEDEXE_LDFLAGS.linux = $(filter-out $(VBOX_GCC_ORIGIN_OPT),$(TEMPLATE_VBOXR3EXE_LDFLAGS.linux))
-@@ -5515,12 +5507,8 @@ TEMPLATE_VBOXMAINEXE_LIBS = $(LIB_RUNTI
+@@ -5699,12 +5691,8 @@ TEMPLATE_VBOXMAINEXE_LIBS = $(LIB_RUNTI
TEMPLATE_VBOXMAINEXE_TOOL = GXX3
TEMPLATE_VBOXMAINEXE_LIBS = $(LIB_RUNTIME)
TEMPLATE_VBOXMAINEXE_INCS += \
@@ -101,7 +119,7 @@
/usr/local/lib
else ifeq ($(KBUILD_TARGET),netbsd)
TEMPLATE_VBOXMAINEXE_TOOL = GXX3
-@@ -6054,12 +6042,8 @@ ifdef VBOX_WITH_QTGUI
+@@ -6238,12 +6226,8 @@ ifdef VBOX_WITH_QTGUI
$(VBOX_LIBPATH_X11)
ifeq ($(KBUILD_TARGET),freebsd)
TEMPLATE_VBOXQTGUIEXE_INCS += \
@@ -114,7 +132,7 @@
/usr/local/lib
endif
ifeq ($(KBUILD_TARGET),solaris)
-@@ -6282,12 +6266,8 @@ TEMPLATE_VBoxBldProg_LIBPATH += \
+@@ -6466,12 +6450,8 @@ TEMPLATE_VBoxBldProg_LIBPATH += \
TEMPLATE_VBoxBldProg_TOOL = GXX3
TEMPLATE_VBoxBldProg_LIBS = pthread
TEMPLATE_VBoxBldProg_INCS += \
@@ -127,7 +145,7 @@
/usr/local/lib
else ifeq ($(KBUILD_HOST),netbsd)
TEMPLATE_VBoxBldProg_TOOL = GXX3
-@@ -6707,6 +6687,7 @@ TEMPLATE_VBOXCROGLR3HOSTDLL_LDFLAGS.darwin += \
+@@ -6872,6 +6852,7 @@ TEMPLATE_VBOXCROGLR3HOSTDLL_LDFLAGS.darwin += \
-current_version $(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD) \
-compatibility_version $(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD)
TEMPLATE_VBOXCROGLR3HOSTDLL_LDFLAGS.linux = -Wl,--no-as-needed
diff --git a/emulators/virtualbox-ose/files/patch-src_VBox_Main_src-client_ConsoleImpl.cpp b/emulators/virtualbox-ose/files/patch-src_VBox_Main_src-client_ConsoleImpl.cpp
deleted file mode 100644
index 3dbdc120801a..000000000000
--- a/emulators/virtualbox-ose/files/patch-src_VBox_Main_src-client_ConsoleImpl.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/VBox/Main/src-client/ConsoleImpl.cpp.orig 2018-11-08 19:42:03 UTC
-+++ src/VBox/Main/src-client/ConsoleImpl.cpp
-@@ -9859,7 +9859,7 @@ void Console::i_powerUpThreadTask(VMPowerUpTask *pTask
-
- alock.acquire();
-
-- /* Enable client connections to the server. */
-+ /* Enable client connections to the VRDP server. */
- pConsole->i_consoleVRDPServer()->EnableConnections();
-
- #ifdef VBOX_WITH_AUDIO_VRDE
-@@ -9876,9 +9876,6 @@ void Console::i_powerUpThreadTask(VMPowerUpTask *pTask
- pConsole->mAudioVRDE->doAttachDriverViaEmt(pConsole->mpUVM, &alock);
- }
- #endif
--
-- /* Enable client connections to the VRDP server. */
-- pConsole->i_consoleVRDPServer()->EnableConnections();
-
- #ifdef VBOX_WITH_VIDEOREC
- BOOL fVideoRecEnabled = FALSE;
diff --git a/emulators/virtualbox-ose/pkg-plist b/emulators/virtualbox-ose/pkg-plist
index e7d1a53e50e1..d7e470cc3a28 100644
--- a/emulators/virtualbox-ose/pkg-plist
+++ b/emulators/virtualbox-ose/pkg-plist
@@ -377,8 +377,6 @@ lib/virtualbox/VBoxBalloonCtrl
lib/virtualbox/VBoxBugReport
lib/virtualbox/VBoxDD.so
lib/virtualbox/VBoxDD2.so
-lib/virtualbox/VBoxDD2R0.r0
-lib/virtualbox/VBoxDD2RC.rc
lib/virtualbox/VBoxDDR0.r0
lib/virtualbox/VBoxDDRC.rc
lib/virtualbox/VBoxDDU.so