aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/bitchx/Makefile24
-rw-r--r--irc/bitchx/distinfo2
-rw-r--r--irc/bitchx/pkg-plist30
3 files changed, 35 insertions, 21 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index d084e61bac7c..f497df003cb6 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= BitchX
PORTVERSION= 1.0c17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc gnome
MASTER_SITES= ftp://ftp.bitchx.com/pub/BitchX/source/ \
ftp://ftp.bitchx.org/pub/BitchX/source/
@@ -37,11 +37,14 @@ CONFIGURE_ARGS+=--with-gtk
.else
CONFIGURE_ARGS+=--without-gtk
.endif
-.if defined(HAVE_ESOUND)
+.if (defined(HAVE_ESOUND) && defined(HAVE_GNOME))
USE_ESOUND= yes
CONFIGURE_ARGS+=--enable-sound
.endif
-
+.if defined(HAVE_IPV6)
+USE_IPV6= yes
+CONFIGURE_ARGS+=--enable-ipv6
+.endif
.if defined(WITH_TCL)
BUILD_DEPENDS+= ${LOCALBASE}/include/tcl8.3/tcl.h:${PORTSDIR}/lang/tcl83
CONFIGURE_ARGS+=--with-tcl \
@@ -53,8 +56,8 @@ post-extract:
.endif
.if defined(WITH_SOCKS5)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a${PORTSDIR}/net/socks5
-CONFIGURE_ARGS+=--with-socks5=${LOCALBASE}
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
+CONFIGURE_ARGS+= --with-socks5=${LOCALBASE}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
.endif
@@ -74,10 +77,21 @@ pre-patch:
pre-extract:
@${ECHO} "Available switches:"
@${ECHO} "-------------------"
+.if !defined(WITH_PLUGINS)
@${ECHO} "WITH_PLUGINS - Build the plugins"
+.endif
+.if !defined(WITH_LATIN)
@${ECHO} "WITH_LATIN - Recommended if you are using an ISO-8859-1 display"
+.endif
+.if !defined(WITH_TCL)
@${ECHO} "WITH_TCL - Build BitchX with TCL scripting"
+.endif
+.if !defined(WITH_SOCKS5)
@${ECHO} "WITH_SOCKS5 - Build BitchX with SOCKS5 support"
+.endif
+.if !defined(WITH_IPV6)
+ @${ECHO} "WITH_IPV6 - Build BitchX with IPV6 support"
+.endif
post-install:
.if !defined(NOPORTDOCS)
diff --git a/irc/bitchx/distinfo b/irc/bitchx/distinfo
index fe05cde5ca6e..2380a7d54b62 100644
--- a/irc/bitchx/distinfo
+++ b/irc/bitchx/distinfo
@@ -1 +1 @@
-MD5 (BitchX-1.0c17.tar.gz) = 4ab094ae58f0bacb14c3e480404215fd
+MD5 (BitchX-1.0c17.tar.gz) = 9cbf6a87d2f3941a57ad10dd5c9cc8ad
diff --git a/irc/bitchx/pkg-plist b/irc/bitchx/pkg-plist
index 4170d9e5f18e..4b7b09fa0ef0 100644
--- a/irc/bitchx/pkg-plist
+++ b/irc/bitchx/pkg-plist
@@ -916,20 +916,20 @@ share/bx/help/findcomm
share/bx/help/functions
share/bx/help/out
%%PLUGINS:%%share/bx/plugins/BitchX.hints
-%%PLUGINS:%%share/bx/plugins/acro.so
-%%PLUGINS:%%share/bx/plugins/amp.so
-%%PLUGINS:%%share/bx/plugins/autobot.so
-%%PLUGINS:%%share/bx/plugins/blowfish.so
-%%PLUGINS:%%share/bx/plugins/encrypt.so
-%%PLUGINS:%%share/bx/plugins/fserv.so
-%%PLUGINS:%%share/bx/plugins/hint.so
-%%PLUGINS:%%share/bx/plugins/nap.so
-%%PLUGINS:%%share/bx/plugins/pkga.so
-%%PLUGINS:%%share/bx/plugins/possum.so
-%%PLUGINS:%%share/bx/plugins/qmail.so
-%%PLUGINS:%%share/bx/plugins/scan.so
-%%PLUGINS:%%share/bx/plugins/wavplay.so
-%%PLUGINS:%%share/bx/plugins/qbx.so
+%%PLUGINS:%%share/bx/plugins/acro.so
+%%PLUGINS:%%share/bx/plugins/amp.so
+%%PLUGINS:%%share/bx/plugins/autobot.so
+%%PLUGINS:%%share/bx/plugins/blowfish.so
+%%PLUGINS:%%share/bx/plugins/encrypt.so
+%%PLUGINS:%%share/bx/plugins/fserv.so
+%%PLUGINS:%%share/bx/plugins/hint.so
+%%PLUGINS:%%share/bx/plugins/nap.so
+%%PLUGINS:%%share/bx/plugins/pkga.so
+%%PLUGINS:%%share/bx/plugins/possum.so
+%%PLUGINS:%%share/bx/plugins/qmail.so
+%%PLUGINS:%%share/bx/plugins/scan.so
+%%PLUGINS:%%share/bx/plugins/wavplay.so
+%%PLUGINS:%%share/bx/plugins/qbx.so
share/bx/script/actplug.gmz
share/bx/script/bxglobal
share/bx/script/bxtcl.tcl
@@ -976,7 +976,7 @@ share/doc/bitchx/bxfaq.html
@dirrm share/doc/bitchx
@dirrm share/bx/translation
@dirrm share/bx/script
-%%PLUGINS:%%@dirrm share/bx/plugins
+%%PLUGINS:%%@dirrm share/bx/plugins
@dirrm share/bx/help/8_Scripts
@dirrm share/bx/help/7_Docs
@dirrm share/bx/help/6_Functions