aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/json-yaml/Makefile24
-rw-r--r--textproc/json-yaml/distinfo3
-rw-r--r--textproc/json-yaml/pkg-descr4
4 files changed, 32 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7593486b6c78..8af6f1f97704 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -378,6 +378,7 @@
SUBDIR += jq
SUBDIR += jrefentry
SUBDIR += jshon
+ SUBDIR += json-yaml
SUBDIR += kdiff3
SUBDIR += kenlm
SUBDIR += kf5-kcodecs
diff --git a/textproc/json-yaml/Makefile b/textproc/json-yaml/Makefile
new file mode 100644
index 000000000000..8d8d25f254a6
--- /dev/null
+++ b/textproc/json-yaml/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= json-yaml
+DISTVERSION= 1.1.2
+CATEGORIES= textproc
+
+MAINTAINER= ik@sjmulder.nl
+COMMENT= Convert JSON to YAML
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+LIB_DEPENDS= libyajl.so:devel/yajl \
+ libyaml.so:textproc/libyaml
+
+MAKE_ARGS+= MANPREFIX=${PREFIX}/man
+
+USE_GITHUB= yes
+GH_ACCOUNT= sjmulder
+
+PLIST_FILES= bin/json-yaml \
+ man/man1/json-yaml.1.gz
+
+.include <bsd.port.mk>
diff --git a/textproc/json-yaml/distinfo b/textproc/json-yaml/distinfo
new file mode 100644
index 000000000000..dc6d00977578
--- /dev/null
+++ b/textproc/json-yaml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545817767
+SHA256 (sjmulder-json-yaml-1.1.2_GH0.tar.gz) = a3302a0492186225388f13bd1a9bcd0759dfa2d39d2fef9768583de8da3420ad
+SIZE (sjmulder-json-yaml-1.1.2_GH0.tar.gz) = 4381
diff --git a/textproc/json-yaml/pkg-descr b/textproc/json-yaml/pkg-descr
new file mode 100644
index 000000000000..206f746b758b
--- /dev/null
+++ b/textproc/json-yaml/pkg-descr
@@ -0,0 +1,4 @@
+json-yaml is a small command line utility to convert JSON to YAML.
+It is useful to get more readable output from web APIs and such.
+
+WWW: https://github.com/sjmulder/json-yaml