aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/Makefile1
-rw-r--r--science/liblinear/Makefile51
-rw-r--r--science/liblinear/distinfo3
-rw-r--r--science/liblinear/pkg-descr16
-rw-r--r--science/liblr/Makefile51
-rw-r--r--science/liblr/distinfo3
-rw-r--r--science/liblr/pkg-descr16
7 files changed, 141 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index fb367c0e0f1d..6d13e5a72f07 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -62,6 +62,7 @@
SUBDIR += libctl
SUBDIR += libghemical
SUBDIR += libint
+ SUBDIR += liblr
SUBDIR += libsvm
SUBDIR += libsvm-python
SUBDIR += linsmith
diff --git a/science/liblinear/Makefile b/science/liblinear/Makefile
new file mode 100644
index 000000000000..cf551fae1aa2
--- /dev/null
+++ b/science/liblinear/Makefile
@@ -0,0 +1,51 @@
+# New ports collection Makefile for: liblr
+# Date created: May 14 2007
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liblr
+PORTVERSION= 1.00
+CATEGORIES= science math
+MASTER_SITES= http://www.csie.ntu.edu.tw/~cjlin/liblr/ \
+ http://www.csie.ntu.edu.tw/~cjlin/liblr/oldfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/0$//}
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= A library for Large Regularized Logistic Regression
+
+OPTIONS= OCFLAGS "Use optimized CFLAGS" On
+
+USE_ZIP= yes
+
+MAKE_ENV= CC="${CC}" CXXC="${CXX}"
+
+TXT_DOCS= COPYRIGHT README
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ${TXT_DOCS}
+.endif
+
+PLIST_FILES= bin/lr-train bin/lr-predict
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_OCFLAGS)
+# same as LIBIR itself
+CFLAGS= -Wall -O3
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lr-train ${TARGETDIR}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/lr-predict ${TARGETDIR}/bin/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ for f in ${TXT_DOCS}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
+ done
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/science/liblinear/distinfo b/science/liblinear/distinfo
new file mode 100644
index 000000000000..6f6dff9396e7
--- /dev/null
+++ b/science/liblinear/distinfo
@@ -0,0 +1,3 @@
+MD5 (liblr-1.0.zip) = 6407b44f889c1465df341d5242f30480
+SHA256 (liblr-1.0.zip) = 1435e9dd96f9723872dc624d0ea3a12b0b6ab5d7240f41765c3fd69677bcbed3
+SIZE (liblr-1.0.zip) = 153199
diff --git a/science/liblinear/pkg-descr b/science/liblinear/pkg-descr
new file mode 100644
index 000000000000..572349efc4bf
--- /dev/null
+++ b/science/liblinear/pkg-descr
@@ -0,0 +1,16 @@
+LIBLR is a linear classifier for data with millions of instances and
+features. It implement a trust region Newton method in
+
+C.-J. Lin, R. C. Weng, and S. S. Keerthi. Trust region Newton method
+for large-scale regularized logistic regression. Technical report, 2007.
+A short version appears in ICML 2007.
+
+Main features of LIBLR include
+
+Same data format as LIBSVM and similar usage
+One-vs-the rest multi-class classification
+Cross validation for model selection
+Probability estimates
+Weights for unbalanced data
+
+WWW: http://www.csie.ntu.edu.tw/~cjlin/liblr/
diff --git a/science/liblr/Makefile b/science/liblr/Makefile
new file mode 100644
index 000000000000..cf551fae1aa2
--- /dev/null
+++ b/science/liblr/Makefile
@@ -0,0 +1,51 @@
+# New ports collection Makefile for: liblr
+# Date created: May 14 2007
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= liblr
+PORTVERSION= 1.00
+CATEGORIES= science math
+MASTER_SITES= http://www.csie.ntu.edu.tw/~cjlin/liblr/ \
+ http://www.csie.ntu.edu.tw/~cjlin/liblr/oldfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/0$//}
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= A library for Large Regularized Logistic Regression
+
+OPTIONS= OCFLAGS "Use optimized CFLAGS" On
+
+USE_ZIP= yes
+
+MAKE_ENV= CC="${CC}" CXXC="${CXX}"
+
+TXT_DOCS= COPYRIGHT README
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= ${TXT_DOCS}
+.endif
+
+PLIST_FILES= bin/lr-train bin/lr-predict
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_OCFLAGS)
+# same as LIBIR itself
+CFLAGS= -Wall -O3
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lr-train ${TARGETDIR}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/lr-predict ${TARGETDIR}/bin/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ for f in ${TXT_DOCS}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$f ${DOCSDIR}; \
+ done
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/science/liblr/distinfo b/science/liblr/distinfo
new file mode 100644
index 000000000000..6f6dff9396e7
--- /dev/null
+++ b/science/liblr/distinfo
@@ -0,0 +1,3 @@
+MD5 (liblr-1.0.zip) = 6407b44f889c1465df341d5242f30480
+SHA256 (liblr-1.0.zip) = 1435e9dd96f9723872dc624d0ea3a12b0b6ab5d7240f41765c3fd69677bcbed3
+SIZE (liblr-1.0.zip) = 153199
diff --git a/science/liblr/pkg-descr b/science/liblr/pkg-descr
new file mode 100644
index 000000000000..572349efc4bf
--- /dev/null
+++ b/science/liblr/pkg-descr
@@ -0,0 +1,16 @@
+LIBLR is a linear classifier for data with millions of instances and
+features. It implement a trust region Newton method in
+
+C.-J. Lin, R. C. Weng, and S. S. Keerthi. Trust region Newton method
+for large-scale regularized logistic regression. Technical report, 2007.
+A short version appears in ICML 2007.
+
+Main features of LIBLR include
+
+Same data format as LIBSVM and similar usage
+One-vs-the rest multi-class classification
+Cross validation for model selection
+Probability estimates
+Weights for unbalanced data
+
+WWW: http://www.csie.ntu.edu.tw/~cjlin/liblr/