aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--print/cups-base/Makefile3
-rw-r--r--print/cups-base/files/patch-configure18
-rw-r--r--print/cups-base/pkg-plist1
3 files changed, 17 insertions, 5 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index e3f010a218f8..faddebbb4818 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -24,6 +24,7 @@ CONFLICTS= LPRng-[0-9]*
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_GHOSTSCRIPT= yes
GNU_CONFIGURE= yes
USE_RC_SUBR= cupsd
CFLAGS+= ${PTHREAD_CFLAGS}
@@ -34,6 +35,8 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" DSOFLAGS="${DSOFLAGS}
CONFIGURE_ARGS+= --localstatedir=/var \
--disable-slp \
--disable-gssapi \
+ --enable-pdftops \
+ --with-pdftops=gs \
--with-cups-user=${CUPSOWN} \
--with-cups-group=${CUPSGRP} \
--with-system-groups=${CUPSSYSGRP} \
diff --git a/print/cups-base/files/patch-configure b/print/cups-base/files/patch-configure
index 1206ccb67246..81f5d483cfde 100644
--- a/print/cups-base/files/patch-configure
+++ b/print/cups-base/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2008-04-01 23:59:43.000000000 +0200
-+++ configure 2008-04-02 15:36:59.000000000 +0200
-@@ -6281,6 +6281,7 @@
+--- configure.orig 2009-04-16 22:02:06.000000000 +0200
++++ configure 2009-05-05 20:42:19.000000000 +0200
+@@ -6287,6 +6287,7 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
$ac_includes_default
@@ -8,7 +8,7 @@
#include <sys/ucred.h>
_ACEOF
rm -f conftest.$ac_objext
-@@ -7637,7 +7638,7 @@
+@@ -7643,7 +7644,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
@@ -17,7 +17,15 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
-@@ -16361,7 +16362,7 @@
+@@ -11782,6 +11783,7 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ $ac_includes_default
++#include <netinet/in.h>
+ #include <resolv.h>
+ _ACEOF
+ rm -f conftest.$ac_objext
+@@ -16791,7 +16793,7 @@
if test x$ac_cv_header_pthread_h = xyes; then
diff --git a/print/cups-base/pkg-plist b/print/cups-base/pkg-plist
index 8ff794dfa347..3b343850e42c 100644
--- a/print/cups-base/pkg-plist
+++ b/print/cups-base/pkg-plist
@@ -135,6 +135,7 @@ sbin/reject
%%DATADIR%%/charmaps/iso-8859-7.txt
%%DATADIR%%/charmaps/iso-8859-8.txt
%%DATADIR%%/charmaps/iso-8859-9.txt
+%%DATADIR%%/charmaps/jis-x0213.txt
%%DATADIR%%/charmaps/koi8-r.txt
%%DATADIR%%/charmaps/koi8-u.txt
%%DATADIR%%/charmaps/mac-roman.txt