aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/asterisk13/Makefile4
-rw-r--r--net/asterisk13/distinfo6
-rw-r--r--net/asterisk13/files/patch-configure106
3 files changed, 44 insertions, 72 deletions
diff --git a/net/asterisk13/Makefile b/net/asterisk13/Makefile
index 98a9d6567e5d..ee9b1c4a9fa5 100644
--- a/net/asterisk13/Makefile
+++ b/net/asterisk13/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= asterisk
-PORTVERSION= 13.20.0
+PORTVERSION= 13.21.0
CATEGORIES= net
MASTER_SITES= https://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
MASTER_SITE_SUBDIR= asterisk/ \
@@ -146,7 +146,7 @@ LDAP_CONFIGURE_WITH= ldap
LDAP_USE= OPENLDAP=yes
LUA_CONFIGURE_WITH= lua
-LUA_USES= lua:51
+LUA_USES= lua
LUA_CFLAGS= -I${LUA_INCDIR}
LUA_LDFLAGS= -L${LUA_LIBDIR}
diff --git a/net/asterisk13/distinfo b/net/asterisk13/distinfo
index a4b77f043b4d..2f5e6c13e9da 100644
--- a/net/asterisk13/distinfo
+++ b/net/asterisk13/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1521143571
-SHA256 (asterisk-13.20.0.tar.gz) = a3d6d953f844867ea11e0be22ee6225049cd4f5870df6ab23454623bcfbc94d5
-SIZE (asterisk-13.20.0.tar.gz) = 32986236
+TIMESTAMP = 1525249390
+SHA256 (asterisk-13.21.0.tar.gz) = 73043e4e7721f3ef919b470932e0c303e9a210c75e2cfb669711a51571f79438
+SIZE (asterisk-13.21.0.tar.gz) = 32998111
SHA256 (asterisk-core-sounds-en-g729-1.5.tar.gz) = 8b28a59cfa53b59c76e0a191704f0708e3d83acffab8c5e6f25dfc599f0123f9
SIZE (asterisk-core-sounds-en-g729-1.5.tar.gz) = 1551123
SHA256 (asterisk-moh-opsound-g729-2.03.tar.gz) = 0147ca9a97f0c550227aacb7793499057c4d2c64e021c95f93722f27d5549585
diff --git a/net/asterisk13/files/patch-configure b/net/asterisk13/files/patch-configure
index 131bdc7d7cc9..40b24ea9de96 100644
--- a/net/asterisk13/files/patch-configure
+++ b/net/asterisk13/files/patch-configure
@@ -1,19 +1,7 @@
---- configure.orig 2017-12-20 19:05:45 UTC
+--- configure.orig 2018-04-19 18:29:01 UTC
+++ configure
-@@ -4782,9 +4782,9 @@ astheaderdir='${includedir}/asterisk'
- astlibdir='${libdir}'
- astmoddir='${libdir}/asterisk/modules'
- astmandir='${mandir}'
--astvarlibdir='${localstatedir}/lib/asterisk'
-+astvarlibdir='${prefix}/share/asterisk'
- astdatadir='${astvarlibdir}'
--astdbdir='${astvarlibdir}'
-+astdbdir='${localstatedir}/db/asterisk'
- astkeydir='${astvarlibdir}'
- astspooldir='${localstatedir}/spool/asterisk'
- astlogdir='${localstatedir}/log/asterisk'
-@@ -4807,8 +4807,6 @@ esac
- case "${host_os}" in
+@@ -4640,8 +4640,6 @@ case "${host_os}" in
+ ;;
freebsd*)
ac_default_prefix=/usr/local
- CPPFLAGS=-I/usr/local/include
@@ -21,7 +9,7 @@
;;
openbsd*)
ac_default_prefix=/usr/local
-@@ -20266,6 +20264,8 @@ $as_echo_n "checking for getifaddrs() support... " >&6
+@@ -20421,6 +20419,8 @@ $as_echo_n "checking for getifaddrs() support... " >&6
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -30,73 +18,57 @@
#include <ifaddrs.h>
int
main ()
-@@ -29529,13 +29529,13 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
-
- ast_ext_lib_check_save_CFLAGS="${CFLAGS}"
- CFLAGS="${CFLAGS} "
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua5.2" >&5
--$as_echo_n "checking for luaL_newstate in -llua5.2... " >&6; }
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua-5.2" >&5
-+$as_echo_n "checking for luaL_newstate in -lluai-5.2... " >&6; }
- if ${ac_cv_lib_lua5_2_luaL_newstate+:} false; then :
- $as_echo_n "(cached) " >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-llua5.2 ${pbxlibdir} -lm $LIBS"
-+LIBS="-llua-5.2 ${pbxlibdir} -lm $LIBS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
+@@ -28701,6 +28701,8 @@ fi
-@@ -29576,7 +29576,7 @@ fi
+ for ver in 5.3 5.2 5.1; do
- # now check for the header.
- if test "${AST_LUA_FOUND}" = "yes"; then
-- LUA_LIB="${pbxlibdir} -llua5.2 -lm"
-+ LUA_LIB="${pbxlibdir} -llua-5.2 -lm"
- # if --with-LUA=DIR has been specified, use it.
- if test "x${LUA_DIR}" != "x"; then
- LUA_INCLUDE="-I${LUA_DIR}/include"
-@@ -29586,7 +29586,7 @@ fi
- # check for the header
- ast_ext_lib_check_saved_CPPFLAGS="${CPPFLAGS}"
- CPPFLAGS="${CPPFLAGS} ${LUA_INCLUDE}"
-- ac_fn_c_check_header_mongrel "$LINENO" "lua5.2/lua.h" "ac_cv_header_lua5_2_lua_h" "$ac_includes_default"
-+ ac_fn_c_check_header_mongrel "$LINENO" "lua52/lua.h" "ac_cv_header_lua5_2_lua_h" "$ac_includes_default"
- if test "x$ac_cv_header_lua5_2_lua_h" = xyes; then :
- LUA_HEADER_FOUND=1
- else
-@@ -29633,13 +29633,13 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
-
- ast_ext_lib_check_save_CFLAGS="${CFLAGS}"
++vernodot=`echo ${ver} | sed 's/\.//'`
++
+ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no"; then
+ pbxlibdir=""
+ # if --with-LUA=DIR has been specified, use it.
+@@ -28716,12 +28718,12 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
CFLAGS="${CFLAGS} "
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua5.1" >&5
--$as_echo_n "checking for luaL_newstate in -llua5.1... " >&6; }
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua-5.1" >&5
-+$as_echo_n "checking for luaL_newstate in -llua-5.1... " >&6; }
- if ${ac_cv_lib_lua5_1_luaL_newstate+:} false; then :
+ as_ac_Lib=`$as_echo "ac_cv_lib_lua${ver}''_luaL_newstate" | $as_tr_sh`
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua${ver}" >&5
+-$as_echo_n "checking for luaL_newstate in -llua${ver}... " >&6; }
++$as_echo_n "checking for luaL_newstate in -llua-${ver}... " >&6; }
+ if eval \${$as_ac_Lib+:} false; then :
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
--LIBS="-llua5.1 ${pbxlibdir} -lm $LIBS"
-+LIBS="-llua-5.1 ${pbxlibdir} -lm $LIBS"
+-LIBS="-llua${ver} ${pbxlibdir} -lm $LIBS"
++LIBS="-llua-${ver} ${pbxlibdir} -lm $LIBS"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -29680,7 +29680,7 @@ fi
+@@ -28763,7 +28765,7 @@ fi
# now check for the header.
if test "${AST_LUA_FOUND}" = "yes"; then
-- LUA_LIB="${pbxlibdir} -llua5.1 -lm"
-+ LUA_LIB="${pbxlibdir} -llua-5.1 -lm"
+- LUA_LIB="${pbxlibdir} -llua${ver} -lm"
++ LUA_LIB="${pbxlibdir} -llua-${ver} -lm"
# if --with-LUA=DIR has been specified, use it.
if test "x${LUA_DIR}" != "x"; then
LUA_INCLUDE="-I${LUA_DIR}/include"
-@@ -29690,7 +29690,7 @@ fi
- # check for the header
+@@ -28774,7 +28776,7 @@ fi
ast_ext_lib_check_saved_CPPFLAGS="${CPPFLAGS}"
CPPFLAGS="${CPPFLAGS} ${LUA_INCLUDE}"
-- ac_fn_c_check_header_mongrel "$LINENO" "lua5.1/lua.h" "ac_cv_header_lua5_1_lua_h" "$ac_includes_default"
-+ ac_fn_c_check_header_mongrel "$LINENO" "lua51/lua.h" "ac_cv_header_lua5_1_lua_h" "$ac_includes_default"
- if test "x$ac_cv_header_lua5_1_lua_h" = xyes; then :
+ as_ac_Header=`$as_echo "ac_cv_header_lua${ver}/lua.h" | $as_tr_sh`
+-ac_fn_c_check_header_mongrel "$LINENO" "lua${ver}/lua.h" "$as_ac_Header" "$ac_includes_default"
++ac_fn_c_check_header_mongrel "$LINENO" "lua${vernodot}/lua.h" "$as_ac_Header" "$ac_includes_default"
+ if eval test \"x\$"$as_ac_Header"\" = x"yes"; then :
LUA_HEADER_FOUND=1
else
+@@ -28801,9 +28803,9 @@ fi
+
+ if test "x${PBX_LUA}" = "x1" ; then
+ if test x"${LUA_DIR}" = x; then
+- LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua${ver}"
++ LUA_INCLUDE="${LUA_INCLUDE} -I/usr/include/lua${vernodot}"
+ else
+- LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua${ver}"
++ LUA_INCLUDE="${LUA_INCLUDE} -I${LUA_DIR}/lua${vernodot}"
+ fi
+ break;
+ fi