aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/skippy-xd/Makefile36
-rw-r--r--x11-wm/skippy-xd/distinfo3
-rw-r--r--x11-wm/skippy-xd/files/patch-src_config.c22
-rw-r--r--x11-wm/skippy-xd/pkg-descr12
6 files changed, 74 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 2bd431095df3..41090c8285d4 100644
--- a/MOVED
+++ b/MOVED
@@ -3679,7 +3679,6 @@ games/rigsofrods||2012-10-16|Has expired: Broken for more than 6 months
sysutils/bacula2-client||2012-10-20|No longer supported upstream and may contain vulnerabilities. Use sysutils/bacula-client instead
sysutils/bacula2-server||2012-10-20|No longer supported upstream and may contain vulnerabilities. Use sysutils/bacula-server instead
x11-wm/wmcp||2012-10-25|Has expired: No more public distfiles
-x11-wm/skippy-xd||2012-10-25|Has expired: Abandonware, upstream disappeared
x11-wm/skippy||2012-10-25|Has expired: Abandonware, upstream disappeared
x11-wm/matchbox||2012-10-25|Has expired: Abandonware, upstream disappeared
x11-wm/blwm||2012-10-25|Has expired: Abandonware, upstream disappeared
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index ec63a2f4c70e..2c7c96e94349 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -113,6 +113,7 @@
SUBDIR += sawfish
SUBDIR += selectwm
SUBDIR += simple-ccsm
+ SUBDIR += skippy-xd
SUBDIR += spectrwm
SUBDIR += stumpwm
SUBDIR += subtle
diff --git a/x11-wm/skippy-xd/Makefile b/x11-wm/skippy-xd/Makefile
new file mode 100644
index 000000000000..5c84eb574f07
--- /dev/null
+++ b/x11-wm/skippy-xd/Makefile
@@ -0,0 +1,36 @@
+# Created by: Michael Johnson <ahze@ahze.net>
+# $FreeBSD$
+
+PORTNAME= skippy-xd
+PORTVERSION= 0.5.0
+PORTREVISION= 2
+CATEGORIES= x11-wm
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Full-screen Expose-style standalone task switcher for X11
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libgif.so:graphics/giflib \
+ libpng.so:graphics/png
+
+USES= gmake jpeg pkgconfig
+USE_XORG= x11 xcomposite xdamage xext xfixes xft xinerama xrender
+
+USE_GITHUB= yes
+GH_ACCOUNT= richardgv
+GH_TAGNAME= 397216c
+
+MAKE_ARGS= SKIPPYXD_VERSION=${PORTVERSION}-git-${GH_TAGNAME}-2015-02-24
+
+PLIST_FILES= bin/skippy-xd \
+ @sample\ etc/xdg/skippy-xd.rc.sample
+PORTDOCS= CHANGELOG
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-wm/skippy-xd/distinfo b/x11-wm/skippy-xd/distinfo
new file mode 100644
index 000000000000..e6fba9eaaf05
--- /dev/null
+++ b/x11-wm/skippy-xd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1424784900
+SHA256 (richardgv-skippy-xd-0.5.0-397216c_GH0.tar.gz) = 172ab8c0fcbd61df3de27d08b87851c17a31a2e06f99dd42894436921a92e1d9
+SIZE (richardgv-skippy-xd-0.5.0-397216c_GH0.tar.gz) = 57168
diff --git a/x11-wm/skippy-xd/files/patch-src_config.c b/x11-wm/skippy-xd/files/patch-src_config.c
new file mode 100644
index 000000000000..c5af18ff6f02
--- /dev/null
+++ b/x11-wm/skippy-xd/files/patch-src_config.c
@@ -0,0 +1,22 @@
+--- src/config.c.orig 2015-02-24 13:35:00 UTC
++++ src/config.c
+@@ -73,9 +73,9 @@ config_parse(const char *config) {
+ int ix = 0, l_ix = 0;
+ dlist *new_config = 0;
+
+- regcomp(&re_section, "^[[:space:]]*\\[[[:space:]]*([[:alnum:]]*?)[[:space:]]*\\][[:space:]]*$", REG_EXTENDED);
++ regcomp(&re_section, "^[[:space:]]*\\[[[:space:]]*([[:alnum:]]*)[[:space:]]*\\][[:space:]]*$", REG_EXTENDED);
+ regcomp(&re_empty, "^[[:space:]]*#|^[[:space:]]*$", REG_EXTENDED);
+- regcomp(&re_entry, "^[[:space:]]*([[:alnum:]]+)[[:space:]]*=[[:space:]]*(.*?)[[:space:]]*$", REG_EXTENDED);
++ regcomp(&re_entry, "^[[:space:]]*([[:alnum:]]+)[[:space:]]*=[[:space:]]*(.*)[[:space:]]*$", REG_EXTENDED);
+
+ while(1)
+ {
+@@ -150,6 +150,7 @@ config_load(const char *path)
+ fclose(fin);
+ return 0;
+ }
++ data[flen] = '\0';
+
+ fclose(fin);
+
diff --git a/x11-wm/skippy-xd/pkg-descr b/x11-wm/skippy-xd/pkg-descr
new file mode 100644
index 000000000000..716c4c72eabf
--- /dev/null
+++ b/x11-wm/skippy-xd/pkg-descr
@@ -0,0 +1,12 @@
+Skippy-XD is a version of Skippy that uses Xserver's XDamage, XComposite and
+XFixes extensions to provide you with 'live' versions of the windows.
+
+Skippy-XD is best described as a full-screen task-switcher for X11. It tries to
+provide an alternative when taskbars or regular task-switchers aren't the most
+efficient way of switching tasks (like when you have a lot of applications open)
+When activated (currently only through a hotkey), it will arrange and scale
+snapshots of all windows on the current desktop and it'll let you pick a
+window using a mouse or a keyboard. Yes, this is also what expocity and Apple's
+Expose.
+
+WWW: https://github.com/richardgv/skippy-xd