aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.default-versions.mk2
-rw-r--r--UPDATING13
-rw-r--r--databases/php-adodb-ext/Makefile2
-rw-r--r--lang/php5/Makefile2
-rw-r--r--lang/php5/distinfo4
-rw-r--r--lang/php55/Makefile2
-rw-r--r--lang/php55/distinfo4
-rw-r--r--lang/php55/pkg-plist1
-rw-r--r--lang/php56/Makefile2
-rw-r--r--lang/php56/distinfo4
-rw-r--r--lang/php56/pkg-plist1
11 files changed, 27 insertions, 10 deletions
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index d8ac964de294..5ea59cbe2ee0 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -25,7 +25,7 @@ LUA_DEFAULT?= 5.2
MYSQL_DEFAULT?= 5.6
PERL5_DEFAULT?= 5.18
PGSQL_DEFAULT?= 9.3
-PHP_DEFAULT?= 5.4
+PHP_DEFAULT?= 5.6
PYTHON_DEFAULT?= 2.7
PYTHON2_DEFAULT?= 2.7
PYTHON3_DEFAULT?= 3.4
diff --git a/UPDATING b/UPDATING
index ad5328eb523b..dd57cdf268ba 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,19 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20150220:
+ AFFECTS: users of PHP
+
+ The default PHP version has been updated from 5.4 to 5.6.
+
+ If you use binary packages you should make a list of php packages
+ before running 'pkg upgrade':
+
+ # pkg info php5\* > ~/installed-php-ports-list
+
+ After the upgrade, check with such list if all your php extensions
+ are still installed, and reinstall them if needed.
+
20150213:
AFFECTS: users who upgraded from FreeBSD 7.x or older with "make world" but never ran "make delete-old"
AUTHOR: antoine@FreeBSD.org
diff --git a/databases/php-adodb-ext/Makefile b/databases/php-adodb-ext/Makefile
index 8b63ffdbfeaf..836a15beff8d 100644
--- a/databases/php-adodb-ext/Makefile
+++ b/databases/php-adodb-ext/Makefile
@@ -18,6 +18,8 @@ USES= dos2unix zip
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= adodb
+PHP_DEFAULT= 55
+IGNORE_WITH_PHP=56
SUB_FILES= pkg-message
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 5e892748a653..8b2048d0fa78 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= php5
-PORTVERSION= 5.4.37
+PORTVERSION= 5.4.38
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
diff --git a/lang/php5/distinfo b/lang/php5/distinfo
index dce3e9df0944..5f445abeef05 100644
--- a/lang/php5/distinfo
+++ b/lang/php5/distinfo
@@ -1,4 +1,4 @@
-SHA256 (php-5.4.37.tar.bz2) = 857bf6675eeb0ae9c3cd6f9ccdb2a9b7bf89dcfda7f0a80857638fe023f3a8ad
-SIZE (php-5.4.37.tar.bz2) = 12275113
+SHA256 (php-5.4.38.tar.bz2) = abf37db0cfadc9bb814f9df35f6aa966ad63f4f4c4475e432ec625568a5d3e88
+SIZE (php-5.4.38.tar.bz2) = 12273298
SHA256 (php-5.4.x-mail-header.patch) = 005ae1cd8ed17c72d7b09dee9c4466e8b16d4ecba7fe11276731ed6ff9fbb344
SIZE (php-5.4.x-mail-header.patch) = 3379
diff --git a/lang/php55/Makefile b/lang/php55/Makefile
index ba086e7db744..95e8a6b45cd5 100644
--- a/lang/php55/Makefile
+++ b/lang/php55/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= php55
-PORTVERSION= 5.5.21
+PORTVERSION= 5.5.22
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
diff --git a/lang/php55/distinfo b/lang/php55/distinfo
index 25ae3fd835d7..0603bfc842ef 100644
--- a/lang/php55/distinfo
+++ b/lang/php55/distinfo
@@ -1,4 +1,4 @@
-SHA256 (php-5.5.21.tar.bz2) = 62e9429975c4ca5d7067a5052d5388fbf2ac8c51eeee581d59b04cc5a8da83fe
-SIZE (php-5.5.21.tar.bz2) = 13306064
+SHA256 (php-5.5.22.tar.bz2) = c218c184bef2905bc79fcdda6040f3d1738261395fb706396935d1c6f6e162bb
+SIZE (php-5.5.22.tar.bz2) = 13305486
SHA256 (php-5.5.x-mail-header.patch) = b0b5a7c961b2052eb14d9528e76155cbeaa881fb9b4a49f452f9dab07b6fb1c4
SIZE (php-5.5.x-mail-header.patch) = 3379
diff --git a/lang/php55/pkg-plist b/lang/php55/pkg-plist
index 9c2a30bac5cc..b3d6118d98f0 100644
--- a/lang/php55/pkg-plist
+++ b/lang/php55/pkg-plist
@@ -91,6 +91,7 @@ include/php/ext/ereg/regex/regex2.h
include/php/ext/ereg/regex/utils.h
include/php/ext/libxml/php_libxml.h
include/php/ext/mysqlnd/config-win.h
+include/php/ext/mysqlnd/mysql_float_to_double.h
include/php/ext/mysqlnd/mysqlnd.h
include/php/ext/mysqlnd/mysqlnd_alloc.h
include/php/ext/mysqlnd/mysqlnd_block_alloc.h
diff --git a/lang/php56/Makefile b/lang/php56/Makefile
index 6c887c27de9b..fe6375473e08 100644
--- a/lang/php56/Makefile
+++ b/lang/php56/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= php56
-PORTVERSION= 5.6.5
+PORTVERSION= 5.6.6
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
diff --git a/lang/php56/distinfo b/lang/php56/distinfo
index 702a9db73154..dd1b5109f9f5 100644
--- a/lang/php56/distinfo
+++ b/lang/php56/distinfo
@@ -1,4 +1,4 @@
-SHA256 (php-5.6.5.tar.bz2) = adab4c0775512a5ca0ae74e08efdc941d92529b75283e0f44d3f53822cdfd06d
-SIZE (php-5.6.5.tar.bz2) = 13556146
+SHA256 (php-5.6.6.tar.bz2) = 09625c9b65e0c8198dc76995a35f0feec0e13ea4489526e64a00954b12adbb4c
+SIZE (php-5.6.6.tar.bz2) = 13687928
SHA256 (php-5.5.x-mail-header.patch) = b0b5a7c961b2052eb14d9528e76155cbeaa881fb9b4a49f452f9dab07b6fb1c4
SIZE (php-5.5.x-mail-header.patch) = 3379
diff --git a/lang/php56/pkg-plist b/lang/php56/pkg-plist
index cd1cb990691b..11ae31535aad 100644
--- a/lang/php56/pkg-plist
+++ b/lang/php56/pkg-plist
@@ -93,6 +93,7 @@ include/php/ext/ereg/regex/regex2.h
include/php/ext/ereg/regex/utils.h
include/php/ext/libxml/php_libxml.h
include/php/ext/mysqlnd/config-win.h
+include/php/ext/mysqlnd/mysql_float_to_double.h
include/php/ext/mysqlnd/mysqlnd.h
include/php/ext/mysqlnd/mysqlnd_alloc.h
include/php/ext/mysqlnd/mysqlnd_block_alloc.h