aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/gnome-schedule/Makefile29
-rw-r--r--sysutils/gnome-schedule/distinfo4
-rw-r--r--sysutils/gnome-schedule/pkg-plist129
3 files changed, 108 insertions, 54 deletions
diff --git a/sysutils/gnome-schedule/Makefile b/sysutils/gnome-schedule/Makefile
index a5df39839090..8c519ec87a7f 100644
--- a/sysutils/gnome-schedule/Makefile
+++ b/sysutils/gnome-schedule/Makefile
@@ -7,25 +7,48 @@
#
PORTNAME= gnome-schedule
-PORTVERSION= 2.1.1
-PORTREVISION= 3
+PORTVERSION= 2.1.5
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-2/${PORTNAME}-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME GUI for configuring a users crontab
+LICENSE= GPLv2
+
BUILD_DEPENDS= yelp:${PORTSDIR}/x11/yelp
RUN_DEPENDS= yelp:${PORTSDIR}/x11/yelp
USE_PYTHON= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack pygnome2
-USE_GETTEXT= yes
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
+.if !defined(WITHOUT_APPLET)
+CONFIGURE_ARGS+= --enable-applet
+PLIST_SUB+= APPLET=""
+.else
+CONFIGURE_ARGS+= --disable-applet
+PLIST_SUB+= APPLET="@comment "
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-extract:
@${RM} ${WRKSRC}/src/config.py
+post-install:
+ @${ECHO} "======================================================================"
+ @${ECHO} " To make one-time tasks work, add your username to /var/at/at.allow "
+ @${ECHO} " Note that one-time tasks will never shows in ${PORTNAME}'s "
+ @${ECHO} " task-list because of lacking FreeBSD's atq output format support. "
+ @${ECHO} "======================================================================"
+
.include <bsd.port.mk>
diff --git a/sysutils/gnome-schedule/distinfo b/sysutils/gnome-schedule/distinfo
index 42ae8c15c9e5..3130ca54e700 100644
--- a/sysutils/gnome-schedule/distinfo
+++ b/sysutils/gnome-schedule/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome-schedule-2.1.1.tar.gz) = c12b17d61c9ed658f75cfbf57fcbde26c97379ea5cde2b55ddc74068d37d58d7
-SIZE (gnome-schedule-2.1.1.tar.gz) = 1440624
+SHA256 (gnome-schedule-2.1.5.tar.gz) = 0969058825527f3617dbc499ba2b13763e4827b21f343d02a652fce775f20726
+SIZE (gnome-schedule-2.1.5.tar.gz) = 1746445
diff --git a/sysutils/gnome-schedule/pkg-plist b/sysutils/gnome-schedule/pkg-plist
index 40c739a0125c..e5b42cffbebc 100644
--- a/sysutils/gnome-schedule/pkg-plist
+++ b/sysutils/gnome-schedule/pkg-plist
@@ -1,5 +1,7 @@
bin/gnome-schedule
-libdata/bonobo/servers/GNOME_GnomeSchedule.server
+bin/gnome-schedule-export
+bin/gnome-schedule-import
+%%APPLET%%libdata/bonobo/servers/GNOME_GnomeSchedule.server
share/applications/gnome-schedule.desktop
%%DATADIR%%/addWindow.py
%%DATADIR%%/addWindow.pyc
@@ -25,7 +27,16 @@ share/applications/gnome-schedule.desktop
%%DATADIR%%/data.py
%%DATADIR%%/data.pyc
%%DATADIR%%/data.pyo
-%%DATADIR%%/gnome-schedule-applet.xml
+%%DATADIR%%/db.py
+%%DATADIR%%/db.pyc
+%%DATADIR%%/db.pyo
+%%APPLET%%%%DATADIR%%/gnome-schedule-applet.xml
+%%DATADIR%%/gnome-schedule-export.py
+%%DATADIR%%/gnome-schedule-export.pyc
+%%DATADIR%%/gnome-schedule-export.pyo
+%%DATADIR%%/gnome-schedule-import.py
+%%DATADIR%%/gnome-schedule-import.pyc
+%%DATADIR%%/gnome-schedule-import.pyo
%%DATADIR%%/gnome-schedule.glade
%%DATADIR%%/gnome-schedule.py
%%DATADIR%%/gnome-schedule.pyc
@@ -36,9 +47,9 @@ share/applications/gnome-schedule.desktop
%%DATADIR%%/mainWindow.py
%%DATADIR%%/mainWindow.pyc
%%DATADIR%%/mainWindow.pyo
-%%DATADIR%%/scheduleapplet.py
-%%DATADIR%%/scheduleapplet.pyc
-%%DATADIR%%/scheduleapplet.pyo
+%%APPLET%%%%DATADIR%%/scheduleapplet.py
+%%APPLET%%%%DATADIR%%/scheduleapplet.pyc
+%%APPLET%%%%DATADIR%%/scheduleapplet.pyo
%%DATADIR%%/setuserWindow.py
%%DATADIR%%/setuserWindow.pyc
%%DATADIR%%/setuserWindow.pyo
@@ -61,6 +72,12 @@ share/gnome/help/gnome-schedule/C/figures/gnome-schedule_new_task_recurrent.png
share/gnome/help/gnome-schedule/C/figures/gnome-schedule_templates.png
share/gnome/help/gnome-schedule/C/gnome-schedule.xml
share/gnome/help/gnome-schedule/C/legal.xml
+share/gnome/help/gnome-schedule/cs/figures/gnome-schedule_main.png
+share/gnome/help/gnome-schedule/cs/figures/gnome-schedule_new_task.png
+share/gnome/help/gnome-schedule/cs/figures/gnome-schedule_new_task_once.png
+share/gnome/help/gnome-schedule/cs/figures/gnome-schedule_new_task_recurrent.png
+share/gnome/help/gnome-schedule/cs/figures/gnome-schedule_templates.png
+share/gnome/help/gnome-schedule/cs/gnome-schedule.xml
share/gnome/help/gnome-schedule/de/figures/gnome-schedule_main.png
share/gnome/help/gnome-schedule/de/figures/gnome-schedule_new_task.png
share/gnome/help/gnome-schedule/de/figures/gnome-schedule_new_task_once.png
@@ -91,54 +108,64 @@ share/gnome/help/gnome-schedule/oc/figures/gnome-schedule_new_task_once.png
share/gnome/help/gnome-schedule/oc/figures/gnome-schedule_new_task_recurrent.png
share/gnome/help/gnome-schedule/oc/figures/gnome-schedule_templates.png
share/gnome/help/gnome-schedule/oc/gnome-schedule.xml
+share/gnome/help/gnome-schedule/sl/figures/gnome-schedule_main.png
+share/gnome/help/gnome-schedule/sl/figures/gnome-schedule_new_task.png
+share/gnome/help/gnome-schedule/sl/figures/gnome-schedule_new_task_once.png
+share/gnome/help/gnome-schedule/sl/figures/gnome-schedule_new_task_recurrent.png
+share/gnome/help/gnome-schedule/sl/figures/gnome-schedule_templates.png
+share/gnome/help/gnome-schedule/sl/gnome-schedule.xml
share/gnome/help/gnome-schedule/sv/figures/gnome-schedule_main.png
share/gnome/help/gnome-schedule/sv/figures/gnome-schedule_new_task.png
share/gnome/help/gnome-schedule/sv/figures/gnome-schedule_new_task_once.png
share/gnome/help/gnome-schedule/sv/figures/gnome-schedule_new_task_recurrent.png
share/gnome/help/gnome-schedule/sv/figures/gnome-schedule_templates.png
share/gnome/help/gnome-schedule/sv/gnome-schedule.xml
-share/locale/ar/LC_MESSAGES/gnome-schedule.mo
-share/locale/bg/LC_MESSAGES/gnome-schedule.mo
-share/locale/ca/LC_MESSAGES/gnome-schedule.mo
-share/locale/cs/LC_MESSAGES/gnome-schedule.mo
-share/locale/da/LC_MESSAGES/gnome-schedule.mo
-share/locale/de/LC_MESSAGES/gnome-schedule.mo
-share/locale/dz/LC_MESSAGES/gnome-schedule.mo
-share/locale/el/LC_MESSAGES/gnome-schedule.mo
-share/locale/en_CA/LC_MESSAGES/gnome-schedule.mo
-share/locale/en_GB/LC_MESSAGES/gnome-schedule.mo
-share/locale/es/LC_MESSAGES/gnome-schedule.mo
-share/locale/fi/LC_MESSAGES/gnome-schedule.mo
-share/locale/fr/LC_MESSAGES/gnome-schedule.mo
-share/locale/gl/LC_MESSAGES/gnome-schedule.mo
-share/locale/gu/LC_MESSAGES/gnome-schedule.mo
-share/locale/hu/LC_MESSAGES/gnome-schedule.mo
-share/locale/it/LC_MESSAGES/gnome-schedule.mo
-share/locale/lt/LC_MESSAGES/gnome-schedule.mo
-share/locale/nb/LC_MESSAGES/gnome-schedule.mo
-share/locale/ne/LC_MESSAGES/gnome-schedule.mo
-share/locale/nl/LC_MESSAGES/gnome-schedule.mo
-share/locale/nn/LC_MESSAGES/gnome-schedule.mo
-share/locale/oc/LC_MESSAGES/gnome-schedule.mo
-share/locale/pa/LC_MESSAGES/gnome-schedule.mo
-share/locale/pt/LC_MESSAGES/gnome-schedule.mo
-share/locale/pt_BR/LC_MESSAGES/gnome-schedule.mo
-share/locale/ru/LC_MESSAGES/gnome-schedule.mo
-share/locale/rw/LC_MESSAGES/gnome-schedule.mo
-share/locale/sl/LC_MESSAGES/gnome-schedule.mo
-share/locale/sq/LC_MESSAGES/gnome-schedule.mo
-share/locale/sv/LC_MESSAGES/gnome-schedule.mo
-share/locale/uk/LC_MESSAGES/gnome-schedule.mo
-share/locale/vi/LC_MESSAGES/gnome-schedule.mo
-share/locale/zh_CN/LC_MESSAGES/gnome-schedule.mo
-share/locale/zh_HK/LC_MESSAGES/gnome-schedule.mo
-share/locale/zh_TW/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/da/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/dz/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/el/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/en_CA/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/gu/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/ne/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/oc/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/gnome-schedule.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/gnome-schedule.mo
share/omf/gnome-schedule/gnome-schedule-C.omf
+share/omf/gnome-schedule/gnome-schedule-cs.omf
share/omf/gnome-schedule/gnome-schedule-de.omf
share/omf/gnome-schedule/gnome-schedule-es.omf
share/omf/gnome-schedule/gnome-schedule-fr.omf
share/omf/gnome-schedule/gnome-schedule-it.omf
share/omf/gnome-schedule/gnome-schedule-oc.omf
+share/omf/gnome-schedule/gnome-schedule-sl.omf
share/omf/gnome-schedule/gnome-schedule-sv.omf
share/pixmaps/gnome-schedule/at.svg
share/pixmaps/gnome-schedule/calendar.svg
@@ -147,16 +174,18 @@ share/pixmaps/gnome-schedule/gnome-schedule.svg
share/pixmaps/gnome-schedule/template.svg
@dirrm share/pixmaps/gnome-schedule
@dirrm share/omf/gnome-schedule
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
+%%NLS%%@dirrmtry share/locale/zh_HK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/zh_HK
+%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/rw
+%%NLS%%@dirrmtry share/locale/oc/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/oc
+%%NLS%%@dirrmtry share/locale/dz/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/dz
@dirrm share/gnome/help/gnome-schedule/sv/figures
@dirrm share/gnome/help/gnome-schedule/sv
+@dirrm share/gnome/help/gnome-schedule/sl/figures
+@dirrm share/gnome/help/gnome-schedule/sl
@dirrm share/gnome/help/gnome-schedule/oc/figures
@dirrm share/gnome/help/gnome-schedule/oc
@dirrm share/gnome/help/gnome-schedule/it/figures
@@ -167,6 +196,8 @@ share/pixmaps/gnome-schedule/template.svg
@dirrm share/gnome/help/gnome-schedule/es
@dirrm share/gnome/help/gnome-schedule/de/figures
@dirrm share/gnome/help/gnome-schedule/de
+@dirrm share/gnome/help/gnome-schedule/cs/figures
+@dirrm share/gnome/help/gnome-schedule/cs
@dirrm share/gnome/help/gnome-schedule/C/figures
@dirrm share/gnome/help/gnome-schedule/C
@dirrm share/gnome/help/gnome-schedule