aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.perl.mk2
-rw-r--r--Mk/bsd.port.mk2
-rw-r--r--UPDATING10
-rw-r--r--lang/perl5.10/Makefile2
-rw-r--r--lang/perl5.12/Makefile2
-rw-r--r--lang/perl5.14/Makefile2
-rw-r--r--lang/perl5.16/Makefile2
-rw-r--r--lang/perl5.8/Makefile2
8 files changed, 17 insertions, 7 deletions
diff --git a/Mk/bsd.perl.mk b/Mk/bsd.perl.mk
index d95689232c3e..ce8f14a8d702 100644
--- a/Mk/bsd.perl.mk
+++ b/Mk/bsd.perl.mk
@@ -84,7 +84,7 @@ PERL_Include_MAINTAINER= perl@FreeBSD.org
# to set one of the conditionals that force the inclusion of bsd.perl.mk
.if defined(_PERL_REFACTORING_COMPLETE)
-PERL_VERSION?= 5.8.9
+PERL_VERSION?= 5.10.1
.if !defined(PERL_LEVEL) && defined(PERL_VERSION)
perl_major= ${PERL_VERSION:C|\..*||}
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 4b0336defeae..9c4de5912865 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1452,7 +1452,7 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
# to set one of the conditionals that force the inclusion of bsd.perl.mk
.if !defined(_PERL_REFACTORING_COMPLETE)
-PERL_VERSION?= 5.8.9
+PERL_VERSION?= 5.10.1
.if !defined(PERL_LEVEL) && defined(PERL_VERSION)
perl_major= ${PERL_VERSION:C|^([1-9]+).*|\1|}
diff --git a/UPDATING b/UPDATING
index d288f93e1bfb..e3d769963962 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,16 @@ You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20100205:
+ AFFECTS: users of lang/perl*
+ AUTHOR: skv@FreeBSD.org
+
+ Change the default version of Perl to 5.10.
+
+ If you have already installed lang/perl5.8 and
+ want switch to lang/perl5.10 please follow instructions
+ in the entry 20090328 in this file.
+
+20100205:
AFFECTS: users of net/samba34
AUTHOR: timur@FreeBSD.org
diff --git a/lang/perl5.10/Makefile b/lang/perl5.10/Makefile
index aad0acd41238..55480b6b7b21 100644
--- a/lang/perl5.10/Makefile
+++ b/lang/perl5.10/Makefile
@@ -147,7 +147,7 @@ LINK_USRBIN= yes
LINK_USRBIN= no
.endif
-NO_LATEST_LINK= yes
+LATEST_LINK= perl
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index aad0acd41238..55480b6b7b21 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -147,7 +147,7 @@ LINK_USRBIN= yes
LINK_USRBIN= no
.endif
-NO_LATEST_LINK= yes
+LATEST_LINK= perl
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index aad0acd41238..55480b6b7b21 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -147,7 +147,7 @@ LINK_USRBIN= yes
LINK_USRBIN= no
.endif
-NO_LATEST_LINK= yes
+LATEST_LINK= perl
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index aad0acd41238..55480b6b7b21 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -147,7 +147,7 @@ LINK_USRBIN= yes
LINK_USRBIN= no
.endif
-NO_LATEST_LINK= yes
+LATEST_LINK= perl
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3
diff --git a/lang/perl5.8/Makefile b/lang/perl5.8/Makefile
index 8e88a66a83e2..080d33e03e2b 100644
--- a/lang/perl5.8/Makefile
+++ b/lang/perl5.8/Makefile
@@ -146,7 +146,7 @@ LINK_USRBIN= yes
LINK_USRBIN= no
.endif
-LATEST_LINK= perl
+NO_LATEST_LINK= yes
PLIST_SUB+= NEED_USE_PERL="@comment "