aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING7
-rw-r--r--www/lighttpd/Makefile66
-rw-r--r--www/lighttpd/files/h264_streaming.conf19
-rw-r--r--www/lighttpd/files/pkg-descr.mod_geoip4
-rw-r--r--www/lighttpd/files/pkg-descr.mod_h264_streaming9
-rw-r--r--www/lighttpd/files/pkg-plist.mod_geoip6
-rw-r--r--www/lighttpd/files/pkg-plist.mod_h264_streaming6
7 files changed, 76 insertions, 41 deletions
diff --git a/UPDATING b/UPDATING
index e6745c8027c6..e4b6ecda9715 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,13 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20100817:
+ AFFECTS: users of www/lighttpd
+ AUTHOR: mm@FreeBSD.org
+
+ The modules mod_geoip and mod_h264_streaming have been moved into slave
+ ports: www/lighttpd-mod_geoip and www/lighttpd-mod_h264_streaming
+
20100818:
AFFECTS: users of www/lighttpd
AUTHOR: mm@FreeBSD.org
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 60b9d0abffc8..b0677c3ada95 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -5,35 +5,43 @@
# $FreeBSD$
#
-PORTNAME= lighttpd
+PORTNAME?= lighttpd
PORTVERSION= 1.4.28
-CATEGORIES= www
-MASTER_SITES= http://download.lighttpd.net/lighttpd/releases-1.4.x/
+PORTREVISION= 1
+CATEGORIES?= www
+MASTER_SITES?= http://download.lighttpd.net/lighttpd/releases-1.4.x/
-MAINTAINER= mm@FreeBSD.org
-COMMENT= A secure, fast, compliant, and very flexible Web Server
+MAINTAINER?= mm@FreeBSD.org
+COMMENT?= A secure, fast, compliant, and very flexible Web Server
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
-LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
-USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_GNOME= lthack
-USE_RC_SUBR= lighttpd.sh
-CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd --enable-static
+.if defined(_BUILDING_LIGHTTPD_MODULE)
+USE_AUTOTOOLS?= libtool:22
+CONFIGURE_ARGS?= --libdir=${PREFIX}/lib/lighttpd --enable-static
+.else
+USE_AUTOTOOLS= libtool:22
+CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd --enable-static
+.endif # defined(_BUILDING_LIGHTTPD_MODULE)
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+
+.if !defined(_BUILDING_LIGHTTPD_MODULE)
+USE_RC_SUBR= lighttpd.sh
+
MAN8= lighttpd.8
OPTIONS= BZIP2 "Enable Bzip2 support" off \
CML "Enable Cache Meta Language support" off \
FAM "Enable fam/gamin support" off \
GDBM "Enable gdbm storage support" off \
- GEOIP "Enable GeoIP support" off \
- H264 "Enable H.264 streaming" off \
IPV6 "Enable IPV6 support" on \
LIBEV "Enable libev support" off \
MAGNET "Enable magnet support" off \
@@ -54,7 +62,7 @@ CONF_FILES= lighttpd.conf modules.conf
CONFD_FILES= access_log.conf auth.conf cgi.conf cml.conf \
compress.conf debug.conf dirlisting.conf \
- evhost.conf expire.conf fastcgi.conf geoip.conf \
+ evhost.conf expire.conf fastcgi.conf \
magnet.conf mime.conf mysql_vhost.conf proxy.conf \
rrdtool.conf scgi.conf secdownload.conf \
simple_vhost.conf ssi.conf status.conf \
@@ -71,35 +79,14 @@ PLIST_SUB+= LOGROOT="${LIGHTTPD_LOGROOT}" \
MKDIR="${MKDIR}" \
CHOWN="${CHOWN}"
+.endif # !defined(_BUILDING_LIGHTTPD_MODULE)
+
.include <bsd.port.pre.mk>
+.if !defined(_BUILDING_LIGHTTPD_MODULE)
# Default REQUIRE to rc.d script
_REQUIRE= DAEMON
-.if defined(WITH_H264) || defined(WITH_GEOIP)
-PATCH_SITES+= ${MASTER_SITE_LOCAL}
-PATCH_SITE_SUBDIR+= mm
-USE_AUTOTOOLS+= autoconf:262 autoheader:262 aclocal:110 automake:110
-ACLOCAL_ARGS+= -I m4
-.endif
-
-.if defined(WITH_H264)
-PATCHFILES+= lighttpd-1.4.26_mod_h264_streaming-2.2.9.patch.gz
-PORTDOCS+= COPYING_H264
-#MANUAL_PACKAGE_BUILD= free for non-commercial use only
-PLIST_SUB+= H264=""
-.else
-PLIST_SUB+= H264="@comment "
-.endif
-
-.if defined(WITH_GEOIP)
-PATCHFILES+= lighttpd-1.4.26_mod_geoip.patch.gz
-LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
-PLIST_SUB+= GEOIP=""
-.else
-PLIST_SUB+= GEOIP="@comment "
-.endif
-
.if !defined(WITHOUT_OPENSSL)
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --with-openssl \
@@ -204,10 +191,6 @@ post-patch:
${WRKSRC}/doc/config/lighttpd.conf
@${ECHO} "\$$SERVER[\"socket\"] == \"0.0.0.0:80\" { }" >> \
${WRKSRC}/doc/config/lighttpd.conf
-.if defined(WITH_H264)
- @${CAT} ${WRKSRC}/COPYING_H264
- @sleep 10
-.endif
post-install:
@${MKDIR} ${PREFIX}/etc/lighttpd/conf.d ${PREFIX}/etc/lighttpd/vhosts.d
@@ -238,5 +221,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/${FILE}
. endfor
.endif
+.endif # !defined(_BUILDING_LIGHTTPD_MODULE)
.include <bsd.port.post.mk>
diff --git a/www/lighttpd/files/h264_streaming.conf b/www/lighttpd/files/h264_streaming.conf
new file mode 100644
index 000000000000..c5c695bae170
--- /dev/null
+++ b/www/lighttpd/files/h264_streaming.conf
@@ -0,0 +1,19 @@
+#######################################################################
+##
+## H.264 Streaming Module
+## ------------------------
+##
+server.modules += ( "mod_h264_streaming" )
+
+##
+## Configure streaming for .mp4 files
+##
+h264-streaming.extensions = ( ".mp4", ".f4v" )
+
+##
+## Bandwidth shaping
+##
+#h264-streaming.buffer-seconds = 10
+
+##
+#######################################################################
diff --git a/www/lighttpd/files/pkg-descr.mod_geoip b/www/lighttpd/files/pkg-descr.mod_geoip
new file mode 100644
index 000000000000..f3e8285e67cf
--- /dev/null
+++ b/www/lighttpd/files/pkg-descr.mod_geoip
@@ -0,0 +1,4 @@
+mod_geoip is an Apache module that looks up the country code for the
+IP address making the request without using reverse DNS.
+
+WWW: http://www.maxmind.com/app/mod_geoip
diff --git a/www/lighttpd/files/pkg-descr.mod_h264_streaming b/www/lighttpd/files/pkg-descr.mod_h264_streaming
new file mode 100644
index 000000000000..81239d78a9f6
--- /dev/null
+++ b/www/lighttpd/files/pkg-descr.mod_h264_streaming
@@ -0,0 +1,9 @@
+The H264 Streaming Module is a plugin for your existing Apache
+webserver. Its features are as follows:
+
+ * Timeshifting seek
+ * Virtual video clips
+ * Network efficiency
+ * Encoding
+
+WWW: http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Apache-Version2
diff --git a/www/lighttpd/files/pkg-plist.mod_geoip b/www/lighttpd/files/pkg-plist.mod_geoip
new file mode 100644
index 000000000000..511c275028b4
--- /dev/null
+++ b/www/lighttpd/files/pkg-plist.mod_geoip
@@ -0,0 +1,6 @@
+@unexec if cmp -s %D/etc/lighttpd/conf.d/geoip.conf %D/etc/lighttpd/conf.d/geoip.conf.sample; then rm -f %D/etc/lighttpd/conf.d/geoip.conf; fi
+etc/lighttpd/conf.d/geoip.conf.sample
+@exec [ -f %B/geoip.conf ] || cp %B/%f %B/geoip.conf
+lib/lighttpd/mod_geoip.a
+lib/lighttpd/mod_geoip.la
+lib/lighttpd/mod_geoip.so
diff --git a/www/lighttpd/files/pkg-plist.mod_h264_streaming b/www/lighttpd/files/pkg-plist.mod_h264_streaming
new file mode 100644
index 000000000000..0aeebaf65c53
--- /dev/null
+++ b/www/lighttpd/files/pkg-plist.mod_h264_streaming
@@ -0,0 +1,6 @@
+@unexec if cmp -s %D/etc/lighttpd/conf.d/h264_streaming.conf %D/etc/lighttpd/conf.d/h264_streaming.conf.sample; then rm -f %D/etc/lighttpd/conf.d/h264_streaming.conf; fi
+etc/lighttpd/conf.d/h264_streaming.conf.sample
+@exec [ -f %B/h264_streaming.conf ] || cp %B/%f %B/h264_streaming.conf
+lib/lighttpd/mod_h264_streaming.a
+lib/lighttpd/mod_h264_streaming.la
+lib/lighttpd/mod_h264_streaming.so