aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING5
-rw-r--r--www/redmine/Makefile11
-rw-r--r--www/redmine/files/patch-config-boot.rb23
-rw-r--r--www/redmine/pkg-plist1
4 files changed, 35 insertions, 5 deletions
diff --git a/UPDATING b/UPDATING
index ae053c96afc4..3d84f050af22 100644
--- a/UPDATING
+++ b/UPDATING
@@ -9,8 +9,9 @@ you update your ports collection, before attempting any port upgrades.
AFFECTS: users of www/redmine
AUTHOR: decke@FreeBSD.org
- Redmine explicitly requires i18n with version 0.4.2. You need to install
- that manually until a better solution is available.
+ If you use 3rd party plugins that are incompatible with i18n >= 0.5.0
+ (eg. variables in yml files as {{variable}}) then you need to
+ install an older i18n version manually.
# gem install -v=0.4.2 i18n
diff --git a/www/redmine/Makefile b/www/redmine/Makefile
index 7baa40b04ef4..c013d4e49cd2 100644
--- a/www/redmine/Makefile
+++ b/www/redmine/Makefile
@@ -7,6 +7,7 @@
PORTNAME= redmine
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,7 +15,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= decke@FreeBSD.org
COMMENT= A flexible project management web application
-RUN_DEPENDS= rackup:${PORTSDIR}/www/rubygem-rack
+RUN_DEPENDS= rackup:${PORTSDIR}/www/rubygem-rack \
+ rubygem-i18n>=0.4.2:${PORTSDIR}/devel/rubygem-i18n
USE_RUBY= yes
USE_RUBY_FEATURES= iconv
@@ -56,9 +58,14 @@ IGNORE= either Thin or Apache/Nginx WEB server option required. \
Please 'make config' again.
.endif
+post-patch:
+ # hack to fix template syntax for rubygem-i18n >= 0.5.0
+ ${FIND} ${WRKSRC} -name "*.yml" -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|{{|%{|g ; s|}}|}|g'
+
do-install:
${MKDIR} ${WWWDIR}
- (cd ${WRKSRC}/ && ${COPYTREE_SHARE} "*" ${WWWDIR} "! -name *.orig")
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} "*" ${WWWDIR} "! -name *.orig ! -name *.bak")
${MKDIR} ${WWWDIR}/public/plugin_assets
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
diff --git a/www/redmine/files/patch-config-boot.rb b/www/redmine/files/patch-config-boot.rb
new file mode 100644
index 000000000000..5c9414ea0226
--- /dev/null
+++ b/www/redmine/files/patch-config-boot.rb
@@ -0,0 +1,23 @@
+--- config/boot.rb.orig 2010-12-23 11:22:21.000000000 +0100
++++ config/boot.rb 2010-12-23 14:14:20.000000000 +0100
+@@ -110,13 +110,13 @@
+ # Loads i18n 0.4.2 before Rails loads any more recent gem
+ # 0.5.0 is not compatible with the old interpolation syntax
+ # Plugins will have to migrate to the new syntax for 1.2.0
+-require 'rubygems'
+-begin
+- gem 'i18n', '0.4.2'
+-rescue Gem::LoadError => load_error
+- $stderr.puts %(Missing the i18n 0.4.2 gem. Please `gem install -v=0.4.2 i18n`)
+- exit 1
+-end
++#require 'rubygems'
++#begin
++# gem 'i18n', '0.4.2'
++#rescue Gem::LoadError => load_error
++# $stderr.puts %(Missing the i18n 0.4.2 gem. Please `gem install -v=0.4.2 i18n`)
++# exit 1
++#end
+
+ # All that for this:
+ Rails.boot!
diff --git a/www/redmine/pkg-plist b/www/redmine/pkg-plist
index 8cd8013077a1..803243678728 100644
--- a/www/redmine/pkg-plist
+++ b/www/redmine/pkg-plist
@@ -1780,7 +1780,6 @@
%%WWWDIR%%/vendor/rails/actionmailer/test/fixtures/test_mailer/custom_templating_extension.text.html.haml
%%WWWDIR%%/vendor/rails/actionmailer/test/fixtures/test_mailer/custom_templating_extension.text.plain.haml
%%WWWDIR%%/vendor/rails/actionmailer/test/fixtures/test_mailer/implicitly_multipart_example.ignored.erb
-%%WWWDIR%%/vendor/rails/actionmailer/test/fixtures/test_mailer/implicitly_multipart_example.rhtml.bak
%%WWWDIR%%/vendor/rails/actionmailer/test/fixtures/test_mailer/implicitly_multipart_example.text.html.erb
%%WWWDIR%%/vendor/rails/actionmailer/test/fixtures/test_mailer/implicitly_multipart_example.text.html.erb~
%%WWWDIR%%/vendor/rails/actionmailer/test/fixtures/test_mailer/implicitly_multipart_example.text.plain.erb