aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/opencpn/Makefile2
-rw-r--r--audio/mixxx/Makefile2
-rw-r--r--audio/musicpd/Makefile1
-rw-r--r--benchmarks/fio/Makefile2
-rw-r--r--biology/bwa/Makefile2
-rw-r--r--cad/kicad-devel/Makefile3
-rw-r--r--chinese/pyzy/Makefile3
-rw-r--r--comms/linrad/Makefile2
-rw-r--r--devel/avr-gcc-devel/Makefile3
-rw-r--r--devel/avr-gcc/Makefile3
-rw-r--r--devel/gcc-msp430-ti-toolchain/Makefile3
-rw-r--r--devel/isa-l/Makefile2
-rw-r--r--devel/liblas/Makefile3
-rw-r--r--devel/pinba_engine/Makefile2
-rw-r--r--emulators/hatari/Makefile3
-rw-r--r--emulators/unicorn/Makefile2
-rw-r--r--games/0ad/Makefile3
-rw-r--r--games/blobby/Makefile2
-rw-r--r--games/diaspora/Makefile2
-rw-r--r--games/openspades/Makefile2
-rw-r--r--games/vegastrike/Makefile2
-rw-r--r--graphics/agave/Makefile2
-rw-r--r--graphics/code-eli/Makefile2
-rw-r--r--graphics/s10sh/Makefile1
-rw-r--r--lang/sdcc-devel/Makefile2
-rw-r--r--lang/sdcc/Makefile2
-rw-r--r--math/amath/Makefile3
-rw-r--r--math/asir2000/Makefile2
-rw-r--r--math/stp/Makefile2
-rw-r--r--multimedia/aegisub/Makefile2
-rw-r--r--multimedia/handbrake/Makefile1
-rw-r--r--net-im/ring-daemon/Makefile2
-rw-r--r--net/chrony/Makefile2
-rw-r--r--security/botan110/Makefile2
-rw-r--r--textproc/kenlm/Makefile5
-rw-r--r--textproc/randlm/Makefile6
-rw-r--r--www/ufdbguard/Makefile2
37 files changed, 82 insertions, 5 deletions
diff --git a/astro/opencpn/Makefile b/astro/opencpn/Makefile
index 84edf0f3148d..48b5aca177e1 100644
--- a/astro/opencpn/Makefile
+++ b/astro/opencpn/Makefile
@@ -32,6 +32,8 @@ CMAKE_ARGS= -DBUNDLE_DOCS=ON -DBUNDLE_GSHHS=CRUDE -DBUNDLE_TCDATA=ON
LDFLAGS+= -Wl,-E # plugins
LDFLAGS+= -Wl,--as-needed # ICE, SM, Xext
+BROKEN_aarch64= Fails to compile: use of undeclared identifier rand
+
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},' \
${WRKSRC}/src/mygdal/cpl_csv.cpp \
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index f8151dbbe1a1..4ec9698889af 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -25,6 +25,8 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+BROKEN_aarch64= Fails to compile: Exception("invalid machine type")
+
USES= scons iconv
USE_QT4= corelib gui network opengl script sql svg xml \
linguisttools_build moc_build qmake_build rcc_build uic_build
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index e8f97de8839b..599307e3f9c5 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -27,6 +27,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/sidplay/builders
#Workaround (transient?) link error with libwrap
CONFIGURE_ARGS+=--disable-libwrap
+BROKEN_armv6= Fails to compile: undefined reference to request_init
BROKEN_powerpc64= Does not build on powerpc64
PORTDOCS= AUTHORS README.md COPYING NEWS
diff --git a/benchmarks/fio/Makefile b/benchmarks/fio/Makefile
index be169eaf9faf..63ed325d0fdf 100644
--- a/benchmarks/fio/Makefile
+++ b/benchmarks/fio/Makefile
@@ -18,6 +18,8 @@ GNUPLOT_DESC= Support for plotting graphs
GNUPLOT_BUILD_DEPENDS= ${LOCALBASE}/bin/gnuplot:math/gnuplot
+BROKEN_aarch64= Fails to compile: error: sys/auxv.h file not found
+BROKEN_armv6= Fails to compile: error: use of undeclared identifier nop
BROKEN_powerpc64= Does not build on powerpc64
do-install:
diff --git a/biology/bwa/Makefile b/biology/bwa/Makefile
index 5afe21194947..a20f1209ac52 100644
--- a/biology/bwa/Makefile
+++ b/biology/bwa/Makefile
@@ -11,6 +11,8 @@ COMMENT= Burrows-Wheeler sequence aligner
LICENSE= GPLv3
+BROKEN_aarch64= fails to compile: error: invalid conversion between vector type and integer type
+
USES= perl5 shebangfix tar:bzip2
SHEBANG_FILES= qualfa2fq.pl xa2multi.pl
USE_PERL5= run
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index 4bdbb1a746a8..a826081f6ecb 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -16,7 +16,6 @@ COMMENT= Schematic and PCB editing software
LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:math/glm
-
LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libcurl.so:ftp/curl
@@ -33,6 +32,8 @@ WX_COMPS= wx
WX_UNICODE= yes
USE_GNOME= atk cairo # Required by libwx_gtk2_aui-2.8.so
+BROKEN_aarch64= Fails to compile: use of undeclared identifier builtin_ia32_emms
+
OPTIONS_DEFINE= DOCS
PLIST_SUB= OPSYS=${OPSYS} \
diff --git a/chinese/pyzy/Makefile b/chinese/pyzy/Makefile
index 9de6098cf5c4..bc1bcb6a318d 100644
--- a/chinese/pyzy/Makefile
+++ b/chinese/pyzy/Makefile
@@ -21,6 +21,9 @@ SHEBANG_FILES= data/db/android/create_db.py
USE_GNOME= glib20
USE_LDCONFIG= yes
+BROKEN_aarch64= Fails to compile: error: constant expression evaluates to -1
+BROKEN_armv6= Fails to compile: error: constant expression evaluates to -1
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking --disable-boost
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index d8c2063de89e..ccb2f4a29ca4 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -32,6 +32,8 @@ LINRAD_DOCFILES= z_APM.txt z_BUFFERS.txt z_CALIBRATE.txt \
z_PARALLEL_PORT.txt z_SETTINGS.txt \
z_USERS_EXTRA.txt z_USERS_HWARE.txt
+BROKEN_aarch64= Fails to compile: implicit declaration of function outb
+BROKEN_armv6= Fails to configure: can not find /nxb-bin/usr/bin/cc
BROKEN_sparc64= Fails to compile: implicit declaration of function outb
.include <bsd.port.pre.mk>
diff --git a/devel/avr-gcc-devel/Makefile b/devel/avr-gcc-devel/Makefile
index 88c133f86622..0a3196d22bd2 100644
--- a/devel/avr-gcc-devel/Makefile
+++ b/devel/avr-gcc-devel/Makefile
@@ -36,6 +36,9 @@ USE_PERL5= build
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
+BROKEN_aarch64= Fails to package: cannot find manpages
+BROKEN_mips64= Fails to configure: cannot compute suffix of object files
+
.include <bsd.port.pre.mk>
.if (${ARCH} == "amd64")
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index bc836ff93a68..7fbc6e8cd7eb 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -47,6 +47,9 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
+BROKEN_aarch64= Fails to package: cannot find manpages
+BROKEN_mips64= Fails to configure: cannot compute suffix of object files
+
.include <bsd.port.pre.mk>
.if (${ARCH} == "amd64")
diff --git a/devel/gcc-msp430-ti-toolchain/Makefile b/devel/gcc-msp430-ti-toolchain/Makefile
index 6663ed5e71fb..147ff2ce67d7 100644
--- a/devel/gcc-msp430-ti-toolchain/Makefile
+++ b/devel/gcc-msp430-ti-toolchain/Makefile
@@ -24,6 +24,7 @@ EXTRACT_ONLY= gcc-${GCC_VERSION}.tar.bz2 \
newlib-${NEWLIB_VERSION}.tar.gz \
msp430-gcc-${PATCHSET_VERSION}_source-patches.tar.bz2 \
msp430-gcc-support-files-${SUPPORT_VERSION}.zip
+
MAINTAINER= lev@FreeBSD.org
COMMENT= Complete gcc-based toolcahin for TI MSP430 uC
@@ -35,6 +36,8 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libmpc.so:math/mpc \
libisl.so:devel/isl
+BROKEN_aarch64= fails to compile: c++: error: unsupported option -print-multi-os-directory
+
USES= bison compiler cpe gmake iconv libtool makeinfo ncurses \
tar:bzip2
USE_CSTD= gnu89
diff --git a/devel/isa-l/Makefile b/devel/isa-l/Makefile
index 4953cac26c15..a75210a94b72 100644
--- a/devel/isa-l/Makefile
+++ b/devel/isa-l/Makefile
@@ -23,4 +23,6 @@ USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+BROKEN_aarch64= Fails to compile: invalid conversion between vector type and integer type
+
.include <bsd.port.mk>
diff --git a/devel/liblas/Makefile b/devel/liblas/Makefile
index 7e0618969f7f..29aab747637b 100644
--- a/devel/liblas/Makefile
+++ b/devel/liblas/Makefile
@@ -26,4 +26,7 @@ USE_GITHUB= yes
GH_ACCOUNT= libLAS
GH_PROJECT= ${GH_ACCOUNT}
+BROKEN_aarch64= Fails to compile: file liblas/detail/endian.hpp needs to be set up for your CPU type
+BROKEN_armv6= Fails to compile: file liblas/detail/endian.hpp needs to be set up for your CPU type
+
.include <bsd.port.mk>
diff --git a/devel/pinba_engine/Makefile b/devel/pinba_engine/Makefile
index 16e35b635d7e..d7eba362d831 100644
--- a/devel/pinba_engine/Makefile
+++ b/devel/pinba_engine/Makefile
@@ -42,6 +42,8 @@ CFLAGS+= -I${LOCALBASE}/include/mysql
SUB_FILES= pkg-message
PORTDOCS= NEWS TODO README
+BROKEN_aarch64= Fails to configure: failed to find required header file include/mysql_version.h
+
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
@${INSTALL} ${WRKSRC}/default_tables.sql ${STAGEDIR}${DATADIR}
diff --git a/emulators/hatari/Makefile b/emulators/hatari/Makefile
index 033b27c639b8..41e3201c0fe4 100644
--- a/emulators/hatari/Makefile
+++ b/emulators/hatari/Makefile
@@ -27,6 +27,9 @@ CMAKE_ARGS= -DETCDIR:PATH="${PREFIX}/etc" \
-DREADLINE_FOUND:BOOL=ON
INSTALLS_ICONS= yes
+BROKEN_aarch64= Fails to configure: error: unrecognized CPU type
+BROKEN_armv6= Fails to configure: CMake Error: Generator: execution of make failed
+
OPTIONS_DEFINE= DEBUG DOCS SDL2 WINUAE
DEBUG_CFLAGS_OFF= -DNDEBUG
diff --git a/emulators/unicorn/Makefile b/emulators/unicorn/Makefile
index 697c01dcb781..ea59c10ee56c 100644
--- a/emulators/unicorn/Makefile
+++ b/emulators/unicorn/Makefile
@@ -24,4 +24,6 @@ MAKE_ENV= INSTALL_LIB="${INSTALL_LIB}" \
TEST_TARGET= test
TEST_WRKSRC= ${WRKSRC}/tests/unit
+BROKEN_aarch64= fails to compile: error: use of undeclared identifier tcg_op_defs
+
.include <bsd.port.mk>
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index 8a8b17d84eba..aab18801262c 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -41,6 +41,9 @@ USE_WX= 2.8+
WX_COMPS= wx:lib
MAKE_ENV+= JOBS=${_MAKE_JOBS}
+BROKEN_aarch64= Fails to compile: no member named verifyHeapAccessDisassembly
+BROKEN_armv6= Fails to link: fatal error: conftest: Unknown error: -1
+
PORTDATA= *
.include <bsd.port.pre.mk>
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index 98c26bf8087c..87a41a6ebd65 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -29,6 +29,8 @@ WRKSRC= ${WRKDIR}/blobby-1.0rc3
PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README TODO
+BROKEN_aarch64= Fails to compile: I can't tell what endian-ness to use for your architecture
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/games/diaspora/Makefile b/games/diaspora/Makefile
index d71d2ce8a593..bc7de66fe264 100644
--- a/games/diaspora/Makefile
+++ b/games/diaspora/Makefile
@@ -66,6 +66,8 @@ WXLAUNCHER_VARS= PORTDATA+="resources *.ini *.png *.bmp"
POST_PLIST+= build-plist-empty
+BROKEN_aarch64= Fails to compile: cast from pointer to smaller type loses information
+
post-extract: .SILENT
.for v in 1.1 1.1.1
(cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
diff --git a/games/openspades/Makefile b/games/openspades/Makefile
index 9f807799f233..5b603b0826e3 100644
--- a/games/openspades/Makefile
+++ b/games/openspades/Makefile
@@ -35,6 +35,8 @@ PORTDATA= *
OPTIONS_DEFINE= DOCS
+BROKEN_aarch64= Fails to compile: unknown register name %xmm0 in asm
+
post-extract:
@${MKDIR} ${WRKSRC}/Resources/DevPak
@${MV} ${WRKDIR}/*.pak ${WRKSRC}/Resources/DevPak/
diff --git a/games/vegastrike/Makefile b/games/vegastrike/Makefile
index 5acdf4ba7ae1..a15d4ee85b48 100644
--- a/games/vegastrike/Makefile
+++ b/games/vegastrike/Makefile
@@ -48,6 +48,8 @@ MESHER_PLIST_FILES= bin/mesher
MESHER_LIB_DEPENDS= libOgreMain.so:graphics/ogre3d
MESHER_CONFIGURE_ENABLE= ogre
+BROKEN_aarch64= Fails to compile: POSH cannot determine target CPU
+
post-patch:
@${REINPLACE_CMD} -E 's,/usr/(local|X11R6),${LOCALBASE},' \
${WRKSRC}/configure
diff --git a/graphics/agave/Makefile b/graphics/agave/Makefile
index d5ca65ee66bb..cb8820c4f3b2 100644
--- a/graphics/agave/Makefile
+++ b/graphics/agave/Makefile
@@ -34,6 +34,8 @@ OPTIONS_DEFINE= GNOME
GNOME_USE= gnome=libgnomeui
GNOME_CONFIGURE_ENABLE= gnome
+BROKEN_aarch64= Fails to compile: variable has incomplete type union compat_IEEEl2bits
+
post-patch:
@${REINPLACE_CMD} -e \
's| _GCS_| __GCS_|' ${WRKSRC}/src/gcs-conf.h
diff --git a/graphics/code-eli/Makefile b/graphics/code-eli/Makefile
index 93ff1b0624fe..bf45528087f1 100644
--- a/graphics/code-eli/Makefile
+++ b/graphics/code-eli/Makefile
@@ -33,6 +33,8 @@ DOXYGEN_BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:devel/doxygen
DOXYGEN_ALL_TARGET= doc
DOXYGEN_PORTDOCS= html latex
+BROKEN_armv6= Fails to compile: undefined reference to cbrtl
+
post-patch-EXAMPLES-off:
${REINPLACE_CMD} \
-e 's/add_subdirectory(example)//g' \
diff --git a/graphics/s10sh/Makefile b/graphics/s10sh/Makefile
index fa78ce9146f5..e58027774115 100644
--- a/graphics/s10sh/Makefile
+++ b/graphics/s10sh/Makefile
@@ -15,6 +15,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_aarch64= Fails to build: error: can not find the byte order for this architecture, fix bytesex.h
+BROKEN_armv6= Fails to build: error: can not find the byte order for this architecture, fix bytesex.h
USES= ncurses readline
diff --git a/lang/sdcc-devel/Makefile b/lang/sdcc-devel/Makefile
index 86bc60bed271..0e7ebe63a8a2 100644
--- a/lang/sdcc-devel/Makefile
+++ b/lang/sdcc-devel/Makefile
@@ -55,6 +55,8 @@ Z80_CONFIGURE_OFF= --disable-z80 --disable-z80-port \
--disable-r2k-port --disable-r3ka-port \
--disable-tlcs90-port
+BROKEN_aarch64= Fails to configure: BFD does not support target aarch64-portbld-freebsd11.0
+
.include <bsd.port.options.mk>
.if ${ARCH} == "amd64"
diff --git a/lang/sdcc/Makefile b/lang/sdcc/Makefile
index cb3b7f225492..68800ae9118e 100644
--- a/lang/sdcc/Makefile
+++ b/lang/sdcc/Makefile
@@ -52,6 +52,8 @@ Z80_CONFIGURE_OFF= --disable-z80 --disable-z80-port \
--disable-r2k-port --disable-r3ka-port \
--disable-tlcs90-port
+BROKEN_aarch64= Fails to configure: BFD does not support target aarch64-portbld-freebsd11.0
+
.include <bsd.port.options.mk>
.if ${ARCH} == "amd64"
diff --git a/math/amath/Makefile b/math/amath/Makefile
index 38ef590abd9a..71e06704dd53 100644
--- a/math/amath/Makefile
+++ b/math/amath/Makefile
@@ -23,4 +23,7 @@ do-install:
do-test:
${WRKSRC}/${PORTNAME} test
+BROKEN_aarch64= Fails to compile: must define endianness
+BROKEN_armv6= Fails to configure: what cpu is this ?!
+
.include <bsd.port.mk>
diff --git a/math/asir2000/Makefile b/math/asir2000/Makefile
index df5febf13122..8ed76a77eb8d 100644
--- a/math/asir2000/Makefile
+++ b/math/asir2000/Makefile
@@ -35,6 +35,8 @@ ASIR_DOC= asirdoc-${ASIR_DOC_VERSION}${EXTRACT_SUFX}
GC_SRC= gc-${GC_VERSION}.tar.gz
WRKSRC= ${WRKDIR}/asir2000
+BROKEN_aarch64= Fails to compile: the collector has not been ported to this machine/OS combination
+
LIB_DATA= alpi bfct bgk const cyclic defs.h dfff dmul dmul102 fctrdata \
fctrtest fff glib gr ifplot katsura launch mat nf num primdec \
primdec_lex primdec_mod ratint robot solve sp sturm sym weight xm
diff --git a/math/stp/Makefile b/math/stp/Makefile
index 1cd015245801..b012dd4f1fb4 100644
--- a/math/stp/Makefile
+++ b/math/stp/Makefile
@@ -19,4 +19,6 @@ USES= bison:build cmake perl5 tar:xz
USE_PERL5= build
CMAKE_ARGS= -DFL_LIBRARY=/usr/lib/libfl.a
+BROKEN_aarch64= Fails to compile: undefined reference to sbrk
+
.include <bsd.port.mk>
diff --git a/multimedia/aegisub/Makefile b/multimedia/aegisub/Makefile
index 5149d355292c..b8b604e322ec 100644
--- a/multimedia/aegisub/Makefile
+++ b/multimedia/aegisub/Makefile
@@ -64,6 +64,8 @@ PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_OFF=\
--without-libpulse
+BROKEN_aarch64= Fails to compile: no support for this architecture (yet)
+
# src/audio_display.o: undefined reference to symbol '__atomic_load_8@@LIBATOMIC_1.0'
.if empty(CFLAGS:M-march=*)
CFLAGS+= ${CFLAGS_${ARCH}_${CHOSEN_COMPILER_TYPE}}
diff --git a/multimedia/handbrake/Makefile b/multimedia/handbrake/Makefile
index 69b1d2a542b0..c7e8ae36a085 100644
--- a/multimedia/handbrake/Makefile
+++ b/multimedia/handbrake/Makefile
@@ -46,6 +46,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libmp3lame.so:audio/lame
BROKEN_aarch64= Fails to build: invokes x86 asm
+BROKEN_armv6= Fails to build: invokes x86 asm
.if !defined(PACKAGE_BUILDING)
# DVDCSS version hardcoded in contrib/libdvdread/libdvdread-5.0.0-6-gcb1ae87/src/dvd_input.c (dlopen'ed)
diff --git a/net-im/ring-daemon/Makefile b/net-im/ring-daemon/Makefile
index 96864f20ee17..b5d48dc7df1b 100644
--- a/net-im/ring-daemon/Makefile
+++ b/net-im/ring-daemon/Makefile
@@ -57,6 +57,8 @@ DBUS_LIB_DEPENDS= \
libdbus-c++-1.so:devel/dbus-c++
OPTIONS_SUB= yes
+BROKEN_aarch64= Fails to configure: machine arm64-portbld not recognized
+
.include <bsd.port.pre.mk>
post-extract:
diff --git a/net/chrony/Makefile b/net/chrony/Makefile
index 1fc9a25758aa..d09e01785371 100644
--- a/net/chrony/Makefile
+++ b/net/chrony/Makefile
@@ -41,6 +41,8 @@ OPTIONS_DEFINE= IPV6
IPV6_CATEGORIES= ipv6
IPV6_CONFIGURE_OFF= --disable-ipv6
+BROKEN_aarch64= Fails to compile: invalid operands to binary expression (double and double)
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/chronyc
${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/chronyd
diff --git a/security/botan110/Makefile b/security/botan110/Makefile
index c602939bbe82..050d31529a23 100644
--- a/security/botan110/Makefile
+++ b/security/botan110/Makefile
@@ -31,6 +31,8 @@ PLIST_FILES= bin/botan-config-1.10 lib/libbotan-1.10.a lib/libbotan-1.10.so lib/
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= *
+BROKEN_aarch64= Fails to configure: unknown or unidentifiable processor arm64
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
diff --git a/textproc/kenlm/Makefile b/textproc/kenlm/Makefile
index cfbb4b3fa43f..c5f3d740e9d3 100644
--- a/textproc/kenlm/Makefile
+++ b/textproc/kenlm/Makefile
@@ -11,8 +11,6 @@ DISTNAME= ${PORTNAME}
MAINTAINER= demon@FreeBSD.org
COMMENT= KenLM Language Model Toolkit
-BROKEN_powerpc64= Does not build
-
BUILD_DEPENDS= bjam:devel/boost-jam \
bash:shells/bash
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
@@ -22,6 +20,9 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV+= BOOST_BUILD_PATH=${WRKSRC}/jam-files/boost-build
+BROKEN_aarch64= Fails to compile: target architecture was not detected as supported by Double-Conversion
+BROKEN_powerpc64= Does not build
+
do-build:
(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${LOCALBASE}/bin/bjam --toolset=${CHOSEN_COMPILER_TYPE} --with-boost=${LOCALBASE} ${_MAKE_JOBS})
diff --git a/textproc/randlm/Makefile b/textproc/randlm/Makefile
index 7683c42127f0..0c21e0f4e6c0 100644
--- a/textproc/randlm/Makefile
+++ b/textproc/randlm/Makefile
@@ -10,8 +10,6 @@ MASTER_SITES= SF/${PORTNAME}
MAINTAINER= demon@FreeBSD.org
COMMENT= A toolkit for building randomized language models
-BROKEN_powerpc64= Does not build
-
BUILD_DEPENDS= ${LOCALBASE}/include/google/sparse_hash_map:devel/sparsehash
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/include/google/sparse_hash_map:devel/sparsehash
@@ -26,6 +24,10 @@ CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
+BROKEN_aarch64= Fails to compile: invalid output constraint =a in asm
+BROKEN_armv6= Fails to compile: invalid output constraint =a in asm
+BROKEN_powerpc64= Does not build
+
post-patch:
cd ${WRKSRC}/hadoop && ${MV} strings.cpp strings.cc && ${MV} strings.h s.h
${REINPLACE_CMD} -e s#strings.h#s.h# ${WRKSRC}/hadoop/r_compute_ngram_counts.cpp ${WRKSRC}/hadoop/m_compute_ngram_counts_batch.cpp
diff --git a/www/ufdbguard/Makefile b/www/ufdbguard/Makefile
index edd8023239f0..d8853126b6ec 100644
--- a/www/ufdbguard/Makefile
+++ b/www/ufdbguard/Makefile
@@ -12,6 +12,8 @@ COMMENT= URL filter for the Squid web proxy
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_aarch64= fails to compile: error: regparm is not valid on this platform
+
USES= perl5 shebangfix ssl
SHEBANG_FILES= samples/URLblocked.cgi
GNU_CONFIGURE= yes