aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/sudo/Makefile9
-rw-r--r--security/sudo/distinfo4
-rw-r--r--security/sudo/files/patch-plugins__sudoers__Makefile.in14
-rw-r--r--security/sudo/pkg-install13
4 files changed, 7 insertions, 33 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 7cbc297681f9..aaca28eacf39 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sudo
PORTVERSION= 1.8.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
http://www.signal42.com/mirrors/sudo_ftp/ \
@@ -43,7 +43,7 @@ MASTER_SITES= http://www.sudo.ws/sudo/dist/ \
ftp://sunsite.icm.edu.pl/packages/sudo/ \
ftp://mirror.cdmon.com/pub/sudo/ \
ftp://ftp.twaren.net/Unix/Security/Sudo/
-DISTNAME= ${PORTNAME}-1.8.1
+DISTNAME= ${PORTNAME}-1.8.1p1
MAINTAINER= wxs@FreeBSD.org
COMMENT= Allow others to run commands as root
@@ -119,11 +119,6 @@ post-patch:
@${REINPLACE_CMD} -e 's/$$(DESTDIR)$$(sudoersdir) $$(DESTDIR)$$(docdir)/$$(DESTDIR)$$(sudoersdir)/' ${WRKSRC}/plugins/sudoers/Makefile.in
.endif
-# XXX: Because I botched the upgrade to 1.8.1, this is necessary.
-# Eventually, once 1.8.1 is ancient enough, this can be removed.
-pre-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
post-install:
${INSTALL_DATA} ${FILESDIR}/pam.conf ${PREFIX}/etc/pam.d/sudo.default
if [ ! -f ${PREFIX}/etc/pam.d/sudo ]; then \
diff --git a/security/sudo/distinfo b/security/sudo/distinfo
index 50d2017bf313..df6d47b9fbfd 100644
--- a/security/sudo/distinfo
+++ b/security/sudo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sudo-1.8.1.tar.gz) = 87cfb9c06e69fc16bb8246554804452130a1202b046e069b0da3e3b3a633f0cb
-SIZE (sudo-1.8.1.tar.gz) = 1238495
+SHA256 (sudo-1.8.1p1.tar.gz) = c6bd76bda54aab022b758e0f321f008403cdaf73621a7f316c22c44e28133e13
+SIZE (sudo-1.8.1p1.tar.gz) = 1239231
diff --git a/security/sudo/files/patch-plugins__sudoers__Makefile.in b/security/sudo/files/patch-plugins__sudoers__Makefile.in
index 56477360a222..db20d5b80870 100644
--- a/security/sudo/files/patch-plugins__sudoers__Makefile.in
+++ b/security/sudo/files/patch-plugins__sudoers__Makefile.in
@@ -1,14 +1,6 @@
---- ./plugins/sudoers/Makefile.in.orig 2011-04-06 10:59:31.000000000 -0400
-+++ ./plugins/sudoers/Makefile.in 2011-04-11 12:47:45.435271822 -0400
-@@ -350,6 +350,7 @@
- install-includes:
-
- install-doc:
-+ @LDAP@$(SHELL) $(top_srcdir)/mkinstalldirs $(DESTDIR)$(docdir)
- @LDAP@$(INSTALL) -O $(install_uid) -G $(install_gid) -M 0555 $(srcdir)/sudoers2ldif $(DESTDIR)$(docdir)
-
- install-plugin: sudoers.la install-dirs
-@@ -358,9 +359,8 @@
+--- ./plugins/sudoers/Makefile.in.orig 2011-04-11 08:28:33.000000000 -0400
++++ ./plugins/sudoers/Makefile.in 2011-04-17 09:38:29.349385961 -0400
+@@ -358,9 +358,8 @@
install-sudoers: install-dirs
$(INSTALL) -d -O $(sudoers_uid) -G $(sudoers_gid) -M 0750 \
$(DESTDIR)$(sudoersdir)/sudoers.d
diff --git a/security/sudo/pkg-install b/security/sudo/pkg-install
deleted file mode 100644
index 8dd08a559ab3..000000000000
--- a/security/sudo/pkg-install
+++ /dev/null
@@ -1,13 +0,0 @@
-#! /bin/sh
-#
-# $FreeBSD$
-
-PATH=/bin:/usr/bin:/usr/sbin
-
-case $2 in
-
-PRE-INSTALL)
- install -d -o 0 -g 0 -m 0750 ${PKG_PREFIX}/etc/sudoers.d
- ;;
-
-esac