aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING18
-rw-r--r--www/owncloud/Makefile10
2 files changed, 24 insertions, 4 deletions
diff --git a/UPDATING b/UPDATING
index b188122430ca..f1c8d00f8c5c 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,24 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20121202:
+ AFFECTS: Users of www/owncloud
+ AUTHOR: crees@FreeBSD.org
+
+ www/owncloud includes the entire WWWDIR directory structure in pkg-plist.
+
+ This means that if you upgrade it, your config files are added to pkg-plist,
+ and are then removed on the next deinstall.
+
+ This issue has been fixed, but you must back up your install of owncloud and
+ reinstall to avoid data loss;
+
+ # cd /usr/ports/www/owncloud
+ # tar cfC /tmp/owncloud.tar `make -VWWWDIR` .
+ # make deinstall
+ # tar xfC /tmp/owncloud.tar `make -VWWWDIR`
+ # make install clean && rm /tmp/owncloud.tar
+
20121201:
AFFECTS: Users of www/typo3
AUTHOR: Helmut Ritter <freebsd-ports@charlieroot.de>
diff --git a/www/owncloud/Makefile b/www/owncloud/Makefile
index 5cb4b7031e2e..6ab5c96070c9 100644
--- a/www/owncloud/Makefile
+++ b/www/owncloud/Makefile
@@ -30,9 +30,11 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
- @${FIND} -s -d ${WWWDIR} -type f -print | \
- ${SED} -e "s#${PREFIX}/##g" >> ${TMPPLIST}
- @${FIND} -s -d ${WWWDIR} -type d -print | \
- ${SED} -E -e "s#${PREFIX}/#@dirrm #g" >> ${TMPPLIST}
+ @cd ${WRKSRC} && \
+ ${FIND} -s -d . -type f -print | \
+ ${SED} -e "s#^\.#${WWWDIR_REL}#" >> ${TMPPLIST}
+ @cd ${WRKSRC} && \
+ ${FIND} -s -d . -type d -print | \
+ ${SED} -e "s#^\.#@dirrm ${WWWDIR_REL}#" >> ${TMPPLIST}
.include <bsd.port.mk>