aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Email-Sender-Transport-SQLite/Makefile26
-rw-r--r--mail/p5-Email-Sender-Transport-SQLite/distinfo3
-rw-r--r--mail/p5-Email-Sender-Transport-SQLite/pkg-descr6
-rw-r--r--mail/p5-Email-Sender-Transport-SQLite/pkg-plist9
5 files changed, 45 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 1387f4bd1be1..9ef5eeab6e3b 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -351,6 +351,7 @@
SUBDIR += p5-Email-Reply
SUBDIR += p5-Email-Send
SUBDIR += p5-Email-Sender
+ SUBDIR += p5-Email-Sender-Transport-SQLite
SUBDIR += p5-Email-Simple
SUBDIR += p5-Email-Stuff
SUBDIR += p5-Email-Valid
diff --git a/mail/p5-Email-Sender-Transport-SQLite/Makefile b/mail/p5-Email-Sender-Transport-SQLite/Makefile
new file mode 100644
index 000000000000..967e849e3d12
--- /dev/null
+++ b/mail/p5-Email-Sender-Transport-SQLite/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Email-Sender-Transport-SQLite
+# Date created: 11 Oct 2010
+# Whom: Bill Brinzer <bill.brinzer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-Sender-Transport-SQLite
+PORTVERSION= 0.091660
+CATEGORIES= mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bill.brinzer@gmail.com
+COMMENT= Deliver mail to an SQLite db for testing
+
+RUN_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Email-Sender>=0.091660:${PORTSDIR}/mail/p5-Email-Sender
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.8+
+
+MAN3= Email::Sender::Transport::SQLite.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-Sender-Transport-SQLite/distinfo b/mail/p5-Email-Sender-Transport-SQLite/distinfo
new file mode 100644
index 000000000000..958bd14b6793
--- /dev/null
+++ b/mail/p5-Email-Sender-Transport-SQLite/distinfo
@@ -0,0 +1,3 @@
+MD5 (Email-Sender-Transport-SQLite-0.091660.tar.gz) = 891d2e59993f1127da9ad8f4bf7ea8b7
+SHA256 (Email-Sender-Transport-SQLite-0.091660.tar.gz) = 8b4487c1076921601a9afbb8de445ebba6803bb9ac612ac06dc08a50c1365c1d
+SIZE (Email-Sender-Transport-SQLite-0.091660.tar.gz) = 9299
diff --git a/mail/p5-Email-Sender-Transport-SQLite/pkg-descr b/mail/p5-Email-Sender-Transport-SQLite/pkg-descr
new file mode 100644
index 000000000000..366602d2a4ea
--- /dev/null
+++ b/mail/p5-Email-Sender-Transport-SQLite/pkg-descr
@@ -0,0 +1,6 @@
+This transport makes deliveries to an SQLite database, creating it if needed.
+The SQLite transport is intended for testing programs that fork or that
+otherwise can't use the Test transport. It is not meant for robust, long-term
+storage of mail.
+
+WWW: http://search.cpan.org/dist/Email-Sender-Transport-SQLite/
diff --git a/mail/p5-Email-Sender-Transport-SQLite/pkg-plist b/mail/p5-Email-Sender-Transport-SQLite/pkg-plist
new file mode 100644
index 000000000000..8338550779b8
--- /dev/null
+++ b/mail/p5-Email-Sender-Transport-SQLite/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Email/Sender/Transport/SQLite.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Sender/Transport/SQLite/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Sender/Transport/SQLite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Sender/Transport
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Sender
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email
+@dirrmtry %%SITE_PERL%%/Email/Sender/Transport
+@dirrmtry %%SITE_PERL%%/Email/Sender
+@dirrmtry %%SITE_PERL%%/Email