aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-FillInForm/Makefile26
-rw-r--r--www/p5-HTML-FillInForm/distinfo1
-rw-r--r--www/p5-HTML-FillInForm/pkg-comment1
-rw-r--r--www/p5-HTML-FillInForm/pkg-descr12
-rw-r--r--www/p5-HTML-FillInForm/pkg-plist5
6 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 903010f0399e..28bf6a23d8cb 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -170,6 +170,7 @@
SUBDIR += p5-HTML
SUBDIR += p5-HTML-Clean
SUBDIR += p5-HTML-Embperl
+ SUBDIR += p5-HTML-FillInForm
SUBDIR += p5-HTML-Mason
SUBDIR += p5-HTML-Navigation
SUBDIR += p5-HTML-Pager
diff --git a/www/p5-HTML-FillInForm/Makefile b/www/p5-HTML-FillInForm/Makefile
new file mode 100644
index 000000000000..8d8ff30d7068
--- /dev/null
+++ b/www/p5-HTML-FillInForm/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-HTML-FillInForm
+# Date created: March 30th 2001
+# Whom: Alex Kapranoff <kapr@crosswinds.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-FillInForm
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kapr@crosswinds.net
+
+BUILD_DEPEND= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser
+
+PERL_CONFIGURE= yes
+
+INSTALL_TARGET= pure_install
+
+MAN3= HTML::FillInForm.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-FillInForm/distinfo b/www/p5-HTML-FillInForm/distinfo
new file mode 100644
index 000000000000..ed5d92be66f1
--- /dev/null
+++ b/www/p5-HTML-FillInForm/distinfo
@@ -0,0 +1 @@
+MD5 (HTML-FillInForm-0.11.tar.gz) = d086a46cde130d9c3f49a0bdb4ee62ad
diff --git a/www/p5-HTML-FillInForm/pkg-comment b/www/p5-HTML-FillInForm/pkg-comment
new file mode 100644
index 000000000000..f1897e367e5f
--- /dev/null
+++ b/www/p5-HTML-FillInForm/pkg-comment
@@ -0,0 +1 @@
+Perl5 module for auto-filling HTML form fields from previous values
diff --git a/www/p5-HTML-FillInForm/pkg-descr b/www/p5-HTML-FillInForm/pkg-descr
new file mode 100644
index 000000000000..e0fbd07d49d5
--- /dev/null
+++ b/www/p5-HTML-FillInForm/pkg-descr
@@ -0,0 +1,12 @@
+From README:
+
+This module automatically inserts data from a previous HTML form into
+the HTML input and select tags. It is a subclass of HTML::Parser and
+uses it to parse the HTML and insert the values into the form tags.
+
+One useful application is after a user submits an HTML form without
+filling out required field. HTML::FillInForm can be used to redisplay
+the HTML form with all the form elements containing the submitted
+info.
+
+-- Alex Kapranoff <kapr@crosswinds.net>
diff --git a/www/p5-HTML-FillInForm/pkg-plist b/www/p5-HTML-FillInForm/pkg-plist
new file mode 100644
index 000000000000..b19f55e05e18
--- /dev/null
+++ b/www/p5-HTML-FillInForm/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/HTML/FillInForm.pm
+@unexec rmdir lib/perl5/site_perl/%%PERL_VER%%/HTML 2>/dev/null || true
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/FillInForm/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/FillInForm
+@unexec rmdir lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null|| true