aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/gambas/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/gambas/Makefile b/lang/gambas/Makefile
index fa3342719097..1c16ece8e60c 100644
--- a/lang/gambas/Makefile
+++ b/lang/gambas/Makefile
@@ -13,7 +13,6 @@ MAINTAINER= thierry@FreeBSD.org
COMMENT= Gambas Almost Means BASic
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
-RUN_DEPENDS= pgrep:${PORTSDIR}/sysutils/pkill
USE_LIBLTDL= yes
USE_KDELIBS_VER= 3
@@ -53,6 +52,10 @@ PLIST_SUB+= SDL="@comment "
BROKEN= "Does not compile with gcc-2.95"
.endif
+.if ${OSVERSION} < 502110
+RUN_DEPENDS+= pgrep:${PORTSDIR}/sysutils/pkill
+.endif
+
.for lib in ${LIBS2FIX}
NEW${lib:U}!= ${LDCONFIG} -r | ${GREP} ${lib} | ${GREP} -v 'compat/pkg' \
| ${AWK} -F 'lib\/' '{print $$2}'