aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/libu2f-host/Makefile11
-rw-r--r--security/libu2f-host/distinfo6
-rw-r--r--security/libu2f-host/files/u2f.conf.sample91
-rw-r--r--security/libu2f-host/pkg-plist2
4 files changed, 9 insertions, 101 deletions
diff --git a/security/libu2f-host/Makefile b/security/libu2f-host/Makefile
index 0a2c3043742b..4340dd3f3a61 100644
--- a/security/libu2f-host/Makefile
+++ b/security/libu2f-host/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= libu2f-host
-PORTVERSION= 1.1.3
+PORTVERSION= 1.1.4
DISTVERSIONPREFIX= ${PORTNAME}-
-PORTREVISION= 1
CATEGORIES= security devel
MAINTAINER= cpm@FreeBSD.org
@@ -17,13 +16,13 @@ BUILD_DEPENDS= gengetopt:devel/gengetopt \
LIB_DEPENDS= libhidapi.so:comms/hidapi \
libjson-c.so:devel/json-c
-USE_GITHUB= yes
-GH_ACCOUNT= Yubico
-
USES= autoreconf pkgconfig gmake libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= Yubico
+
CONFIGURE_ARGS= --disable-gtk-doc
INSTALL_TARGET= install-strip
@@ -32,7 +31,7 @@ SUB_FILES= pkg-message
GROUPS= u2f
post-install:
- ${INSTALL_DATA} ${FILESDIR}/u2f.conf.sample \
+ ${INSTALL_DATA} ${WRKSRC}/u2f.conf.sample \
${STAGEDIR}${PREFIX}/etc/devd
.include <bsd.port.mk>
diff --git a/security/libu2f-host/distinfo b/security/libu2f-host/distinfo
index e1551b4a8cb2..30626c4f00ec 100644
--- a/security/libu2f-host/distinfo
+++ b/security/libu2f-host/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1499685915
-SHA256 (Yubico-libu2f-host-libu2f-host-1.1.3_GH0.tar.gz) = 2e43679655bbfe3bb1dfee16bb6c2a324d22c7907071a8703f5195eafe891e27
-SIZE (Yubico-libu2f-host-libu2f-host-1.1.3_GH0.tar.gz) = 142392
+TIMESTAMP = 1504348234
+SHA256 (Yubico-libu2f-host-libu2f-host-1.1.4_GH0.tar.gz) = b12026fd9ea5dc9d20e700ef599bdb0396e59a7fd2d632fb36f54da7c5276b15
+SIZE (Yubico-libu2f-host-libu2f-host-1.1.4_GH0.tar.gz) = 143548
diff --git a/security/libu2f-host/files/u2f.conf.sample b/security/libu2f-host/files/u2f.conf.sample
deleted file mode 100644
index 54ab3951f9b5..000000000000
--- a/security/libu2f-host/files/u2f.conf.sample
+++ /dev/null
@@ -1,91 +0,0 @@
-# Allow members of group u2f to access U2F devices
-
-# Yubico Yubikey
-notify 100 {
- match "system" "USB";
- match "subsystem" "DEVICE";
- match "type" "ATTACH";
- match "vendor" "0x1050";
- match "product" "(0x0113|0x0114|0x0115|0x0116|0x0120|0x0420|0x0403|0x0406|0x0407|0x0410)";
- action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
-};
-
-# Happlink (formerly Plug-Up) Security KEY
-notify 100 {
- match "system" "USB";
- match "subsystem" "DEVICE";
- match "type" "ATTACH";
- match "vendor" "0x2581";
- match "product" "0xf1d0";
- action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
-};
-
-# Neowave Keydo and Keydo AES
-notify 100 {
- match "system" "USB";
- match "subsystem" "DEVICE";
- match "type" "ATTACH";
- match "vendor" "0x1e0d";
- match "product" "(0xf1d0|0xf1ae)";
- action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
-};
-
-# HyperSecu HyperFIDO
-notify 100 {
- match "system" "USB";
- match "subsystem" "DEVICE";
- match "type" "ATTACH";
- match "vendor" "(0x096e|0x2ccf)";
- match "product" "0x0880";
- action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
-};
-
-# Feitian ePass FIDO
-notify 100 {
- match "system" "USB";
- match "subsystem" "DEVICE";
- match "type" "ATTACH";
- match "vendor" "0x096e";
- match "product" "(0x0850|0x0852|0x0853|0x0854|0x0856|0x0858|0x085a|0x085b)";
- action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
-};
-
-# JaCarta U2F
-notify 100 {
- match "system" "USB";
- match "subsystem" "DEVICE";
- match "type" "ATTACH";
- match "vendor" "0x24dc";
- match "product" "0x0101";
- action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
-};
-
-# U2F Zero
-notify 100 {
- match "system" "USB";
- match "subsystem" "DEVICE";
- match "type" "ATTACH";
- match "vendor" "0x10c4";
- match "product" "0x8acf";
- action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
-};
-
-# VASCO SeccureClick
-notify 100 {
- match "system" "USB";
- match "subsystem" "DEVICE";
- match "type" "ATTACH";
- match "vendor" "0x1a44";
- match "product" "0x00bb";
- action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
-};
-
-# Bluink Key
-notify 100 {
- match "system" "USB";
- match "subsystem" "DEVICE";
- match "type" "ATTACH";
- match "vendor" "0x2abe";
- match "product" "0x1002";
- action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
-};
diff --git a/security/libu2f-host/pkg-plist b/security/libu2f-host/pkg-plist
index 076187a49359..974465f14763 100644
--- a/security/libu2f-host/pkg-plist
+++ b/security/libu2f-host/pkg-plist
@@ -6,6 +6,6 @@ include/u2f-host/u2f-host.h
lib/libu2f-host.a
lib/libu2f-host.so
lib/libu2f-host.so.0
-lib/libu2f-host.so.0.1.3
+lib/libu2f-host.so.0.1.4
libdata/pkgconfig/u2f-host.pc
man/man1/u2f-host.1.gz