aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING13
-rw-r--r--net-p2p/Makefile5
-rw-r--r--net-p2p/transmission-cli/Makefile3
-rw-r--r--net-p2p/transmission-gtk2/Makefile2
-rw-r--r--net-p2p/transmission/Makefile4
-rw-r--r--net-p2p/transmission25-cli/Makefile88
-rw-r--r--net-p2p/transmission25-cli/distinfo2
-rw-r--r--net-p2p/transmission25-cli/files/disable-web19
-rw-r--r--net-p2p/transmission25-cli/files/patch-fix_without_ipv611
-rw-r--r--net-p2p/transmission25-cli/files/patch-third-party_libutp_utp.cpp12
-rw-r--r--net-p2p/transmission25-cli/files/transmission.in45
-rw-r--r--net-p2p/transmission25-cli/pkg-descr9
-rw-r--r--net-p2p/transmission25-cli/pkg-plist9
-rw-r--r--net-p2p/transmission25-daemon/Makefile38
-rw-r--r--net-p2p/transmission25-daemon/pkg-descr11
-rw-r--r--net-p2p/transmission25-daemon/pkg-install46
-rw-r--r--net-p2p/transmission25-daemon/pkg-plist10
-rw-r--r--net-p2p/transmission25-gtk2/Makefile44
-rw-r--r--net-p2p/transmission25-gtk2/pkg-descr9
-rw-r--r--net-p2p/transmission25-gtk2/pkg-plist139
-rw-r--r--net-p2p/transmission25-qt4/Makefile57
-rw-r--r--net-p2p/transmission25-qt4/pkg-descr13
-rw-r--r--net-p2p/transmission25-qt4/pkg-plist12
-rw-r--r--net-p2p/transmission25/Makefile30
-rw-r--r--net-p2p/transmission25/pkg-descr7
-rw-r--r--www/Makefile1
-rw-r--r--www/transmission25-web/Makefile32
-rw-r--r--www/transmission25-web/pkg-descr16
28 files changed, 686 insertions, 1 deletions
diff --git a/UPDATING b/UPDATING
index 9c2ca29638cf..0b5bc0ee14bb 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,19 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20120810:
+ AFFECTS: users of net-p2p/transmission-gtk2
+ AUTHOR: crees@FreeBSD.org
+
+ Unfortunately Transmission 2.61 moved the requirement for GTK to version
+ 3.2.0, which is not yet in our tree.
+
+ Those who wish to have a graphical client can either choose transmission-qt4
+ in the meantime, or switch to the transmission25 ports.
+
+ A script to generate appropriate commands can be found at:
+ http://people.FreeBSD.org/~crees/scripts/transmission25.sh
+
20120808:
AFFECTS: users of www/libmicrohttpd
AUTHOR: bdrewery@FreeBSD.org
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index b27c482d08cd..7613c8f2f55e 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -101,6 +101,11 @@
SUBDIR += transmission-daemon
SUBDIR += transmission-gtk2
SUBDIR += transmission-qt4
+ SUBDIR += transmission25
+ SUBDIR += transmission25-cli
+ SUBDIR += transmission25-daemon
+ SUBDIR += transmission25-gtk2
+ SUBDIR += transmission25-qt4
SUBDIR += transmission-remote-gui
SUBDIR += tribler
SUBDIR += uhub
diff --git a/net-p2p/transmission-cli/Makefile b/net-p2p/transmission-cli/Makefile
index d0b30b457425..17bc0525b257 100644
--- a/net-p2p/transmission-cli/Makefile
+++ b/net-p2p/transmission-cli/Makefile
@@ -17,6 +17,9 @@ MAINTAINER?= crees@FreeBSD.org
COMMENT?= A lightweight CLI (command line) BitTorrent client and utilities
SLAVEPORT?= cli
+
+CONFLICTS_INSTALL= ${PORTNAME}${PKGNAMESUFFIX}-2.5*
+
.if ${SLAVEPORT}!="web"
LIB_DEPENDS?= ${GEN_LIB_DEPENDS}
diff --git a/net-p2p/transmission-gtk2/Makefile b/net-p2p/transmission-gtk2/Makefile
index 37808466c195..bb7b397794fb 100644
--- a/net-p2p/transmission-gtk2/Makefile
+++ b/net-p2p/transmission-gtk2/Makefile
@@ -10,7 +10,7 @@ PKGNAMESUFFIX= -gtk2
MAINTAINER= crees@FreeBSD.org
COMMENT= A fast and lightweight GTK+2 BitTorrent client
-BROKEN= Relies on GTK 3.0 version > 3.2.0
+BROKEN= Relies on GTK 3.0 version > 3.2.0; use net-p2p/transmission25-gtk20
LIB_DEPENDS= ${GEN_LIB_DEPENDS} \
notify.4:${PORTSDIR}/devel/libnotify \
diff --git a/net-p2p/transmission/Makefile b/net-p2p/transmission/Makefile
index 2387828c7340..12a74008df59 100644
--- a/net-p2p/transmission/Makefile
+++ b/net-p2p/transmission/Makefile
@@ -19,6 +19,10 @@ RUN_DEPENDS= transmission-cli:${PORTSDIR}/net-p2p/transmission-cli \
transmission-daemon:${PORTSDIR}/net-p2p/transmission-daemon \
transmission-gtk:${PORTSDIR}/net-p2p/transmission-gtk2
+CONFLICTS_INSTALL= ${PORTNAME}${PKGNAMESUFFIX}-2.6*
+
+BROKEN= Depends on GTK 2.0 frontend; use net-p2p/transmission25 for now
+
NO_BUILD= yes
do-install:
diff --git a/net-p2p/transmission25-cli/Makefile b/net-p2p/transmission25-cli/Makefile
new file mode 100644
index 000000000000..bf51832f62f9
--- /dev/null
+++ b/net-p2p/transmission25-cli/Makefile
@@ -0,0 +1,88 @@
+# New ports collection makefile for: transmission
+# Date created: 08 October 2005
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= transmission
+PORTVERSION= 2.51
+PORTREVISION?= 0
+CATEGORIES?= net-p2p
+#MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/ \
+MASTER_SITES= http://transmission.cachefly.net/
+PKGNAMESUFFIX?= -cli
+
+MAINTAINER?= crees@FreeBSD.org
+COMMENT?= The last version of Transmission that still supports GTK 2.0
+
+LATEST_LINK= ${PORTNAME}25${PKGNAMESUFFIX}
+CONFLICTS_INSTALL= ${PORTNAME}${PKGNAMESUFFIX}-2.6*
+
+SLAVEPORT?= cli
+.if ${SLAVEPORT}!="web"
+LIB_DEPENDS?= ${GEN_LIB_DEPENDS}
+
+# General dependencies
+GEN_LIB_DEPENDS=curl.6:${PORTSDIR}/ftp/curl \
+ event-2.0.6:${PORTSDIR}/devel/libevent2
+GEN_RUN_DEPENDS=${LOCALBASE}/share/transmission/web/index.html:${PORTSDIR}/www/transmission-web
+
+USE_GMAKE= yes
+USE_GNOME?= pkgconfig
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS=--with-zlib=/usr \
+ --disable-libappindicator \
+ --disable-gconf2 \
+ ${EXTRA_CONF_ARGS}
+EXTRA_CONF_ARGS?=--enable-cli \
+ --disable-daemon \
+ --without-gtk \
+ --disable-mac \
+ --disable-nls
+
+MAN1?= transmission-cli.1 transmission-create.1 transmission-edit.1 \
+ transmission-show.1
+EXTRA_PATCHES= ${PATCHDIR}/disable-web
+.endif
+
+USE_XZ= yes
+
+DOCS= AUTHORS COPYING NEWS README
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+
+general-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|noinst_PROGRAMS = |noinst_PROGRAMS = #|g'
+.if ${SLAVEPORT}!="gtk2"
+ @${REINPLACE_CMD} -e '/#define DISABLE_GETTEXT/s,/\* \(.*\) \*/,\1,' \
+ ${WRKSRC}/libtransmission/utils.h
+.endif
+ @${REINPLACE_CMD} -e \
+ 's|_pthread_flags=".*"|_pthread_flags="${PTHREAD_LIBS}"|g ; \
+ s|rt_clock_gettime=yes|rt_clock_gettime=no|g ; \
+ s|" == "|" = "|g ; s|$$with_ssl.*/usr;|${OPENSSLBASE};|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|doc \\| \\|g' \
+ ${WRKSRC}/Makefile.in
+.if ${SLAVEPORT}!="cli"
+ @${REINPLACE_CMD} -e 's|utils \\|\\|g' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+post-patch: general-patch
+
+general-install:
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+post-install: general-install
+
+.include <bsd.port.mk>
diff --git a/net-p2p/transmission25-cli/distinfo b/net-p2p/transmission25-cli/distinfo
new file mode 100644
index 000000000000..2ce4ace420c4
--- /dev/null
+++ b/net-p2p/transmission25-cli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (transmission-2.51.tar.xz) = 1c9a54864acf8fd0c7aa4132e9e69b454a7c72c305c96016a38551157af8858b
+SIZE (transmission-2.51.tar.xz) = 2784036
diff --git a/net-p2p/transmission25-cli/files/disable-web b/net-p2p/transmission25-cli/files/disable-web
new file mode 100644
index 000000000000..2c63c36e62a8
--- /dev/null
+++ b/net-p2p/transmission25-cli/files/disable-web
@@ -0,0 +1,19 @@
+--- Makefile.in.orig 2010-10-23 15:56:02.000000000 -0500
++++ Makefile.in 2010-10-23 15:56:55.000000000 -0500
+@@ -303,15 +303,13 @@
+ @BUILD_GTK_TRUE@GTK_DIR = gtk po
+ @BUILD_MAC_TRUE@MAC_DIR = macosx
+ SUBDIRS = \
+- extras \
+ third-party \
+ libtransmission \
+ utils \
+ $(DAEMON_DIR) \
+ $(CLI_DIR) \
+ $(GTK_DIR) \
+- $(MAC_DIR) \
+- web
++ $(MAC_DIR)
+
+ EXTRA_DIST = \
+ qt \
diff --git a/net-p2p/transmission25-cli/files/patch-fix_without_ipv6 b/net-p2p/transmission25-cli/files/patch-fix_without_ipv6
new file mode 100644
index 000000000000..49e1c57a269a
--- /dev/null
+++ b/net-p2p/transmission25-cli/files/patch-fix_without_ipv6
@@ -0,0 +1,11 @@
+--- libtransmission/fdlimit.c.orig 2011-02-27 15:34:55.000000000 -0600
++++ libtransmission/fdlimit.c 2011-02-27 15:35:12.000000000 -0600
+@@ -609,7 +609,7 @@
+
+ if( gFd->socket_count < session->peerLimit )
+ if(( s = socket( domain, type, 0 )) < 0 )
+- if( sockerrno != EAFNOSUPPORT )
++ if( sockerrno != EPROTONOSUPPORT )
+ tr_err( _( "Couldn't create socket: %s" ), tr_strerror( sockerrno ) );
+
+ if( s > -1 )
diff --git a/net-p2p/transmission25-cli/files/patch-third-party_libutp_utp.cpp b/net-p2p/transmission25-cli/files/patch-third-party_libutp_utp.cpp
new file mode 100644
index 000000000000..8f4b4866ad29
--- /dev/null
+++ b/net-p2p/transmission25-cli/files/patch-third-party_libutp_utp.cpp
@@ -0,0 +1,12 @@
+--- third-party/libutp/utp.cpp.orig 2011-04-29 21:45:38.000000000 -0500
++++ third-party/libutp/utp.cpp 2011-04-29 21:47:05.000000000 -0500
+@@ -10,6 +10,9 @@
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <limits.h> // for UINT_MAX
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+
+ #ifdef WIN32
+ #include "win32_inet_ntop.h"
diff --git a/net-p2p/transmission25-cli/files/transmission.in b/net-p2p/transmission25-cli/files/transmission.in
new file mode 100644
index 000000000000..def430c8b88b
--- /dev/null
+++ b/net-p2p/transmission25-cli/files/transmission.in
@@ -0,0 +1,45 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: transmission
+# REQUIRE: DAEMON
+#
+# Add the following lines to /etc/rc.conf to enable this service:
+#
+# transmission_enable: Set to NO by default. Set it to YES to enable it.
+# transmission_watch_dir: Directory for torrent files to download
+# automatically. Off by default unless you add
+# a path.
+# transmission_conf_dir: Directory where transmission configuration
+# data is stored.
+# Default: %%PREFIX%%/etc/transmission/home
+# transmission_download_dir: Directory to store downloaded data.
+# Default: %%PREFIX%%/etc/transmission/home/Downloads
+# transmission_user: The user account transmission daemon runs as what
+# you want it to be. It uses 'transmission' user by
+# default. Do not sets it as empty or it will run
+# as root.
+#
+
+. /etc/rc.subr
+
+name="transmission"
+rcvar=transmission_enable
+
+command=%%PREFIX%%/bin/transmission-daemon
+
+load_rc_config ${name}
+
+: ${transmission_enable:="NO"}
+: ${transmission_user:="transmission"}
+: ${transmission_conf_dir="%%PREFIX%%/etc/transmission/home"}
+: ${transmission_download_dir="%%PREFIX%%/etc/transmission/home/Downloads"}
+
+transmission_flags=" \
+ ${transmission_watch_dir:+-c ${transmission_watch_dir}} \
+ ${transmission_conf_dir:+-g ${transmission_conf_dir}} \
+ ${transmission_download_dir:+-w ${transmission_download_dir}} \
+ ${transmission_flags}"
+
+run_rc_command "$1"
diff --git a/net-p2p/transmission25-cli/pkg-descr b/net-p2p/transmission25-cli/pkg-descr
new file mode 100644
index 000000000000..5809e6716ef4
--- /dev/null
+++ b/net-p2p/transmission25-cli/pkg-descr
@@ -0,0 +1,9 @@
+A fast and lightweight CLI (command line) BitTorrent client.
+
+Transmission has been built from the ground up to be a lightweight, yet
+powerful BitTorrent client. Its simple, intuitive interface is designed
+to integrate tightly with whatever computing environment you choose to
+use. Transmission strikes a balance between providing useful functionality
+without feature bloat. Furthermore, it is free for anyone to use or modify.
+
+WWW: http://www.transmissionbt.com/
diff --git a/net-p2p/transmission25-cli/pkg-plist b/net-p2p/transmission25-cli/pkg-plist
new file mode 100644
index 000000000000..58ae01daf4a8
--- /dev/null
+++ b/net-p2p/transmission25-cli/pkg-plist
@@ -0,0 +1,9 @@
+bin/transmission-cli
+bin/transmission-create
+bin/transmission-edit
+bin/transmission-show
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/net-p2p/transmission25-daemon/Makefile b/net-p2p/transmission25-daemon/Makefile
new file mode 100644
index 000000000000..c0637ae1557f
--- /dev/null
+++ b/net-p2p/transmission25-daemon/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: transmission-daemon
+# Date created: 08 February 2008
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -daemon
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= A fast and lightweight daemon BitTorrent client
+
+RUN_DEPENDS= ${GEN_RUN_DEPENDS}
+
+DESCR= ${.CURDIR}/pkg-descr
+MASTERDIR= ${.CURDIR}/../transmission25-cli
+PLIST= ${.CURDIR}/pkg-plist
+PKGINSTALL= ${.CURDIR}/pkg-install
+SLAVEPORT= daemon
+
+USE_RC_SUBR= transmission
+
+EXTRA_CONF_ARGS=--disable-cli \
+ --enable-daemon \
+ --without-gtk \
+ --disable-mac \
+ --disable-nls
+
+MAN1= transmission-daemon.1 transmission-remote.1
+
+post-install: general-install
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} \
+ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/transmission25-daemon/pkg-descr b/net-p2p/transmission25-daemon/pkg-descr
new file mode 100644
index 000000000000..d609b375191d
--- /dev/null
+++ b/net-p2p/transmission25-daemon/pkg-descr
@@ -0,0 +1,11 @@
+The transmission-daemon is a daemon-based Transmission session that can
+be controlled via RPC by transmission-remote (included) and other
+Transmission BiTtorrent client such as GTK+ and CLI interface.
+
+Transmission has been built from the ground up to be a lightweight, yet
+powerful BitTorrent client. Its simple, intuitive interface is designed
+to integrate tightly with whatever computing environment you choose to
+use. Transmission strikes a balance between providing useful functionality
+without feature bloat. Furthermore, it is free for anyone to use or modify.
+
+WWW: http://www.transmissionbt.com/
diff --git a/net-p2p/transmission25-daemon/pkg-install b/net-p2p/transmission25-daemon/pkg-install
new file mode 100644
index 000000000000..7d6ee9b0a832
--- /dev/null
+++ b/net-p2p/transmission25-daemon/pkg-install
@@ -0,0 +1,46 @@
+#!/bin/sh
+
+case $2 in
+POST-INSTALL)
+ USER=transmission
+ GROUP=${USER}
+ UID=921
+ GID=${UID}
+ PW=/usr/sbin/pw
+ CHMOD=/bin/chmod
+ CHOWN=/usr/sbin/chown
+ MKDIR=/bin/mkdir
+ THOME=${PKG_PREFIX}/etc/${USER}/home
+
+ if ${PW} group show "${GROUP}" 2>/dev/null; then
+ echo "You already have a group \"${GROUP}\", so I will use it."
+ else
+ if ${PW} groupadd ${GROUP} -g ${GID}; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Adding group \"${GROUP}\" failed..."
+ exit 1
+ fi
+ fi
+
+ if ${PW} user show "${USER}" 2>/dev/null; then
+ echo "You already have a user \"${USER}\", so I will use it."
+ else
+ if ${PW} useradd ${USER} -u ${UID} -g ${GROUP} -h - \
+ -d "${THOME}" -s /usr/sbin/nologin -c "Transmission Daemon User"
+ then
+ echo "Added user \"${USER}\"."
+ else
+ echo "Adding user \"${USER}\" failed..."
+ exit 1
+ fi
+ fi
+
+ ${MKDIR} -p ${THOME}/Downloads
+ ${CHOWN} root:${GROUP} ${THOME}
+ ${CHOWN} ${USER}:${GROUP} ${THOME}/Downloads
+ ${CHMOD} 1770 ${THOME}
+
+ exit 0
+ ;;
+esac
diff --git a/net-p2p/transmission25-daemon/pkg-plist b/net-p2p/transmission25-daemon/pkg-plist
new file mode 100644
index 000000000000..e7cb3d4f583f
--- /dev/null
+++ b/net-p2p/transmission25-daemon/pkg-plist
@@ -0,0 +1,10 @@
+bin/transmission-daemon
+bin/transmission-remote
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry etc/transmission/home/Downloads
+@dirrmtry etc/transmission/home
+@dirrmtry etc/transmission
diff --git a/net-p2p/transmission25-gtk2/Makefile b/net-p2p/transmission25-gtk2/Makefile
new file mode 100644
index 000000000000..81ffdf041cfb
--- /dev/null
+++ b/net-p2p/transmission25-gtk2/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: transmission-gtk2
+# Date created: 11 February 2006
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -gtk2
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= The last version of Transmission to support GTK 2.0
+
+LIB_DEPENDS= ${GEN_LIB_DEPENDS} \
+ notify.4:${PORTSDIR}/devel/libnotify \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+RUN_DEPENDS= ${GEN_RUN_DEPENDS} \
+ xdg-open:${PORTSDIR}/devel/xdg-utils
+
+DESCR= ${.CURDIR}/pkg-descr
+MASTERDIR= ${.CURDIR}/../transmission25-cli
+PLIST= ${.CURDIR}/pkg-plist
+SLAVEPORT= gtk2
+
+USE_GNOME= gnomehack gtk20 desktopfileutils intlhack
+USE_GETTEXT= yes
+INSTALLS_ICONS= yes
+
+EXTRA_CONF_ARGS=--disable-cli \
+ --disable-daemon \
+ --with-gtk \
+ --enable-inotify \
+ --disable-mac \
+ --enable-nls
+
+MAN1= transmission-gtk.1
+
+post-patch: general-patch
+ @${REINPLACE_CMD} -e 's|TryExec=.*||g ; /^$$/d' \
+ ${WRKSRC}/gtk/transmission-gtk.desktop.in
+
+post-install: general-install
+ @-update-desktop-database
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/transmission25-gtk2/pkg-descr b/net-p2p/transmission25-gtk2/pkg-descr
new file mode 100644
index 000000000000..b735240917bd
--- /dev/null
+++ b/net-p2p/transmission25-gtk2/pkg-descr
@@ -0,0 +1,9 @@
+A fast and lightweight GTK+2 BitTorrent client.
+
+Transmission has been built from the ground up to be a lightweight, yet
+powerful BitTorrent client. Its simple, intuitive interface is designed
+to integrate tightly with whatever computing environment you choose to
+use. Transmission strikes a balance between providing useful functionality
+without feature bloat. Furthermore, it is free for anyone to use or modify.
+
+WWW: http://www.transmissionbt.com/
diff --git a/net-p2p/transmission25-gtk2/pkg-plist b/net-p2p/transmission25-gtk2/pkg-plist
new file mode 100644
index 000000000000..9d034c833f6d
--- /dev/null
+++ b/net-p2p/transmission25-gtk2/pkg-plist
@@ -0,0 +1,139 @@
+bin/transmission-gtk
+share/applications/transmission-gtk.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/icons/hicolor/16x16/apps/transmission.png
+share/icons/hicolor/22x22/apps/transmission.png
+share/icons/hicolor/24x24/apps/transmission.png
+share/icons/hicolor/256x256/apps/transmission.png
+share/icons/hicolor/32x32/apps/transmission.png
+share/icons/hicolor/48x48/apps/transmission.png
+share/icons/hicolor/scalable/apps/transmission.svg
+share/locale/an/LC_MESSAGES/transmission-gtk.mo
+share/locale/ar/LC_MESSAGES/transmission-gtk.mo
+share/locale/ast/LC_MESSAGES/transmission-gtk.mo
+share/locale/az/LC_MESSAGES/transmission-gtk.mo
+share/locale/be/LC_MESSAGES/transmission-gtk.mo
+share/locale/be@latin/LC_MESSAGES/transmission-gtk.mo
+share/locale/bg/LC_MESSAGES/transmission-gtk.mo
+share/locale/bn/LC_MESSAGES/transmission-gtk.mo
+share/locale/bo/LC_MESSAGES/transmission-gtk.mo
+share/locale/br/LC_MESSAGES/transmission-gtk.mo
+share/locale/bs/LC_MESSAGES/transmission-gtk.mo
+share/locale/ca/LC_MESSAGES/transmission-gtk.mo
+share/locale/ca@valencia/LC_MESSAGES/transmission-gtk.mo
+share/locale/ceb/LC_MESSAGES/transmission-gtk.mo
+share/locale/ckb/LC_MESSAGES/transmission-gtk.mo
+share/locale/cs/LC_MESSAGES/transmission-gtk.mo
+share/locale/da/LC_MESSAGES/transmission-gtk.mo
+share/locale/de/LC_MESSAGES/transmission-gtk.mo
+share/locale/el/LC_MESSAGES/transmission-gtk.mo
+share/locale/en_AU/LC_MESSAGES/transmission-gtk.mo
+share/locale/en_CA/LC_MESSAGES/transmission-gtk.mo
+share/locale/en_GB/LC_MESSAGES/transmission-gtk.mo
+share/locale/eo/LC_MESSAGES/transmission-gtk.mo
+share/locale/es/LC_MESSAGES/transmission-gtk.mo
+share/locale/et/LC_MESSAGES/transmission-gtk.mo
+share/locale/eu/LC_MESSAGES/transmission-gtk.mo
+share/locale/fa/LC_MESSAGES/transmission-gtk.mo
+share/locale/fi/LC_MESSAGES/transmission-gtk.mo
+share/locale/fil/LC_MESSAGES/transmission-gtk.mo
+share/locale/fo/LC_MESSAGES/transmission-gtk.mo
+share/locale/fr/LC_MESSAGES/transmission-gtk.mo
+share/locale/ga/LC_MESSAGES/transmission-gtk.mo
+share/locale/gl/LC_MESSAGES/transmission-gtk.mo
+share/locale/gv/LC_MESSAGES/transmission-gtk.mo
+share/locale/he/LC_MESSAGES/transmission-gtk.mo
+share/locale/hi/LC_MESSAGES/transmission-gtk.mo
+share/locale/hr/LC_MESSAGES/transmission-gtk.mo
+share/locale/hy/LC_MESSAGES/transmission-gtk.mo
+share/locale/hu/LC_MESSAGES/transmission-gtk.mo
+share/locale/ia/LC_MESSAGES/transmission-gtk.mo
+share/locale/id/LC_MESSAGES/transmission-gtk.mo
+share/locale/is/LC_MESSAGES/transmission-gtk.mo
+share/locale/it/LC_MESSAGES/transmission-gtk.mo
+share/locale/ja/LC_MESSAGES/transmission-gtk.mo
+share/locale/ka/LC_MESSAGES/transmission-gtk.mo
+share/locale/kk/LC_MESSAGES/transmission-gtk.mo
+share/locale/ko/LC_MESSAGES/transmission-gtk.mo
+share/locale/ku/LC_MESSAGES/transmission-gtk.mo
+share/locale/li/LC_MESSAGES/transmission-gtk.mo
+share/locale/lt/LC_MESSAGES/transmission-gtk.mo
+share/locale/lv/LC_MESSAGES/transmission-gtk.mo
+share/locale/mk/LC_MESSAGES/transmission-gtk.mo
+share/locale/ml/LC_MESSAGES/transmission-gtk.mo
+share/locale/mr/LC_MESSAGES/transmission-gtk.mo
+share/locale/ms/LC_MESSAGES/transmission-gtk.mo
+share/locale/mt/LC_MESSAGES/transmission-gtk.mo
+share/locale/nb/LC_MESSAGES/transmission-gtk.mo
+share/locale/nds/LC_MESSAGES/transmission-gtk.mo
+share/locale/nl/LC_MESSAGES/transmission-gtk.mo
+share/locale/nn/LC_MESSAGES/transmission-gtk.mo
+share/locale/oc/LC_MESSAGES/transmission-gtk.mo
+share/locale/pa/LC_MESSAGES/transmission-gtk.mo
+share/locale/pl/LC_MESSAGES/transmission-gtk.mo
+share/locale/pt/LC_MESSAGES/transmission-gtk.mo
+share/locale/pt_BR/LC_MESSAGES/transmission-gtk.mo
+share/locale/ro/LC_MESSAGES/transmission-gtk.mo
+share/locale/ru/LC_MESSAGES/transmission-gtk.mo
+share/locale/si/LC_MESSAGES/transmission-gtk.mo
+share/locale/sk/LC_MESSAGES/transmission-gtk.mo
+share/locale/sl/LC_MESSAGES/transmission-gtk.mo
+share/locale/sq/LC_MESSAGES/transmission-gtk.mo
+share/locale/sr/LC_MESSAGES/transmission-gtk.mo
+share/locale/sv/LC_MESSAGES/transmission-gtk.mo
+share/locale/ta_LK/LC_MESSAGES/transmission-gtk.mo
+share/locale/te/LC_MESSAGES/transmission-gtk.mo
+share/locale/th/LC_MESSAGES/transmission-gtk.mo
+share/locale/tl/LC_MESSAGES/transmission-gtk.mo
+share/locale/tr/LC_MESSAGES/transmission-gtk.mo
+share/locale/ug/LC_MESSAGES/transmission-gtk.mo
+share/locale/uk/LC_MESSAGES/transmission-gtk.mo
+share/locale/ur/LC_MESSAGES/transmission-gtk.mo
+share/locale/uz/LC_MESSAGES/transmission-gtk.mo
+share/locale/vi/LC_MESSAGES/transmission-gtk.mo
+share/locale/zh_CN/LC_MESSAGES/transmission-gtk.mo
+share/locale/zh_TW/LC_MESSAGES/transmission-gtk.mo
+share/pixmaps/transmission.png
+@dirrmtry share/locale/ur/LC_MESSAGES
+@dirrmtry share/locale/ur
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/tl/LC_MESSAGES
+@dirrmtry share/locale/tl
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/ta_LK/LC_MESSAGES
+@dirrmtry share/locale/ta_LK
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
+@dirrmtry share/locale/gv/LC_MESSAGES
+@dirrmtry share/locale/gv
+@dirrmtry share/locale/fo/LC_MESSAGES
+@dirrmtry share/locale/fo
+@dirrmtry share/locale/fil/LC_MESSAGES
+@dirrmtry share/locale/fil
+@dirrmtry share/locale/ckb/LC_MESSAGES
+@dirrmtry share/locale/ckb
+@dirrmtry share/locale/ceb/LC_MESSAGES
+@dirrmtry share/locale/ceb
+@dirrmtry share/locale/bo/LC_MESSAGES
+@dirrmtry share/locale/bo
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/an/LC_MESSAGES
+@dirrmtry share/locale/an
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
diff --git a/net-p2p/transmission25-qt4/Makefile b/net-p2p/transmission25-qt4/Makefile
new file mode 100644
index 000000000000..0ea0a91e0a0c
--- /dev/null
+++ b/net-p2p/transmission25-qt4/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: transmission-qt4
+# Date created: 23 October 2010
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 1
+PKGNAMESUFFIX= -qt4
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= A fast and lightweight QT4 BitTorrent client
+
+LIB_DEPENDS= ${GEN_LIB_DEPENDS}
+RUN_DEPENDS= ${GEN_RUN_DEPENDS}
+
+DESCR= ${.CURDIR}/pkg-descr
+MASTERDIR= ${.CURDIR}/../transmission25-cli
+PLIST= ${.CURDIR}/pkg-plist
+SLAVEPORT= qt4
+
+QT_NONSTANDARD= yes
+USE_QT4= moc_build qmake_build rcc_build uic_build gui dbus network
+USE_GNOME= desktopfileutils
+
+EXTRA_CONF_ARGS=--disable-cli \
+ --disable-daemon \
+ --without-gtk \
+ --disable-mac \
+ --disable-nls
+
+MAN1= transmission-qt.1
+
+post-patch: general-patch
+ @${REINPLACE_CMD} -e 's|/share/man|/man|g ; /PKGCONFIG/s| openssl||g' \
+ ${WRKSRC}/qt/qtr.pro
+
+post-build:
+ @(cd ${WRKSRC}/qt ; ${QMAKE} ${QMAKEFLAGS} qtr.pro ; ${GMAKE})
+
+do-install:
+ @(cd ${WRKSRC}/qt ; ${SETENV} INSTALL_ROOT=${PREFIX} ${MAKE} install)
+
+post-install: general-install
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/qt/README.txt ${DOCSDIR}/README-qt4
+.endif
+ @${MKDIR} ${PREFIX}/share/applications
+ @${INSTALL_DATA} ${WRKSRC}/qt/transmission-qt.desktop \
+ ${PREFIX}/share/applications/
+ @${MKDIR} ${PREFIX}/share/pixmaps
+ @${INSTALL_DATA} ${WRKSRC}/qt/icons/transmission.png \
+ ${PREFIX}/share/pixmaps/transmission-qt.png
+ @-update-desktop-database
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/transmission25-qt4/pkg-descr b/net-p2p/transmission25-qt4/pkg-descr
new file mode 100644
index 000000000000..1e252e2875e1
--- /dev/null
+++ b/net-p2p/transmission25-qt4/pkg-descr
@@ -0,0 +1,13 @@
+A fast and lightweight QT4 BitTorrent client, loosely based on the GTK+ client.
+
+This is the only Transmission client that can act as its own self-contained
+session (as the GTK+ and Mac clients do), and can also connect to a remote
+session (as the web client and transmission-remote terminal client do).
+
+Transmission has been built from the ground up to be a lightweight, yet
+powerful BitTorrent client. Its simple, intuitive interface is designed
+to integrate tightly with whatever computing environment you choose to
+use. Transmission strikes a balance between providing useful functionality
+without feature bloat. Furthermore, it is free for anyone to use or modify.
+
+WWW: http://www.transmissionbt.com/
diff --git a/net-p2p/transmission25-qt4/pkg-plist b/net-p2p/transmission25-qt4/pkg-plist
new file mode 100644
index 000000000000..11f5b41a91a1
--- /dev/null
+++ b/net-p2p/transmission25-qt4/pkg-plist
@@ -0,0 +1,12 @@
+bin/transmission-qt
+share/applications/transmission-qt.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README-qt4
+share/pixmaps/transmission-qt.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
diff --git a/net-p2p/transmission25/Makefile b/net-p2p/transmission25/Makefile
new file mode 100644
index 000000000000..61dd484b8d19
--- /dev/null
+++ b/net-p2p/transmission25/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: transmission
+# Date created: 08 October 2005
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= transmission
+PORTVERSION= 2.51
+CATEGORIES= net-p2p
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= The last version of Transmission that supports GTK 2.0
+
+RUN_DEPENDS= transmission-cli:${PORTSDIR}/net-p2p/transmission25-cli \
+ transmission-daemon:${PORTSDIR}/net-p2p/transmission25-daemon \
+ transmission-gtk:${PORTSDIR}/net-p2p/transmission25-gtk2
+
+LATEST_LINK= ${PORTNAME}25${PKGNAMESUFFIX}
+CONFLICTS_INSTALL= ${PORTNAME}${PKGNAMESUFFIX}-2.6*
+
+NO_BUILD= yes
+
+do-install:
+ @${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/net-p2p/transmission25/pkg-descr b/net-p2p/transmission25/pkg-descr
new file mode 100644
index 000000000000..fd7d0a09875d
--- /dev/null
+++ b/net-p2p/transmission25/pkg-descr
@@ -0,0 +1,7 @@
+Transmission has been built from the ground up to be a lightweight, yet
+powerful BitTorrent client. Its simple, intuitive interface is designed
+to integrate tightly with whatever computing environment you choose to
+use. Transmission strikes a balance between providing useful functionality
+without feature bloat. Furthermore, it is free for anyone to use or modify.
+
+WWW: http://www.transmissionbt.com/
diff --git a/www/Makefile b/www/Makefile
index 92de2a9d93e5..dad0cf582ab6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1906,6 +1906,7 @@
SUBDIR += trac-xmlrpc
SUBDIR += trafficserver
SUBDIR += transmission-web
+ SUBDIR += transmission25-web
SUBDIR += transproxy
SUBDIR += tt-rss
SUBDIR += ttf2eot
diff --git a/www/transmission25-web/Makefile b/www/transmission25-web/Makefile
new file mode 100644
index 000000000000..a89613897998
--- /dev/null
+++ b/www/transmission25-web/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: transmission-web
+# Date created: 14 July 2008
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= www net-p2p
+PKGNAMESUFFIX= -web
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= A fast and lightweight WebUI for Transmission BitTorrent client
+
+DESCR= ${.CURDIR}/pkg-descr
+MASTERDIR= ${.CURDIR}/../../net-p2p/transmission25-cli
+PLIST= ${NONEXISTENT}
+SLAVEPORT= web
+
+PORTDATA= web
+PORTDOCS= *
+
+NO_BUILD= yes
+
+post-extract:
+ @${FIND} ${WRKSRC}/web -name Makefile.* -delete
+
+do-install:
+ @${MKDIR} ${DATADIR}/web
+ @(cd ${WRKSRC}/web && ${COPYTREE_SHARE} \* ${DATADIR}/web)
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/transmission25-web/pkg-descr b/www/transmission25-web/pkg-descr
new file mode 100644
index 000000000000..5c3661bbedf9
--- /dev/null
+++ b/www/transmission25-web/pkg-descr
@@ -0,0 +1,16 @@
+Transmission Web Interface (Clutch) is a WebUI for the Transmission BitTorrent
+client. It allows you to manage your torrents from anywhere you can access the
+internet, and runs on OS X and various flavors of *nix. It provides most of
+the basic features of the desktop client, including torrent upload, torrent
+start/stop, file path selection, speed limiting etc.
+
+Transmission has been built from the ground up to be a lightweight, yet
+powerful BitTorrent client. Its simple, intuitive interface is designed
+to integrate tightly with whatever computing environment you choose to
+use. Transmission strikes a balance between providing useful functionality
+without feature bloat. Furthermore, it is free for anyone to use or modify.
+
+You will need to install either transmission-daemon, transmission-gtk2 or
+both to use WebUI.
+
+WWW: http://www.transmissionbt.com/