aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING12
-rw-r--r--shells/zsh/Makefile18
-rw-r--r--shells/zsh/files/pkg-message.in10
3 files changed, 33 insertions, 7 deletions
diff --git a/UPDATING b/UPDATING
index 0bbfb2777bec..0616d5c9adb9 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,18 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20160624
+ AFFECTS: users of shells/zsh
+ AUTHOR: adamw@FreeBSD.org
+
+ zsh now looks for system-wide conf files in ${PREFIX}/etc, instead of
+ /etc. If you have files like zshrc, zshenv, zprofile, zlogin, or zlogout
+ in /etc, either move them to /usr/local/etc or rebuild zsh with the
+ ETCDIR option on.
+
+ Note that this change only affects system-wide conf files, which are not
+ installed or created by a default installation.
+
20160621
AFFECTS: users of www/redmine
AUTHOR: tz@FreeBSD.org
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 3bfcc885f409..a3d08dd8582f 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -3,10 +3,9 @@
PORTNAME= zsh
DISTVERSION= 5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= shells
-MASTER_SITES= \
- http://www.zsh.org/pub/:doc \
+MASTER_SITES= http://www.zsh.org/pub/:doc \
http://www.zsh.org/pub/ \
SF \
SF/${PORTNAME}/${PORTNAME}-doc/${PORTVERSION}:doc
@@ -25,6 +24,7 @@ MAKE_JOBS_UNSAFE= yes
EXTRA_PATCHES= ${FILESDIR}/extra-patch-bsdtar
ZSH_VER= ${PORTVERSION}
PLIST_SUB+= ZSH_VER="${ZSH_VER}"
+SUB_FILES= pkg-message
USES= iconv ncurses shebangfix tar:xz
@@ -46,7 +46,8 @@ CPPFLAGS+= -I${LOCALBASE}/include -DBOOL_DEFINED
LDFLAGS+= -L${LOCALBASE}/lib -Wl,--as-needed
CONFIGURE_ENV+= zsh_cv_sys_path_dev_fd=no
CONFIGURE_ARGS= --with-tcsetpgrp \
- --enable-function-subdirs --enable-multibyte \
+ --enable-function-subdirs \
+ --enable-multibyte \
--sysconfdir=${PREFIX}/etc
DOCS= LICENCE META-FAQ README \
@@ -60,7 +61,7 @@ PORTEXAMPLES= zlogin zshenv zshrc
#EXTRA_COMPLETION_FILES= _sockstat
#EXTRA_COMPLETION_DIR= Completion/BSD/Command
-OPTIONS_DEFINE= GDBM MEM SECURE_FREE MAILDIR PCRE STATIC DEBUG \
+OPTIONS_DEFINE= DEBUG ETCDIR GDBM MAILDIR MEM PCRE SECURE_FREE STATIC \
DOCS EXAMPLES
OPTIONS_DEFAULT=SECURE_FREE MAILDIR
OPTIONS_SUB= yes
@@ -73,13 +74,16 @@ GDBM_DESC= Enable GDBM support (GPL)
GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
GDBM_CONFIGURE_ENABLE= gdbm
-MAILDIR_DESC= Enable support for Maildirs in MAIL(PATH)
+ETCDIR_DESC= System-wide defaults in /etc (instead of ${PREFIX}/etc)
+ETCDIR_CONFIGURE_OFF= --enable-etcdir=${PREFIX}/etc
+
+MAILDIR_DESC= Enable support for Maildirs in MAIL(PATH)
MAILDIR_CONFIGURE_ENABLE= maildir-support
MEM_DESC= Enable zsh-mem options
MEM_CONFIGURE_ENABLE= zsh-mem
-SECURE_FREE_DESC= Enable zsh-secure-free
+SECURE_FREE_DESC= Enable zsh-secure-free
SECURE_FREE_CONFIGURE_ENABLE= zsh-secure-free
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
diff --git a/shells/zsh/files/pkg-message.in b/shells/zsh/files/pkg-message.in
new file mode 100644
index 000000000000..44f7e6096cd5
--- /dev/null
+++ b/shells/zsh/files/pkg-message.in
@@ -0,0 +1,10 @@
+==========================================================
+
+By default, zsh looks for system-wide defaults in
+%%PREFIX%%/etc.
+
+If you previously set up /etc/zprofile, /etc/zshenv, etc.,
+either move them to %%PREFIX%%/etc or rebuild zsh with the
+ETCDIR option enabled.
+
+==========================================================