aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING8
-rw-r--r--mail/opensmtpd/Makefile10
-rw-r--r--mail/opensmtpd/distinfo4
-rw-r--r--mail/opensmtpd/files/patch-smtpd_Makefile.am42
-rw-r--r--mail/opensmtpd/files/patch-src_Makefile.am19
-rw-r--r--mail/opensmtpd/files/pkg-deinstall.in2
-rw-r--r--mail/opensmtpd/files/pkg-install.in4
-rw-r--r--mail/opensmtpd/pkg-plist5
8 files changed, 64 insertions, 30 deletions
diff --git a/UPDATING b/UPDATING
index d7405b8f6468..5a48a8bbb09b 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20130102:
+ AFFECTS: users of mail/opensmtpd
+ AUTHOR: ashish@FreeBSD.org
+
+ OpenSMTPD port has been updated to the latest portable snapshot. There
+ has been several changes to the configuration between the last version
+ and this version, which requires configuration file need to be reviewed.
+
20121229:
AFFECTS: users of devel/libical
AUTHOR: gnome@FreeBSD.org
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index 24cd7f827977..99090a0be35b 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -6,19 +6,21 @@
#
PORTNAME= opensmtpd
-PORTVERSION= 201210090136
+PORTVERSION= 201212222206
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
http://distfiles.pirateparty.in/ashish/
+DISTNAME= ${PORTNAME}-${PORTVERSION}p1
MAINTAINER= ashish@FreeBSD.org
COMMENT= OpenSMTPD is a free MTA
-LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= event-1:${PORTSDIR}/devel/libevent \
+ sqlite3:${PORTSDIR}/databases/sqlite3
LICENSE_NAME= ISCL
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-5.2.xp1
USE_AUTOTOOLS= autoconf:env automake:env libtool:env
GNU_CONFIGURE= yes
@@ -30,7 +32,7 @@ SUB_FILES= pkg-install pkg-deinstall
CONFLICTS= postfix-[0-9]* sendmail-[0-9]*
MAN8= makemap.8 newaliases.8 smtpctl.8 smtpd.8
-MAN5= smtpd.conf.5
+MAN5= smtpd.conf.5 aliases.5 forward.5
USERS= _smtpd
GROUPS= _smtpd
diff --git a/mail/opensmtpd/distinfo b/mail/opensmtpd/distinfo
index 70dfd2dbac2e..3bea3488be4b 100644
--- a/mail/opensmtpd/distinfo
+++ b/mail/opensmtpd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (opensmtpd-201210090136.tar.gz) = de3eecd447e5554ada9129632f1184d33930eb2c5721d535ddfe90696912cdd2
-SIZE (opensmtpd-201210090136.tar.gz) = 253466
+SHA256 (opensmtpd-201212222206p1.tar.gz) = 49da146abfbe37a4364e006d1ceb801526cda34cc1831e5996e6f3ec18dc102e
+SIZE (opensmtpd-201212222206p1.tar.gz) = 416789
diff --git a/mail/opensmtpd/files/patch-smtpd_Makefile.am b/mail/opensmtpd/files/patch-smtpd_Makefile.am
new file mode 100644
index 000000000000..7577aaf0874e
--- /dev/null
+++ b/mail/opensmtpd/files/patch-smtpd_Makefile.am
@@ -0,0 +1,42 @@
+
+$FreeBSD$
+
+--- smtpd/Makefile.am.orig
++++ smtpd/Makefile.am
+@@ -97,7 +97,7 @@
+ CFLAGS+= -D_GNU_SOURCE
+ CPPFLAGS= -I$(srcdir) @CPPFLAGS@ $(PATHS) @DEFS@
+
+-PATHS= -DSMTPD_CONFDIR=\"$(sysconfdir)\" \
++PATHS= -DSMTPD_CONFDIR=\"$(sysconfdir)/mail\" \
+ -DPATH_SMTPCTL=\"$(sbindir)/smtpctl\" \
+ -DPATH_MAILLOCAL=\"$(libexecdir)/mail.local\"
+
+@@ -116,7 +116,7 @@
+ ../contrib/lib/libc/asr/asr_private.h \
+ $(CONFIGFILES_IN) $(MANPAGES_IN)
+
+-PATHSUBS= -e 's|/etc/mail/|$(sysconfdir)/|g' \
++PATHSUBS= -e 's|/etc/mail/|$(sysconfdir)/mail/|g' \
+ -e 's|/usr/libexec|$(libexecdir)|g' \
+ -e 's|/var/run/smtpd.sock|$(sockdir)/smtpd.sock|g'
+
+@@ -142,16 +142,12 @@
+ # smtpd.conf
+ # newaliases makemap
+ install-exec-hook: $(CONFIGFILES) $(MANPAGES)
+- $(MKDIR_P) $(DESTDIR)$(sysconfdir)
++ $(MKDIR_P) $(DESTDIR)$(sysconfdir)/mail
+ $(MKDIR_P) $(DESTDIR)$(bindir)
+ $(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)5
+ $(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)8
+
+- @if [ ! -f $(DESTDIR)$(sysconfdir)/smtpd.conf ]; then \
+- $(INSTALL) -m 644 smtpd.conf.out $(DESTDIR)$(sysconfdir)/smtpd.conf; \
+- else \
+- echo "$(DESTDIR)$(sysconfdir)/smtpd.conf already exists, install will not overwrite"; \
+- fi
++ $(INSTALL) -m 644 smtpd.conf.out $(DESTDIR)$(sysconfdir)/mail/smtpd.conf.sample
+
+ ln -f $(DESTDIR)$(sbindir)/smtpctl$(EXEEXT) \
+ $(DESTDIR)$(bindir)/mailq$(EXEEXT);
diff --git a/mail/opensmtpd/files/patch-src_Makefile.am b/mail/opensmtpd/files/patch-src_Makefile.am
deleted file mode 100644
index f11e966cb380..000000000000
--- a/mail/opensmtpd/files/patch-src_Makefile.am
+++ /dev/null
@@ -1,19 +0,0 @@
-
-$FreeBSD$
-
---- src/Makefile.am.orig
-+++ src/Makefile.am
-@@ -107,10 +107,10 @@
- $(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)5
- $(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)8
-
-- @if [ ! -f $(DESTDIR)$(sysconfdir)/mail/smtpd.conf ]; then \
-- $(INSTALL) -m 644 smtpd.conf.out $(DESTDIR)$(sysconfdir)/mail/smtpd.conf; \
-+ @if [ ! -f $(DESTDIR)$(sysconfdir)/mail/smtpd.conf.sample ]; then \
-+ $(INSTALL) -m 644 smtpd.conf.out $(DESTDIR)$(sysconfdir)/mail/smtpd.conf.sample; \
- else \
-- echo "$(DESTDIR)$(sysconfdir)/mail/smtpd.conf already exists, install will not overwrite"; \
-+ echo "$(DESTDIR)$(sysconfdir)/mail/smtpd.conf.sample already exists, install will not overwrite"; \
- fi
-
- @if [ ! -f $(DESTDIR)$(bindir)/mailq$(EXEEXT) ]; then \
diff --git a/mail/opensmtpd/files/pkg-deinstall.in b/mail/opensmtpd/files/pkg-deinstall.in
index b25dc20267aa..3c939c99eee1 100644
--- a/mail/opensmtpd/files/pkg-deinstall.in
+++ b/mail/opensmtpd/files/pkg-deinstall.in
@@ -7,7 +7,7 @@ PREFIX=$(echo %%PREFIX%% |sed -e 's,/,\\/,g')
if [ "$TARGET" = POST-DEINSTALL ]; then
sed -e '/[[:space:]]'$PREFIX'\/sbin\/smtpctl/d' \
- -e '/[[:space:]]'$PREFIX'\/libexec\/opensmtpd-portable\/makemap/d' \
+ -e '/[[:space:]]'$PREFIX'\/libexec\/opensmtpd\/makemap/d' \
-e 's/^### smtpd: //g' -i '' /etc/mail/mailer.conf
fi
diff --git a/mail/opensmtpd/files/pkg-install.in b/mail/opensmtpd/files/pkg-install.in
index c54f17a07499..899ad234742e 100644
--- a/mail/opensmtpd/files/pkg-install.in
+++ b/mail/opensmtpd/files/pkg-install.in
@@ -9,8 +9,8 @@ if [ "$TARGET" = POST-INSTALL ]; then
sendmail %%PREFIX%%/sbin/smtpctl
send-mail %%PREFIX%%/sbin/smtpctl
mailq %%PREFIX%%/sbin/smtpctl
-makemap %%PREFIX%%/libexec/opensmtpd-portable/makemap
-newaliases %%PREFIX%%/libexec/opensmtpd-portable/makemap
+makemap %%PREFIX%%/libexec/opensmtpd/makemap
+newaliases %%PREFIX%%/libexec/opensmtpd/makemap
EOF
fi
diff --git a/mail/opensmtpd/pkg-plist b/mail/opensmtpd/pkg-plist
index 01ab9a8d124d..abd7a14e4b34 100644
--- a/mail/opensmtpd/pkg-plist
+++ b/mail/opensmtpd/pkg-plist
@@ -1,10 +1,11 @@
bin/mailq
bin/newaliases
+bin/smtpscript
etc/mail/smtpd.conf.sample
libexec/mail.local
-libexec/opensmtpd-portable/makemap
+libexec/opensmtpd/makemap
sbin/makemap
sbin/smtpctl
sbin/smtpd
-@dirrm libexec/opensmtpd-portable
+@dirrm libexec/opensmtpd
@dirrmtry etc/mail